aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-String-Trim
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2015-08-23 22:27:06 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2015-08-23 22:27:06 +0000
commitfe6509c88911db5da9cfeb9f3114250fe6736e70 (patch)
treee513c8936b18efb7c3e22f069368fb7e9fe61f21 /textproc/p5-String-Trim
parent10590a85c8f4cb7ef06c2234442ec1351929c124 (diff)
downloadports-fe6509c88911db5da9cfeb9f3114250fe6736e70.tar.gz
ports-fe6509c88911db5da9cfeb9f3114250fe6736e70.zip
String::Trim trims whitespace off your strings. chomp trims only $/
(typically, that's newline), but trim will trim all leading and trailing whitespace. WWW: http://search.cpan.org/dist/String-Trim/
Notes
Notes: svn path=/head/; revision=395138
Diffstat (limited to 'textproc/p5-String-Trim')
-rw-r--r--textproc/p5-String-Trim/Makefile19
-rw-r--r--textproc/p5-String-Trim/distinfo2
-rw-r--r--textproc/p5-String-Trim/pkg-descr5
-rw-r--r--textproc/p5-String-Trim/pkg-plist2
4 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-String-Trim/Makefile b/textproc/p5-String-Trim/Makefile
new file mode 100644
index 000000000000..7627d02157cf
--- /dev/null
+++ b/textproc/p5-String-Trim/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= String-Trim
+PORTVERSION= 0.005
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to trim whitespace from your strings
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+NO_ARCH= YES
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-String-Trim/distinfo b/textproc/p5-String-Trim/distinfo
new file mode 100644
index 000000000000..064f2567f987
--- /dev/null
+++ b/textproc/p5-String-Trim/distinfo
@@ -0,0 +1,2 @@
+SHA256 (String-Trim-0.005.tar.gz) = b169e20b02476f308fec0425c75077fd6a851f578b4ea3703e6220659d73b31f
+SIZE (String-Trim-0.005.tar.gz) = 13956
diff --git a/textproc/p5-String-Trim/pkg-descr b/textproc/p5-String-Trim/pkg-descr
new file mode 100644
index 000000000000..d2194f875320
--- /dev/null
+++ b/textproc/p5-String-Trim/pkg-descr
@@ -0,0 +1,5 @@
+String::Trim trims whitespace off your strings. chomp trims only $/
+(typically, that's newline), but trim will trim all leading and
+trailing whitespace.
+
+WWW: http://search.cpan.org/dist/String-Trim/
diff --git a/textproc/p5-String-Trim/pkg-plist b/textproc/p5-String-Trim/pkg-plist
new file mode 100644
index 000000000000..3d7a60713818
--- /dev/null
+++ b/textproc/p5-String-Trim/pkg-plist
@@ -0,0 +1,2 @@
+%%PERL5_MAN3%%/String::Trim.3.gz
+%%SITE_PERL%%/String/Trim.pm