aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-QRCode
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2011-02-16 05:03:28 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2011-02-16 05:03:28 +0000
commitd030b77dbab4d93726b493d3f1219de2e72e5a0a (patch)
treebb9cc4b6f40da461a1a53b1f0f09d7a2f17de047 /textproc/p5-Text-QRCode
parent55698510cf5f9de37484b9054db09126865e8795 (diff)
downloadports-d030b77dbab4d93726b493d3f1219de2e72e5a0a.tar.gz
ports-d030b77dbab4d93726b493d3f1219de2e72e5a0a.zip
Add textproc/Text-QRCode, gnerate text based QR Code.
This module allows you to generate QR Code using ' ' and '*'. WWW: http://search.cpan.org/dist/Text-QRCode/
Notes
Notes: svn path=/head/; revision=269231
Diffstat (limited to 'textproc/p5-Text-QRCode')
-rw-r--r--textproc/p5-Text-QRCode/Makefile25
-rw-r--r--textproc/p5-Text-QRCode/distinfo2
-rw-r--r--textproc/p5-Text-QRCode/pkg-descr4
-rw-r--r--textproc/p5-Text-QRCode/pkg-plist7
4 files changed, 38 insertions, 0 deletions
diff --git a/textproc/p5-Text-QRCode/Makefile b/textproc/p5-Text-QRCode/Makefile
new file mode 100644
index 000000000000..3469c4eb1206
--- /dev/null
+++ b/textproc/p5-Text-QRCode/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Text-QRCode
+# Date created: 2011/02/14
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-QRCode
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Generate text based QR Code
+
+BUILD_DEPENDS= libqrencode>=2.0.0:${PORTSDIR}/graphics/libqrencode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+
+MAN3= Text::QRCode.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-QRCode/distinfo b/textproc/p5-Text-QRCode/distinfo
new file mode 100644
index 000000000000..78b3d2954350
--- /dev/null
+++ b/textproc/p5-Text-QRCode/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Text-QRCode-0.01.tar.gz) = 925b9f8f03cce5d3818e4bf459e01b701a06ff1c8760e42ada4bf8f43d238a9d
+SIZE (Text-QRCode-0.01.tar.gz) = 51303
diff --git a/textproc/p5-Text-QRCode/pkg-descr b/textproc/p5-Text-QRCode/pkg-descr
new file mode 100644
index 000000000000..a971d87951ac
--- /dev/null
+++ b/textproc/p5-Text-QRCode/pkg-descr
@@ -0,0 +1,4 @@
+This module allows you to generate QR Code using ' ' and '*'. This module
+use libqrencode '2.0.0' and above.
+
+WWW: http://search.cpan.org/dist/Text-QRCode/
diff --git a/textproc/p5-Text-QRCode/pkg-plist b/textproc/p5-Text-QRCode/pkg-plist
new file mode 100644
index 000000000000..7064a8b57c92
--- /dev/null
+++ b/textproc/p5-Text-QRCode/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/QRCode/QRCode.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/QRCode/QRCode.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/QRCode/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/Text/QRCode.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/QRCode
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Text