aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Quote/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-08-02 01:20:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-08-02 01:20:01 +0000
commit1eb712f0b320e0ecddcdb3ba60a82c9b4555951a (patch)
tree0677e950f98339399a388fcf66904b5679e7987a /textproc/p5-Text-Quote/Makefile
parentd32a34a2008942e60a87666d92124422c581dda7 (diff)
downloadports-1eb712f0b320e0ecddcdb3ba60a82c9b4555951a.tar.gz
ports-1eb712f0b320e0ecddcdb3ba60a82c9b4555951a.zip
add p5-Text-Quote 0.3
Quotes strings as required for perl to eval them back correctly PR: 101018
Notes
Notes: svn path=/head/; revision=169418
Diffstat (limited to 'textproc/p5-Text-Quote/Makefile')
-rw-r--r--textproc/p5-Text-Quote/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/p5-Text-Quote/Makefile b/textproc/p5-Text-Quote/Makefile
new file mode 100644
index 000000000000..e38066ae57af
--- /dev/null
+++ b/textproc/p5-Text-Quote/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: Text::Quote
+# Date created: Jul 29, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Quote
+PORTVERSION= 0.3
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Quotes strings as required for perl to eval them back correctly
+
+BUILD_DEPENDS= p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-Carp-Assert>=0:${PORTSDIR}/devel/p5-Carp-Assert
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Quote.3
+
+.include <bsd.port.mk>