aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Trac
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 13:50:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 13:50:26 +0000
commit6a9f73102a45b125c1f356af31b2fd8ec20a014c (patch)
treeb08f5af2facac26ed8681d9a3e0d4f06134930f9 /textproc/p5-Text-Trac
parent0350c7361c215e53765ba835851134de65c038bd (diff)
downloadports-6a9f73102a45b125c1f356af31b2fd8ec20a014c.tar.gz
ports-6a9f73102a45b125c1f356af31b2fd8ec20a014c.zip
Add p5-Text-Trac 0.03, perl extension for formatting text with Trac Wiki
Style. PR: ports/100528 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=168236
Diffstat (limited to 'textproc/p5-Text-Trac')
-rw-r--r--textproc/p5-Text-Trac/Makefile32
-rw-r--r--textproc/p5-Text-Trac/distinfo3
-rw-r--r--textproc/p5-Text-Trac/pkg-descr4
-rw-r--r--textproc/p5-Text-Trac/pkg-plist31
4 files changed, 70 insertions, 0 deletions
diff --git a/textproc/p5-Text-Trac/Makefile b/textproc/p5-Text-Trac/Makefile
new file mode 100644
index 000000000000..29f04189a279
--- /dev/null
+++ b/textproc/p5-Text-Trac/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Text-Trac
+# Date created: 2006-07-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Trac
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for formatting text with Trac Wiki Style
+
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Trac.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500602
+RUN_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-Trac/distinfo b/textproc/p5-Text-Trac/distinfo
new file mode 100644
index 000000000000..da726dc8e300
--- /dev/null
+++ b/textproc/p5-Text-Trac/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-Trac-0.03.tar.gz) = 254fb347a711d7beeda3b252279bab62
+SHA256 (Text-Trac-0.03.tar.gz) = 9927eb0f47f53bcf4d8ce51377544c75f0cb7de9415de478e3877d6844d07163
+SIZE (Text-Trac-0.03.tar.gz) = 7810
diff --git a/textproc/p5-Text-Trac/pkg-descr b/textproc/p5-Text-Trac/pkg-descr
new file mode 100644
index 000000000000..fc0f93b26ec2
--- /dev/null
+++ b/textproc/p5-Text-Trac/pkg-descr
@@ -0,0 +1,4 @@
+Text::Trac parses text with Trac WikiFormatting and convert it to
+html format.
+
+WWW: http://search.cpan.org/dist/Text-Trac/
diff --git a/textproc/p5-Text-Trac/pkg-plist b/textproc/p5-Text-Trac/pkg-plist
new file mode 100644
index 000000000000..4aff7a3e825c
--- /dev/null
+++ b/textproc/p5-Text-Trac/pkg-plist
@@ -0,0 +1,31 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Trac/.packlist
+%%SITE_PERL%%/Text/Trac.pm
+%%SITE_PERL%%/Text/Trac/AutoLinkHttpNode.pm
+%%SITE_PERL%%/Text/Trac/BlockNode.pm
+%%SITE_PERL%%/Text/Trac/BlockquoteNode.pm
+%%SITE_PERL%%/Text/Trac/BoldItalicNode.pm
+%%SITE_PERL%%/Text/Trac/BoldNode.pm
+%%SITE_PERL%%/Text/Trac/BrNode.pm
+%%SITE_PERL%%/Text/Trac/Context.pm
+%%SITE_PERL%%/Text/Trac/DlNode.pm
+%%SITE_PERL%%/Text/Trac/HeadingNode.pm
+%%SITE_PERL%%/Text/Trac/HrNode.pm
+%%SITE_PERL%%/Text/Trac/InlineNode.pm
+%%SITE_PERL%%/Text/Trac/ItalicNode.pm
+%%SITE_PERL%%/Text/Trac/MonospaceNode.pm
+%%SITE_PERL%%/Text/Trac/Node.pm
+%%SITE_PERL%%/Text/Trac/OlNode.pm
+%%SITE_PERL%%/Text/Trac/PNode.pm
+%%SITE_PERL%%/Text/Trac/PreNode.pm
+%%SITE_PERL%%/Text/Trac/StrikeNode.pm
+%%SITE_PERL%%/Text/Trac/SubNode.pm
+%%SITE_PERL%%/Text/Trac/SupNode.pm
+%%SITE_PERL%%/Text/Trac/TableNode.pm
+%%SITE_PERL%%/Text/Trac/Text.pm
+%%SITE_PERL%%/Text/Trac/UlNode.pm
+%%SITE_PERL%%/Text/Trac/UnderlineNode.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Trac
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
+@dirrmtry %%SITE_PERL%%/Text/Trac
+@dirrmtry %%SITE_PERL%%/Text