aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Mini/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-15 07:54:56 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-15 07:54:56 +0000
commit9001c210aaa647cf28d398634273edcf4f61b57b (patch)
tree22692aa5a47dc5a9cbfedebfb426313bf2251d89 /textproc/p5-XML-Mini/Makefile
parentdc1b803ac4ade2954c423afcab2fad21c76809a7 (diff)
downloadports-9001c210aaa647cf28d398634273edcf4f61b57b.tar.gz
ports-9001c210aaa647cf28d398634273edcf4f61b57b.zip
Add p5-XML-Mini 1.2.8, perl implementation of the XML::Mini XML
create/parse interface. PR: ports/100265 Submitted by: Vivek Khera <vivek at khera.org>
Notes
Notes: svn path=/head/; revision=167871
Diffstat (limited to 'textproc/p5-XML-Mini/Makefile')
-rw-r--r--textproc/p5-XML-Mini/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-XML-Mini/Makefile b/textproc/p5-XML-Mini/Makefile
new file mode 100644
index 000000000000..a9d56509279d
--- /dev/null
+++ b/textproc/p5-XML-Mini/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/p5-XML-Mini
+# Date created: 12-JUL-2006
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Mini
+PORTVERSION= 1.2.8
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= Perl implementation of the XML::Mini XML create/parse interface
+
+PERL_CONFIGURE= yes
+
+RUN_DEPENDS+= p5-Text-Balanced>=0.0:${PORTSDIR}/textproc/p5-Text-Balanced
+
+MAN3= XML::Mini.3 XML::Mini::Document.3 XML::Mini::Element.3 \
+ XML::Mini::Element::CData.3 XML::Mini::Element::Comment.3 \
+ XML::Mini::Element::DocType.3 XML::Mini::Element::Entity.3 \
+ XML::Mini::Element::Header.3 XML::Mini::Node.3 \
+ XML::Mini::TreeComponent.3
+
+.include <bsd.port.mk>