aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-RSS-LibXML/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-01-16 02:39:06 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-01-16 02:39:06 +0000
commit2181e34108da4acd75883dfc56775f98412c5c3a (patch)
treeea5691e705b553741b785647ea993e1023b6b5ab /textproc/p5-XML-RSS-LibXML/Makefile
parent3b589924d6b210c81b67caa9554c3a5f6abb69c5 (diff)
downloadports-2181e34108da4acd75883dfc56775f98412c5c3a.tar.gz
ports-2181e34108da4acd75883dfc56775f98412c5c3a.zip
Add p5-XML-RSS-LibXML 0.15, XML::RSS with XML::LibXML.
PR: ports/91819 Submitted by: Gea-Suan Lin <gslin@gslin.org>
Notes
Notes: svn path=/head/; revision=153612
Diffstat (limited to 'textproc/p5-XML-RSS-LibXML/Makefile')
-rw-r--r--textproc/p5-XML-RSS-LibXML/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/textproc/p5-XML-RSS-LibXML/Makefile b/textproc/p5-XML-RSS-LibXML/Makefile
new file mode 100644
index 000000000000..79044ecbcdf7
--- /dev/null
+++ b/textproc/p5-XML-RSS-LibXML/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-XML-RSS-LibXML
+# Date created: 2006-01-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-RSS-LibXML
+PORTVERSION= 0.15
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= XML::RSS with XML::LibXML
+
+BUILD_DEPENDS= ${SITE_PERL}/mach/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/mach/XML/LibXML/XPathContext.pm:${PORTSDIR}/textproc/p5-XML-LibXML-XPathContext
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::RSS::LibXML.3 \
+ XML::RSS::LibXML::Generator.3 \
+ XML::RSS::LibXML::MagicElement.3 \
+ XML::RSS::LibXML::Parser.3 \
+ XML::RSS::LibXML::V10.3 \
+ XML::RSS::LibXML::Format.3 \
+ XML::RSS::LibXML::V09.3 \
+ XML::RSS::LibXML::V20.3
+
+.include <bsd.port.pre.mk>
+
+.if (${PERL_LEVEL} < 500601)
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>