aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-SimpleObject
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2001-11-16 01:41:19 +0000
committerSteve Price <steve@FreeBSD.org>2001-11-16 01:41:19 +0000
commitdabea2158b7747ae6c55df5ca4142eebcc594ede (patch)
tree098d2a0a4b4817d4e04ccd457daac95dbaffa967 /textproc/p5-XML-SimpleObject
parente3958cc5c2ddab02aec13397e084de3be342f909 (diff)
downloadports-dabea2158b7747ae6c55df5ca4142eebcc594ede.tar.gz
ports-dabea2158b7747ae6c55df5ca4142eebcc594ede.zip
Add XML-SimpleObject version 0.41. A simple API for accessing the
structure of an XML document.
Notes
Notes: svn path=/head/; revision=50097
Diffstat (limited to 'textproc/p5-XML-SimpleObject')
-rw-r--r--textproc/p5-XML-SimpleObject/Makefile25
-rw-r--r--textproc/p5-XML-SimpleObject/distinfo1
-rw-r--r--textproc/p5-XML-SimpleObject/pkg-comment1
-rw-r--r--textproc/p5-XML-SimpleObject/pkg-descr5
-rw-r--r--textproc/p5-XML-SimpleObject/pkg-plist6
5 files changed, 38 insertions, 0 deletions
diff --git a/textproc/p5-XML-SimpleObject/Makefile b/textproc/p5-XML-SimpleObject/Makefile
new file mode 100644
index 000000000000..6f6812cd5f4b
--- /dev/null
+++ b/textproc/p5-XML-SimpleObject/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-XML-SimpleObject
+# Date created: 14 November 2001
+# Whom: steve
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-SimpleObject
+PORTVERSION= 0.41
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+PERL_CONFIGURE= YES
+
+MAN3= XML::SimpleObject.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-SimpleObject/distinfo b/textproc/p5-XML-SimpleObject/distinfo
new file mode 100644
index 000000000000..cac888a4fd3e
--- /dev/null
+++ b/textproc/p5-XML-SimpleObject/distinfo
@@ -0,0 +1 @@
+MD5 (XML-SimpleObject0.41.tar.gz) = 81a4c7b8d102e8bcb1e06049783cb5c4
diff --git a/textproc/p5-XML-SimpleObject/pkg-comment b/textproc/p5-XML-SimpleObject/pkg-comment
new file mode 100644
index 000000000000..57d5cd2295f0
--- /dev/null
+++ b/textproc/p5-XML-SimpleObject/pkg-comment
@@ -0,0 +1 @@
+API for accessing the structure of an XML document
diff --git a/textproc/p5-XML-SimpleObject/pkg-descr b/textproc/p5-XML-SimpleObject/pkg-descr
new file mode 100644
index 000000000000..f32e20d96463
--- /dev/null
+++ b/textproc/p5-XML-SimpleObject/pkg-descr
@@ -0,0 +1,5 @@
+This is a small and simple package that takes the output of XML::Parser as
+a tree, and gives simple methods for accessing the structure of an XML
+document. It is very lightweight, but provides the simplest access to an XML
+document possible. It does not subclass XML::Parser; rather, it is meant to
+serve purely as an object struct for an outgoing tree.
diff --git a/textproc/p5-XML-SimpleObject/pkg-plist b/textproc/p5-XML-SimpleObject/pkg-plist
new file mode 100644
index 000000000000..663ad20dc1ef
--- /dev/null
+++ b/textproc/p5-XML-SimpleObject/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SimpleObject/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/SimpleObject.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/ex.pl
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SimpleObject
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true