aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-asv
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-04 16:04:59 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-04 16:04:59 +0000
commit63713f51b5823ababa2badcb27167ca75d522808 (patch)
tree1f92d3cd359ccf911f8c63e95be8fb3afbadbe2d /textproc/py-asv
parent11b7174d5d2bbfc88eed2ae9b33272ef4197eb31 (diff)
downloadports-63713f51b5823ababa2badcb27167ca75d522808.tar.gz
ports-63713f51b5823ababa2badcb27167ca75d522808.zip
Add py-asv 0.4, an extensible Python module to parse simple text
file formats like CSV. PR: 26349 Submitted by: Johann Visagie <johann@egenetics.com>
Notes
Notes: svn path=/head/; revision=40842
Diffstat (limited to 'textproc/py-asv')
-rw-r--r--textproc/py-asv/Makefile42
-rw-r--r--textproc/py-asv/distinfo1
-rw-r--r--textproc/py-asv/pkg-comment1
-rw-r--r--textproc/py-asv/pkg-descr15
-rw-r--r--textproc/py-asv/pkg-plist13
5 files changed, 72 insertions, 0 deletions
diff --git a/textproc/py-asv/Makefile b/textproc/py-asv/Makefile
new file mode 100644
index 000000000000..54344aed8e22
--- /dev/null
+++ b/textproc/py-asv/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: py-asv
+# Date created: 4 April 2001
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asv
+PORTVERSION= 0.4
+CATEGORIES= textproc python
+MASTER_SITES= http://tratt.net/~laurie/python/asv/releases/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= johann@egenetics.com
+
+PYTHON_VERSION= python2.0
+
+ASV_BASEDIR= ${PREFIX}/lib/${PYTHON_VERSION}/site-packages
+ASV_DOCDIR= ${PREFIX}/share/doc/py-asv
+ASV_EGDIR= ${PREFIX}/share/examples/py-asv
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @printf "#!/bin/sh\n${PYTHON_CMD} ${ASV_BASEDIR}/ASV.py\n" \
+ > ${WRKDIR}/asv.sh
+ @${INSTALL_SCRIPT} ${WRKDIR}/asv.sh ${PREFIX}/bin/asv
+ @${INSTALL_DATA} ${WRKSRC}/ASV.* ${ASV_BASEDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${ASV_DOCDIR}
+.for docfile in INSTALL README THANKS
+ @${INSTALL_DATA} ${WRKSRC}/${docfile} ${ASV_DOCDIR}
+.endfor
+ @${MKDIR} ${ASV_EGDIR}
+.for egfile in asv_example.* example_data.csv
+ @${INSTALL_DATA} ${WRKSRC}/${egfile} ${ASV_EGDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/py-asv/distinfo b/textproc/py-asv/distinfo
new file mode 100644
index 000000000000..eb4c7189056c
--- /dev/null
+++ b/textproc/py-asv/distinfo
@@ -0,0 +1 @@
+MD5 (asv-0.4.tar.gz) = 420c54e3be366edb913aa2df3328cc4e
diff --git a/textproc/py-asv/pkg-comment b/textproc/py-asv/pkg-comment
new file mode 100644
index 000000000000..bbbf1274745d
--- /dev/null
+++ b/textproc/py-asv/pkg-comment
@@ -0,0 +1 @@
+An extensible Python module to parse simple text file formats like CSV
diff --git a/textproc/py-asv/pkg-descr b/textproc/py-asv/pkg-descr
new file mode 100644
index 000000000000..c41b02249367
--- /dev/null
+++ b/textproc/py-asv/pkg-descr
@@ -0,0 +1,15 @@
+ASV is a popular Python module to parse or write simple text file formats
+such as comma-separated values (CSV), tab-separated values (TSV) and
+colon-separated values. It can easily be extended to cope with other
+related file formats.
+
+This port installs both a Python module ("ASV"), and an executable
+command-line script ("asv").
+
+This release of ASV requires Python 2.0 or later, and is still to be regarded
+as a beta version.
+
+Author: Laurence Tratt <laurie@tratt.net>
+WWW: http://tratt.net/~laurie/python/asv/
+
+-- Johann Visagie <johann@egenetics.com>
diff --git a/textproc/py-asv/pkg-plist b/textproc/py-asv/pkg-plist
new file mode 100644
index 000000000000..0b07a22d949f
--- /dev/null
+++ b/textproc/py-asv/pkg-plist
@@ -0,0 +1,13 @@
+bin/asv
+lib/%%PYTHON_VERSION%%/site-packages/ASV.py
+lib/%%PYTHON_VERSION%%/site-packages/ASV.pyc
+lib/%%PYTHON_VERSION%%/site-packages/ASV.pyo
+%%PORTDOCS%%share/doc/py-asv/INSTALL
+%%PORTDOCS%%share/doc/py-asv/README
+%%PORTDOCS%%share/doc/py-asv/THANKS
+%%PORTDOCS%%share/examples/py-asv/asv_example.py
+%%PORTDOCS%%share/examples/py-asv/asv_example.pyc
+%%PORTDOCS%%share/examples/py-asv/asv_example.pyo
+%%PORTDOCS%%share/examples/py-asv/example_data.csv
+%%PORTDOCS%%@dirrm share/examples/py-asv
+%%PORTDOCS%%@dirrm share/doc/py-asv