aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-custom_inherit
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2019-01-08 03:15:41 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2019-01-08 03:15:41 +0000
commit19d9ae132f428bad807b8fb4ca79df90be41c4dd (patch)
tree7c42aed6835c5dad9e7032a419c4271a32627490 /textproc/py-custom_inherit
parent96ae020e6abd314bd7008be8de124515c9f5f214 (diff)
downloadports-19d9ae132f428bad807b8fb4ca79df90be41c4dd.tar.gz
ports-19d9ae132f428bad807b8fb4ca79df90be41c4dd.zip
The Python package custom_inherit provides convenient, light-weight tools for
inheriting docstrings in customizeable ways. Features: * Metaclass that instructs children to inherit docstrings for their attributes from their parents, using custom docstring inheritance styles. * Decorator that merges a string/docstring with the docstring of the decorated object using custom styles. * Built-in docstring merging styles for popular docstring specifications: * NumPy docstring specification * Napoleon docstring specifications (for both Google and NumPy styles) * Merging based on reST sections * Simple inheritance from a parent, if the docstring is not overwritten * Simple interface for using your own docstring inheritance style. WWW: https://github.com/meowklaski/custom_inherit
Notes
Notes: svn path=/head/; revision=489639
Diffstat (limited to 'textproc/py-custom_inherit')
-rw-r--r--textproc/py-custom_inherit/Makefile18
-rw-r--r--textproc/py-custom_inherit/distinfo3
-rw-r--r--textproc/py-custom_inherit/pkg-descr16
3 files changed, 37 insertions, 0 deletions
diff --git a/textproc/py-custom_inherit/Makefile b/textproc/py-custom_inherit/Makefile
new file mode 100644
index 000000000000..e8fa92ed3271
--- /dev/null
+++ b/textproc/py-custom_inherit/Makefile
@@ -0,0 +1,18 @@
+# Created by: skreuzer
+# $FreeBSD$
+
+PORTNAME= custom_inherit
+PORTVERSION= 2.2.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Package providing tools for inheriting docstrings in customizable ways
+
+LICENSE= MIT
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/textproc/py-custom_inherit/distinfo b/textproc/py-custom_inherit/distinfo
new file mode 100644
index 000000000000..2bef84152aa9
--- /dev/null
+++ b/textproc/py-custom_inherit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1546916988
+SHA256 (custom_inherit-2.2.0.tar.gz) = 3892ec53aaffae98d757867c3d1dd5f02200db0e1f888ab601223d72262996f8
+SIZE (custom_inherit-2.2.0.tar.gz) = 11257
diff --git a/textproc/py-custom_inherit/pkg-descr b/textproc/py-custom_inherit/pkg-descr
new file mode 100644
index 000000000000..224a77633888
--- /dev/null
+++ b/textproc/py-custom_inherit/pkg-descr
@@ -0,0 +1,16 @@
+The Python package custom_inherit provides convenient, light-weight tools for
+inheriting docstrings in customizeable ways.
+
+Features:
+ * Metaclass that instructs children to inherit docstrings for their
+ attributes from their parents, using custom docstring inheritance styles.
+ * Decorator that merges a string/docstring with the docstring of the decorated
+ object using custom styles.
+ * Built-in docstring merging styles for popular docstring specifications:
+ * NumPy docstring specification
+ * Napoleon docstring specifications (for both Google and NumPy styles)
+ * Merging based on reST sections
+ * Simple inheritance from a parent, if the docstring is not overwritten
+ * Simple interface for using your own docstring inheritance style.
+
+WWW: https://github.com/meowklaski/custom_inherit