aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-libxml2/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-05-13 20:32:00 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-05-13 20:32:00 +0000
commit607eebc44b493d9a5325cbbc6e4f310408e9fc37 (patch)
treeaf5d54de867e1999ce3c9a27fc7b84393b692520 /textproc/py-libxml2/Makefile
parent8c30535693f76b75884fe7a3f37980252601f194 (diff)
downloadports-607eebc44b493d9a5325cbbc6e4f310408e9fc37.tar.gz
ports-607eebc44b493d9a5325cbbc6e4f310408e9fc37.zip
Update to libxml2 2.9.1 [1]
This version fixes CVE-2013-2877. Add upstream patch for CVE-2014-0191. CVE's Reported by: Akinori MUSHA <knu@iDaemons.org> Obtained from: GNOME dev repo [1], libxml2 upstream [2] MFH: 2014Q2
Notes
Notes: svn path=/head/; revision=353989
Diffstat (limited to 'textproc/py-libxml2/Makefile')
-rw-r--r--textproc/py-libxml2/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/textproc/py-libxml2/Makefile b/textproc/py-libxml2/Makefile
index 2022fac33493..bd58792b2d13 100644
--- a/textproc/py-libxml2/Makefile
+++ b/textproc/py-libxml2/Makefile
@@ -1,7 +1,8 @@
# Created by: Alexander Nedotsukov <bland@FreeBSD.org>
# $FreeBSD$
+# $MCom: ports/trunk/textproc/py-libxml2/Makefile 18999 2014-02-04 18:55:27Z kwm $
-PORTREVISION= 2
+PORTREVISION= 0
CATEGORIES= textproc gnome python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,9 @@ PLIST= ${.CURDIR}/pkg-plist
USE_GNOME+= libxml2
USE_PYTHON= 2
-USES= iconv
+USE_PYDISTUTILS=yes
+PYDISTUTILS_EGGINFO= libxml2_python-${PORTVERSION}-py${PYTHON_VER}.egg-info
+
CPPFLAGS+= `${PYTHON_VERSION}-config --cflags`
LDFLAGS+= -L${LOCALBASE}/lib `${PYTHON_VERSION}-config --libs`
CONFIGURE_ARGS= --with-iconv=${ICONV_PREFIX} \
@@ -28,8 +31,6 @@ DOCSDIR= ${PREFIX}/share/doc/py-libxml2
EXAMPLESDIR= ${PREFIX}/share/examples/py-libxml2
post-install:
- @cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
- @cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/libxml2mod.so
.include "${MASTERDIR}/Makefile"