aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-libxml2
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2022-04-10 18:43:18 +0000
committerCharlie Li <vishwin@FreeBSD.org>2022-04-10 19:11:40 +0000
commit57dd5abd6018e0bec9e5b7c406268b349da4b7e7 (patch)
tree5adad35732a065770aeb5461c9335758f066c1a5 /textproc/py-libxml2
parent63ffb1e094a6281301acd644381ad8000246cce4 (diff)
downloadports-57dd5abd6018e0bec9e5b7c406268b349da4b7e7.tar.gz
ports-57dd5abd6018e0bec9e5b7c406268b349da4b7e7.zip
textproc/{,py-}libxml2: switch back to autotools
See notes in Makefile and linked PRs. While here, disable the ICU option by default. CFLAGS for libicu are passed to libxml2's consumers when the option is enabled. As icu's API is not stable between versions, PORTREVISION bumps can get missed. Additionally, properly exclude all OPTIONS from py-libxml2 and prevent do-configure from unnecessarily running. Co-authored-by: diizzy PR: 262853, 262940, 262877 Approved by: fluffy (mentor)
Diffstat (limited to 'textproc/py-libxml2')
-rw-r--r--textproc/py-libxml2/Makefile38
1 files changed, 13 insertions, 25 deletions
diff --git a/textproc/py-libxml2/Makefile b/textproc/py-libxml2/Makefile
index fa8aaffa0b7e..9d94c8735821 100644
--- a/textproc/py-libxml2/Makefile
+++ b/textproc/py-libxml2/Makefile
@@ -1,45 +1,33 @@
# Created by: Alexander Nedotsukov <bland@FreeBSD.org>
-PORTREVISION= 2
+PORTREVISION= 4
CATEGORIES= textproc gnome python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
COMMENT= Python interface for XML parser library for GNOME
MASTERDIR= ${.CURDIR}/../libxml2
-USES+= gnome python shebangfix
+USES+= gettext-runtime gnome python shebangfix
USE_GNOME= libxml2
-USE_PYTHON= flavors
+USE_PYTHON= autoplist distutils
SHEBANG_FILES= *.py doc/*.py python/*.py python/tests/*.py
-# Help CMake determine the correct version of Python if
-# multiple versions are installed
-CMAKE_ARGS= -DPython_EXECUTABLE=${PYTHON_CMD}
-
-OPTIONS_SLAVE= ${OPTIONS_DEFINE:NTEST}
+OPTIONS_EXCLUDE= ${OPTIONS_DEFINE}
# Tell master port we're a slave port
LIBXML2_SLAVE= python
# Grab pkg-descr from slave port
DESCR= ${.CURDIR}/pkg-descr
+
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
# Don't append pkg-plist from master port
PLIST=
-PLIST_FILES= ${PYTHON_SITELIBDIR}/__pycache__/drv_libxml2.cpython-${PYTHON_SUFFIX}.opt-1.pyc \
- ${PYTHON_SITELIBDIR}/__pycache__/drv_libxml2.cpython-${PYTHON_SUFFIX}.pyc \
- ${PYTHON_SITELIBDIR}/__pycache__/libxml2.cpython-${PYTHON_SUFFIX}.opt-1.pyc \
- ${PYTHON_SITELIBDIR}/__pycache__/libxml2.cpython-${PYTHON_SUFFIX}.pyc \
- ${PYTHON_SITELIBDIR}/drv_libxml2.py \
- ${PYTHON_SITELIBDIR}/libxml2.py \
- ${PYTHON_SITELIBDIR}/libxml2mod.so \
- ${PYTHON_SITELIBDIR}/libxml2mod.so.${DISTVERSION}
-
-do-install:
- ${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/python/drv_libxml2.py ${STAGEDIR}${PYTHON_SITELIBDIR}
- ${INSTALL_SCRIPT} ${BUILD_WRKSRC}/libxml2.py ${STAGEDIR}${PYTHON_SITELIBDIR}
- ${PYTHON_CMD} -m compileall -d ${PYTHON_SITELIBDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
- ${PYTHON_CMD} -O -m compileall -d ${PYTHON_SITELIBDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
- ${INSTALL_LIB} ${BUILD_WRKSRC}/libxml2mod.so ${STAGEDIR}${PYTHON_SITELIBDIR}
- ${RLN} ${STAGEDIR}${PYTHON_SITELIBDIR}/libxml2mod.so ${STAGEDIR}${PYTHON_SITELIBDIR}/libxml2mod.so.${DISTVERSION}
+
+DOCSDIR= ${PREFIX}/share/doc/py-libxml2
+EXAMPLESDIR= ${PREFIX}/share/examples/py-libxml2
+
+do-configure:
.include "${MASTERDIR}/Makefile"