aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-ltxml
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2003-01-31 11:14:03 +0000
committerJohann Visagie <wjv@FreeBSD.org>2003-01-31 11:14:03 +0000
commitbde8f43a6680f74cbc14556fef84d34ba379b690 (patch)
treed66a2f041737553267d574eb88ee2948adbd17b0 /textproc/py-ltxml
parent8d9d8afd0853dd646b34ff221171e0b5ff2bd7a1 (diff)
downloadports-bde8f43a6680f74cbc14556fef84d34ba379b690.tar.gz
ports-bde8f43a6680f74cbc14556fef84d34ba379b690.zip
Add py-ltxml 1.3, python bindings to the LT XML toolkit.
Notes
Notes: svn path=/head/; revision=74346
Diffstat (limited to 'textproc/py-ltxml')
-rw-r--r--textproc/py-ltxml/Makefile33
-rw-r--r--textproc/py-ltxml/distinfo1
-rw-r--r--textproc/py-ltxml/files/patch-setup.py14
-rw-r--r--textproc/py-ltxml/pkg-comment1
-rw-r--r--textproc/py-ltxml/pkg-descr5
-rw-r--r--textproc/py-ltxml/pkg-plist11
6 files changed, 65 insertions, 0 deletions
diff --git a/textproc/py-ltxml/Makefile b/textproc/py-ltxml/Makefile
new file mode 100644
index 000000000000..17b705d2a2f4
--- /dev/null
+++ b/textproc/py-ltxml/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-ltxml
+# Date created: 31 January 2002
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ltxml
+PORTVERSION= 1.3
+CATEGORIES= textproc python
+MASTER_SITES= ftp://ftp.cogsci.ed.ac.uk/pub/LTXML/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyLTXML-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/include/ltxml12/lt-safe.h:${PORTSDIR}/textproc/ltxml
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+INSTALLS_SHLIB= yes
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/00README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/py-ltxml/distinfo b/textproc/py-ltxml/distinfo
new file mode 100644
index 000000000000..d73550c492df
--- /dev/null
+++ b/textproc/py-ltxml/distinfo
@@ -0,0 +1 @@
+MD5 (PyLTXML-1.3.tar.gz) = a0f0434c399d2f00e18d1da106dc1707
diff --git a/textproc/py-ltxml/files/patch-setup.py b/textproc/py-ltxml/files/patch-setup.py
new file mode 100644
index 000000000000..68ae8e2026d8
--- /dev/null
+++ b/textproc/py-ltxml/files/patch-setup.py
@@ -0,0 +1,14 @@
+--- setup.py.orig Mon Nov 4 16:50:20 2002
++++ setup.py Fri Jan 31 12:08:31 2003
+@@ -16,10 +16,7 @@
+ self.install_dir = getattr(install_cmd, 'install_lib')
+ return install_data.run(self)
+
+-datafiles=[('PyLTXML/example',
+- ['example/small.xml',
+- 'example/gscore.dtd',
+- 'example/simple.py'])] # only works for bdist and friends
++datafiles=[]
+
+ if sys.platform.find("win32",0,5)==0:
+ incldirs=['C:\Program Files\HCRC LTG\LT XML\include']
diff --git a/textproc/py-ltxml/pkg-comment b/textproc/py-ltxml/pkg-comment
new file mode 100644
index 000000000000..bc0da4f4273f
--- /dev/null
+++ b/textproc/py-ltxml/pkg-comment
@@ -0,0 +1 @@
+Python bindings to the LT XML toolkit
diff --git a/textproc/py-ltxml/pkg-descr b/textproc/py-ltxml/pkg-descr
new file mode 100644
index 000000000000..37b098dfed95
--- /dev/null
+++ b/textproc/py-ltxml/pkg-descr
@@ -0,0 +1,5 @@
+Python bindings for the LT XML API and toolkit.
+
+WWW: http://www.ltg.ed.ac.uk/software/xml/
+
+-- Johann Visagie <wjv@FreeBSD.org>
diff --git a/textproc/py-ltxml/pkg-plist b/textproc/py-ltxml/pkg-plist
new file mode 100644
index 000000000000..63d2c6343ade
--- /dev/null
+++ b/textproc/py-ltxml/pkg-plist
@@ -0,0 +1,11 @@
+%%PORTDOCS%%share/doc/py-ltxml/00README
+%%PORTDOCS%%share/examples/py-ltxml/gscore.dtd
+%%PORTDOCS%%share/examples/py-ltxml/simple.py
+%%PORTDOCS%%share/examples/py-ltxml/small.xml
+lib/python2.2/site-packages/PyLTXML/LTXMLinter.so
+lib/python2.2/site-packages/PyLTXML/__init__.py
+lib/python2.2/site-packages/PyLTXML/__init__.pyc
+lib/python2.2/site-packages/PyLTXML/__init__.pyo
+@dirrm lib/python2.2/site-packages/PyLTXML
+%%PORTDOCS%%@dirrm share/examples/py-ltxml
+%%PORTDOCS%%@dirrm share/doc/py-ltxml