aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-qt5-xml
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-13 21:56:50 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-13 21:56:50 +0000
commit5b3f3dd953448e0ec3ddc609dbf53a005662635d (patch)
treec8ea48f297bee52a8d84f4ec84da2d9fa23078a5 /textproc/py-qt5-xml
parent7f63a1808f185107b013d2e350c33370099f37b3 (diff)
downloadports-5b3f3dd953448e0ec3ddc609dbf53a005662635d.tar.gz
ports-5b3f3dd953448e0ec3ddc609dbf53a005662635d.zip
At very long last land PyQt5 5.5.1 ports.
Add the required bits to Uses/pyqt.mk along with all the PyQt5 ports. Thankfully this commit is mostly adding new ports, as the hard work was already done in r403297 and r403662. Huge kudos to Tobias Berner <tcberner@gmail.com> and, most importantly, Guido Falsi (madpilot@) for their initial work on these ports (see D2910 in Phabricator for an earlier version of the PyQt5 patch set). PR: 204672
Notes
Notes: svn path=/head/; revision=403693
Diffstat (limited to 'textproc/py-qt5-xml')
-rw-r--r--textproc/py-qt5-xml/Makefile26
-rw-r--r--textproc/py-qt5-xml/pkg-descr4
-rw-r--r--textproc/py-qt5-xml/pkg-plist7
3 files changed, 37 insertions, 0 deletions
diff --git a/textproc/py-qt5-xml/Makefile b/textproc/py-qt5-xml/Makefile
new file mode 100644
index 000000000000..1851bf85dc03
--- /dev/null
+++ b/textproc/py-qt5-xml/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= xml
+CATEGORIES= textproc devel python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtXml module
+
+CONFIGURE_ARGS= --enable QtXml
+PYQT_DIST= yes
+
+USES= python pyqt:5
+USE_PYQT= sip_build core_run
+USE_QT5= core xml buildtools_build qmake_build
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtXml API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2-qt5.so:${PORTSDIR}/devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+.include <bsd.port.mk>
diff --git a/textproc/py-qt5-xml/pkg-descr b/textproc/py-qt5-xml/pkg-descr
new file mode 100644
index 000000000000..91d5b1b08121
--- /dev/null
+++ b/textproc/py-qt5-xml/pkg-descr
@@ -0,0 +1,4 @@
+PyQt5 is a set of Python bindings for Digia's Qt5 application framework.
+This package provides the QtXml module.
+
+WWW: http://www.riverbankcomputing.co.uk/software/pyqt/
diff --git a/textproc/py-qt5-xml/pkg-plist b/textproc/py-qt5-xml/pkg-plist
new file mode 100644
index 000000000000..99bc8dd71868
--- /dev/null
+++ b/textproc/py-qt5-xml/pkg-plist
@@ -0,0 +1,7 @@
+bin/pylupdate5
+bin/pyrcc5
+%%PYTHON_SITELIBDIR%%/PyQt5/QtXml.so
+%%PYQT_SIPDIR%%/QtXml/QtXmlmod.sip
+%%PYQT_SIPDIR%%/QtXml/qdom.sip
+%%PYQT_SIPDIR%%/QtXml/qxml.sip
+%%API%%share/qt5/qsci/api/python/QtXml.api