aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-rxp
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2012-02-13 07:05:35 +0000
committerWen Heping <wen@FreeBSD.org>2012-02-13 07:05:35 +0000
commit2bff1d72731f52a90b5c62a57bc49dd15f1980fd (patch)
treed0be4c1ab113abd2e0ed6bdab529917ae7d88257 /textproc/py-rxp
parentd3a0152ccc4363fb42da3b37320e2b3317a49a58 (diff)
downloadports-2bff1d72731f52a90b5c62a57bc49dd15f1980fd.tar.gz
ports-2bff1d72731f52a90b5c62a57bc49dd15f1980fd.zip
- Unbreak on FreeBSD-9 and above
PR: ports/164928 Submitted by: Denis Generalov <gd@rambler-co.ru>
Notes
Notes: svn path=/head/; revision=291268
Diffstat (limited to 'textproc/py-rxp')
-rw-r--r--textproc/py-rxp/Makefile8
-rw-r--r--textproc/py-rxp/files/patch-setup.py12
2 files changed, 13 insertions, 7 deletions
diff --git a/textproc/py-rxp/Makefile b/textproc/py-rxp/Makefile
index 49bb530fe351..38d257ebaefa 100644
--- a/textproc/py-rxp/Makefile
+++ b/textproc/py-rxp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rxp
PORTVERSION= 0.9
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= http://www.reportlab.com/ftp/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -27,13 +28,6 @@ DOCSDIR= ${PREFIX}/share/doc/py-rxp
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 900000
-BROKEN= does not build
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's/freebsd4/freebsd4", "freebsd5", "freebsd6", "freebsd7", "freebsd8/g' ${WRKSRC}/setup.py
-
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${EXAMPLESDIR} ${DOCSDIR}
diff --git a/textproc/py-rxp/files/patch-setup.py b/textproc/py-rxp/files/patch-setup.py
new file mode 100644
index 000000000000..533858906f3e
--- /dev/null
+++ b/textproc/py-rxp/files/patch-setup.py
@@ -0,0 +1,12 @@
+--- setup.py.orig 2012-02-10 14:58:50.000000000 +0800
++++ setup.py 2012-02-10 15:00:05.000000000 +0800
+@@ -25,7 +25,8 @@
+ LIBS=['nsl', 'socket', 'dl']
+ elif sys.platform=="aix4":
+ LIBS=['nsl_r', 'dl']
+- elif sys.platform in ("freebsd4", "darwin", "mac", "linux2"):
++ elif sys.platform in ("freebsd4", "darwin", "mac", "linux2") \
++ or sys.platform.startswith("freebsd"):
+ LIBS=[]
+ else:
+ msg = "Don't know about system %s" % sys.platform