aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-stemming
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2017-06-13 21:02:46 +0000
committerRene Ladan <rene@FreeBSD.org>2017-06-13 21:02:46 +0000
commit009c6cbd88aa7693df09527fe532ba7040676a1b (patch)
tree847bb900c48272e3eee2ad11d348316e04822ba1 /textproc/py-stemming
parenta155d15ea3910cf577573d83793d1bc62777d7a3 (diff)
downloadports-009c6cbd88aa7693df09527fe532ba7040676a1b.tar.gz
ports-009c6cbd88aa7693df09527fe532ba7040676a1b.zip
Python implementations of the Porter, Porter2, Paice-Husk, and Lovins stemming
algorithms for English. These implementations are straightforward and efficient, unlike some Python versions of the same algorithms available on the Web. This package is an extraction of the stemming code included in the Whoosh search engine. Note that these are *pure Python* implementations. Python wrappers for, e.g. the Snoball stemmers and the C implementation of the Porter stemmer are available on PyPI and will be faster if using compiled code is an option for you. Stemming algorithms attempt to automatically remove suffixes (and in some cases prefixes) in order to find the "root word" or stem of a given word. This is useful in various natural language processing scenarios, such as search. In general ``porter2`` is the best overall stemming algorithm, but not necessarily the fastest or most aggressive. WWW: https://pypi.python.org/pypi/stemming
Notes
Notes: svn path=/head/; revision=443539
Diffstat (limited to 'textproc/py-stemming')
-rw-r--r--textproc/py-stemming/Makefile20
-rw-r--r--textproc/py-stemming/distinfo3
-rw-r--r--textproc/py-stemming/pkg-descr19
3 files changed, 42 insertions, 0 deletions
diff --git a/textproc/py-stemming/Makefile b/textproc/py-stemming/Makefile
new file mode 100644
index 000000000000..02f4fb490eb2
--- /dev/null
+++ b/textproc/py-stemming/Makefile
@@ -0,0 +1,20 @@
+# Created by: Rene Ladan <rene@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= stemming
+PORTVERSION= 1.0.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rene@FreeBSD.org
+COMMENT= Algorithms for stemming
+
+LICENSE= PD
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-stemming/distinfo b/textproc/py-stemming/distinfo
new file mode 100644
index 000000000000..fe1bc2988fa8
--- /dev/null
+++ b/textproc/py-stemming/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1497386383
+SHA256 (stemming-1.0.1.tar.gz) = 59678702e1d06caffecee82910f048edf12ad89dcf430776b4b05bfb8850bc51
+SIZE (stemming-1.0.1.tar.gz) = 10954
diff --git a/textproc/py-stemming/pkg-descr b/textproc/py-stemming/pkg-descr
new file mode 100644
index 000000000000..ede400cdcf88
--- /dev/null
+++ b/textproc/py-stemming/pkg-descr
@@ -0,0 +1,19 @@
+Python implementations of the Porter, Porter2, Paice-Husk, and Lovins stemming
+algorithms for English. These implementations are straightforward and
+efficient, unlike some Python versions of the same algorithms available on the
+Web. This package is an extraction of the stemming code included in the Whoosh
+search engine.
+
+Note that these are *pure Python* implementations. Python wrappers for, e.g.
+the Snoball stemmers and the C implementation of the Porter stemmer are
+available on PyPI and will be faster if using compiled code is an option for
+you.
+
+Stemming algorithms attempt to automatically remove suffixes (and in some
+cases prefixes) in order to find the "root word" or stem of a given word. This
+is useful in various natural language processing scenarios, such as search.
+
+In general ``porter2`` is the best overall stemming algorithm, but not
+necessarily the fastest or most aggressive.
+
+WWW: https://pypi.python.org/pypi/stemming