aboutsummaryrefslogtreecommitdiff
path: root/textproc/rarian
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-10-04 21:35:55 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-10-04 21:35:55 +0000
commit162ca4d4e52d9010a7267f0025c9866ae454ae61 (patch)
tree73d830451268143930a073424150b0b4af618c4e /textproc/rarian
parent89bfa2a78f08e0709c3ec3f9335f8230207c2b29 (diff)
downloadports-162ca4d4e52d9010a7267f0025c9866ae454ae61.tar.gz
ports-162ca4d4e52d9010a7267f0025c9866ae454ae61.zip
Clean up port's makefile
In particular: - Remove DOCBOOK_VERSION variable, it was supposed to be removed in r377770. - Switch to using USES=localbase Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=551466
Diffstat (limited to 'textproc/rarian')
-rw-r--r--textproc/rarian/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/textproc/rarian/Makefile b/textproc/rarian/Makefile
index 8514a0d6cb31..66c51f719139 100644
--- a/textproc/rarian/Makefile
+++ b/textproc/rarian/Makefile
@@ -12,27 +12,24 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= OMF help system based on the Freedesktop specification
BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:textproc/docbook-xsl \
- docbook-xml>0:textproc/docbook-xml \
- bash:shells/bash
-RUN_DEPENDS= bash:shells/bash \
- ${LOCALBASE}/bin/getopt:misc/getopt \
+ bash:shells/bash \
+ docbook-xml>0:textproc/docbook-xml
+RUN_DEPENDS= ${LOCALBASE}/bin/getopt:misc/getopt \
${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:textproc/docbook-xsl \
+ bash:shells/bash \
docbook-xml>0:textproc/docbook-xml
-DOCBOOK_VERSION=4.2
-
-CONFLICTS= scrollkeeper-[0-9]*
-
-USES= gmake gnome libtool pathfix python tar:bzip2
+USES= gmake gnome libtool localbase pathfix python tar:bzip2
USE_GNOME= libxslt
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-convert-dir=${LOCALBASE}/share/omf \
- --localstatedir=/var
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --localstatedir=/var \
+ --with-convert-dir=${LOCALBASE}/share/omf
+
INSTALL_TARGET= install-strip
+CONFLICTS= scrollkeeper-[0-9]*
+
post-patch:
@${REINPLACE_CMD} -e 's|/lib/rarian|/db/rarian|' \
${WRKSRC}/util/Makefile.in