aboutsummaryrefslogtreecommitdiff
path: root/textproc/redland
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-04-29 22:51:57 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-04-29 22:51:57 +0000
commitd6bce6de862aad35175bb464e6ac78588ea0a102 (patch)
tree94aee87959562f363b9cc63ae196e03430ea63e6 /textproc/redland
parentcea9f248e76813df97a40327d4554db744808c43 (diff)
downloadports-d6bce6de862aad35175bb464e6ac78588ea0a102.tar.gz
ports-d6bce6de862aad35175bb464e6ac78588ea0a102.zip
- Add OPTIONS for mpfr/gmp for redland
- While here, pass raptor/redland maintainership to kde@ per maintainer's request PR: 146157 Submitted by: Kenyon Ralph <kenyon@kenyonralph.com> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=253449
Diffstat (limited to 'textproc/redland')
-rw-r--r--textproc/redland/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index 0ab29325f2a5..affb15efb9bc 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -8,13 +8,13 @@
PORTNAME= redland
PORTVERSION= 1.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/librdf/${PORTNAME}/${PORTVERSION} \
http://librdf.org/dist/source/
-MAINTAINER= chuck@pkix.net
+MAINTAINER= kde@FreeBSD.org
COMMENT= A high-level interface for RDF
LIB_DEPENDS= raptor.2:${PORTSDIR}/textproc/raptor
@@ -43,6 +43,8 @@ MAN1= rasqal-config.1 rdfproc.1 redland-config.1 \
MAN3= librasqal.3 redland.3
OPTIONS+= MYSQL "Use MySQL instead of BDB" off
+OPTIONS+= MPFR "Use MPFR library for decimals (implies GMP)" off
+OPTIONS+= GMP "Use Gnu MP library for decimals" off
.include <bsd.port.pre.mk>
@@ -55,6 +57,19 @@ CONFIGURE_ARGS+=--with-mysql=no
PLIST_SUB+= MYSQL="@comment "
.endif
+# Set to mpfr if MPFR is on, gmp if only GMP is on and none if neither.
+# This guards against $user setting both GMP and MPFR, since we can't be
+# very verbose in explaining our options.
+.if defined(WITH_MPFR)
+CONFIGURE_ARGS+= --with-decimal=mpfr
+LIB_DEPENDS+= mpfr.3:${PORTSDIR}/math/mpfr
+.elif defined(WITH_GMP)
+CONFIGURE_ARGS+= --with-decimal=gmp
+LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
+.else
+CONFIGURE_ARGS+= --with-decimal=none
+.endif
+
pre-everything::
@${ECHO_CMD} "You can choose BDB version by setting WITH_BDB_VER to one off:"
@${ECHO_CMD} "3 40 41 42 43 44 3+ 40+ 41+ 42+ 43+ 44+ (current: ${BDB_VER})"