aboutsummaryrefslogtreecommitdiff
path: root/textproc/refdb/files
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-09-10 18:57:30 +0000
committerJohn Marino <marino@FreeBSD.org>2014-09-10 18:57:30 +0000
commitf22fd7cc2de5755fb4138d0921327c3afe4e08f5 (patch)
tree43997ded01a805ec6c667482fa51a54cc418e12b /textproc/refdb/files
parent5d4cd0e6daa79a50a2c4e27b7fa1f9445daca788 (diff)
downloadports-f22fd7cc2de5755fb4138d0921327c3afe4e08f5.tar.gz
ports-f22fd7cc2de5755fb4138d0921327c3afe4e08f5.zip
Stage textproc/refdb
PR: 193484 Submitted by: ohartman (zedat.fu-berlin.de) Too much TLC: marino
Notes
Notes: svn path=/head/; revision=367879
Diffstat (limited to 'textproc/refdb/files')
-rw-r--r--textproc/refdb/files/patch-doc_Makefile.in33
-rw-r--r--textproc/refdb/files/refdbd.in84
2 files changed, 117 insertions, 0 deletions
diff --git a/textproc/refdb/files/patch-doc_Makefile.in b/textproc/refdb/files/patch-doc_Makefile.in
new file mode 100644
index 000000000000..071c4f541912
--- /dev/null
+++ b/textproc/refdb/files/patch-doc_Makefile.in
@@ -0,0 +1,33 @@
+--- doc/Makefile.in.orig 2014-09-10 12:40:48 UTC
++++ doc/Makefile.in
+@@ -227,8 +227,8 @@ tei_xsl_ns = @tei_xsl_ns@
+ trang_cmd = @trang_cmd@
+ var_dir = @var_dir@
+ xml_decl = @xml_decl@
+-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/refdb-manual
+-doc_DATA = refdb-manual.pdf refdb-manual/*
++docdir = $(datadir)/doc/refdb
++doc_DATA = refdb-manual/*
+ indexdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/
+ index_DATA = index.html
+ citestylexdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/citestylex
+@@ -779,7 +779,7 @@ uninstall-am: uninstall-citationlistxDAT
+ uninstall-xnoteelementsDATA
+
+
+-all: refdb-manual.pdf refdb-manual/* citestylex/elements.html risx/elements.html citationlistx/elements.html xnote/elements.html
++all: refdb-manual-html citestylex/elements.html risx/elements.html citationlistx/elements.html xnote/elements.html
+
+ ####################################################################
+ # building the manual
+@@ -804,9 +804,8 @@ refdb-manual.pdf: $(manual_sources) $(ma
+ # we have to give Java a little extra memory lest fop will die a horrible death
+ JAVA_OPTS=-Xmx256M fop -fo refdb-manual.fo -pdf refdb-manual.pdf
+
+-refdb-manual/*: $(manual_sources) $(manpage_sources) $(png_images) refdb-manual-statustable.xml include/manual-xhtml.xsl
++refdb-manual-html: $(manual_sources) $(manpage_sources) $(png_images) refdb-manual-statustable.xml include/manual-xhtml.xsl
+ @echo "Creating HTML manual...";
+- rm -rf refdb-manual/*
+ # building outside the source dir won't work here because the docbook
+ # stylesheets screw up the location of the image files for HTML output
+ mkdir -p refdb-manual && cp $(html_extra_files) refdb-manual/ && xsltproc -o refdb-manual/ --nonet --xinclude include/manual-xhtml.xsl refdb-manual.xml
diff --git a/textproc/refdb/files/refdbd.in b/textproc/refdb/files/refdbd.in
new file mode 100644
index 000000000000..43494604ae7c
--- /dev/null
+++ b/textproc/refdb/files/refdbd.in
@@ -0,0 +1,84 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# O. Hartmann, Berlin, 2014
+#
+#
+# PROVIDE: refdbd
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# To enable this service, place
+#
+# refdbd_enable="YES"
+#
+# in /etc/rc.conf[.local]
+#
+# and optionally set the the following variables upon your environment:
+#
+# Choose another PIDFILE as the configured and/or default one:
+# refdbd_pidfile="/var/run/refdbd.pid"
+#
+# To make the refdbd daemon accessible local only (127.0.0.1):
+# refdbd_local="YES"
+
+. /etc/rc.subr
+
+name="refdbd"
+rcvar=refdbd_enable
+
+# read settings, set defaults
+load_rc_config ${name}
+
+command="%%PREFIX%%/bin/${name}"
+globalconfig="%%PREFIX%%/etc/refdb/refdbdrc"
+pidfile="/var/run/${name}.pid"
+extra_commands="reload"
+
+load_rc_config ${name}
+
+: ${refdbd_enable:="NO"}
+: ${refdbd_local:="NO"}
+
+if checkyesno refdbd_local; then
+ refdbd_local_flags="-I"
+else
+ refdbd_local_flags=""
+fi
+
+start_precmd="${name}_prestart"
+
+refdbd_prestart()
+{
+ local refdbvar refdbval
+
+ # Check whether we have configured a PID file
+ if [ "x${refdbd_pidfile}" != "x" ]; then
+ pidfile="${refdbd_pidfile}"
+
+ # ... if not configured via rc.conf[.local],
+ # read the settings in the configure file. We're only interested in
+ # nonstandard PID file settings
+ else
+ for config in ${globalconfig}; do
+ while read refdbvar refdbval; do
+ if [ -n "${refdbvar}" ]; then
+ if [ ${refdbvar}="pidfile" ]; then
+ pidfile=${refdbval}
+ fi
+ fi
+ done < $config
+ done
+ fi
+
+ piddir=`dirname ${pidfile}`
+ mkdir -p ${piddir}
+
+ refdbd_pid_flags="-P ${pidfile}"
+}
+
+# Set command arguments upon configuration
+command_args="${refdbd_local_flags} ${refdbd_pid_flags}"
+
+run_rc_command "$1"