aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-gdome
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-01-23 19:41:27 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-01-23 19:41:27 +0000
commitccf4bffe9485ddb6428e16214e97ba944e4f0848 (patch)
tree2a122a341ae48a0bd235e0edcae9e0b9afaf8c3c /textproc/ruby-gdome
parent365028dd1bf5a39ac1f2e437104cff951a3629df (diff)
downloadports-ccf4bffe9485ddb6428e16214e97ba944e4f0848.tar.gz
ports-ccf4bffe9485ddb6428e16214e97ba944e4f0848.zip
Update to 0.3 and unbreak for ruby 1.8.
Notes
Notes: svn path=/head/; revision=73877
Diffstat (limited to 'textproc/ruby-gdome')
-rw-r--r--textproc/ruby-gdome/Makefile10
-rw-r--r--textproc/ruby-gdome/distinfo2
-rw-r--r--textproc/ruby-gdome/files/patch-extconf.rb17
3 files changed, 25 insertions, 4 deletions
diff --git a/textproc/ruby-gdome/Makefile b/textproc/ruby-gdome/Makefile
index 004bc8552817..2c083c5ac21e 100644
--- a/textproc/ruby-gdome/Makefile
+++ b/textproc/ruby-gdome/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gdome
-PORTVERSION= 0.1
-PORTREVISION= 2
+PORTVERSION= 0.3
CATEGORIES= textproc ruby
MASTER_SITES= http://download.berlios.de/libgdome-ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -18,15 +17,20 @@ MAINTAINER= knu@FreeBSD.org
LIB_DEPENDS= gdome.7:${PORTSDIR}/textproc/gdome2
+USE_BZIP2= yes
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
+post-extract:
+ ${RM} -rf ${WRKSRC}/examples-ruby/CVS
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${RUBY_MODEXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/examples-ruby/* ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}/
.endif
diff --git a/textproc/ruby-gdome/distinfo b/textproc/ruby-gdome/distinfo
index 5df21a70978a..037210450ca1 100644
--- a/textproc/ruby-gdome/distinfo
+++ b/textproc/ruby-gdome/distinfo
@@ -1 +1 @@
-MD5 (ruby/libgdome-ruby-0.1.tar.gz) = e3fefd62ebeb1b0c4b1c3f396777c850
+MD5 (ruby/libgdome-ruby-0.3.tar.bz2) = e333a02e4a1c8f4479d22f8e43ba6874
diff --git a/textproc/ruby-gdome/files/patch-extconf.rb b/textproc/ruby-gdome/files/patch-extconf.rb
new file mode 100644
index 000000000000..3f5ae414140a
--- /dev/null
+++ b/textproc/ruby-gdome/files/patch-extconf.rb
@@ -0,0 +1,17 @@
+--- extconf.rb.orig Fri Jul 13 08:20:23 2001
++++ extconf.rb Fri Jan 24 04:32:03 2003
+@@ -1,11 +1,11 @@
+ require "mkmf"
+
+-$CFLAGS += `gdome-config --cflags`.gsub("\n"," ")
++$CFLAGS << ' ' << `gdome-config --cflags`.gsub("\n"," ")
+ if ($? == 0)
+- $LDFLAGS += `gdome-config --libs`.gsub("\n"," ")
++ $LDFLAGS << ' ' << `gdome-config --libs`.gsub("\n"," ")
+ if ($? == 0)
+ load "code_creation/parse_idl.rb"
+- $LOCAL_LIBS += $LDFLAGS
++ $LOCAL_LIBS << ' ' << $LDFLAGS
+ create_makefile('gdome')
+ end
+ end