aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-chewy/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-12 20:33:49 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-12 20:33:49 +0000
commit9b3435b9ce6c4aaa5fe517d878090b87a60760db (patch)
treec7ba2c6782befb4ffa1a0f22e8d29c7e4a4a40dc /textproc/rubygem-chewy/Makefile
parent2d06e21071d84d6380c548916bbd2d93bb81701c (diff)
downloadports-9b3435b9ce6c4aaa5fe517d878090b87a60760db.tar.gz
ports-9b3435b9ce6c4aaa5fe517d878090b87a60760db.zip
Add rubygem-chewy 5.0.0
Chewy provides functionality for Elasticsearch index handling, documents import mappings and chainable query DSL. WWW: https://github.com/toptal/chewy
Notes
Notes: svn path=/head/; revision=464280
Diffstat (limited to 'textproc/rubygem-chewy/Makefile')
-rw-r--r--textproc/rubygem-chewy/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/textproc/rubygem-chewy/Makefile b/textproc/rubygem-chewy/Makefile
new file mode 100644
index 000000000000..8e8aaf791ef0
--- /dev/null
+++ b/textproc/rubygem-chewy/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= chewy
+PORTVERSION= 5.0.0
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= ODM and wrapper for Elasticsearch client
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-activesupport5>=4.0:devel/rubygem-activesupport5 \
+ rubygem-elasticsearch>=2.0.0:textproc/rubygem-elasticsearch \
+ rubygem-elasticsearch-dsl>=0:textproc/rubygem-elasticsearch-dsl
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>