aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-rails-dom-testing-rails61
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-10 08:51:40 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-10 08:51:40 +0000
commit7d51e7a919e85641b660e74c94df1b1a2bda2d01 (patch)
tree9fe5db1899ae0c31933e754d3a50147ea6c6ff46 /textproc/rubygem-rails-dom-testing-rails61
parent95be95098f9a99b7d89491c3671a1bc2fd06aa38 (diff)
downloadports-7d51e7a919e85641b660e74c94df1b1a2bda2d01.tar.gz
ports-7d51e7a919e85641b660e74c94df1b1a2bda2d01.zip
Add rubygem-rails-dom-testing-rails61 6.1.0 (copied from rubygem-rails-dom-testing-rails60)
Notes
Notes: svn path=/head/; revision=561044
Diffstat (limited to 'textproc/rubygem-rails-dom-testing-rails61')
-rw-r--r--textproc/rubygem-rails-dom-testing-rails61/Makefile24
-rw-r--r--textproc/rubygem-rails-dom-testing-rails61/distinfo3
-rw-r--r--textproc/rubygem-rails-dom-testing-rails61/pkg-descr8
3 files changed, 35 insertions, 0 deletions
diff --git a/textproc/rubygem-rails-dom-testing-rails61/Makefile b/textproc/rubygem-rails-dom-testing-rails61/Makefile
new file mode 100644
index 000000000000..c3b247b0336e
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing-rails61/Makefile
@@ -0,0 +1,24 @@
+# Created by: Johannes Jost Meixner <xmj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rails-dom-testing
+PORTVERSION= 2.0.3
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails61
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Analyse and compare DOMs using Nokogiri
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-activesupport61>=4.2.0:devel/rubygem-activesupport61 \
+ rubygem-nokogiri>=1.6:textproc/rubygem-nokogiri
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-rails-dom-testing-rails61/distinfo b/textproc/rubygem-rails-dom-testing-rails61/distinfo
new file mode 100644
index 000000000000..d87274f660df
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing-rails61/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1494610306
+SHA256 (rubygem/rails-dom-testing-2.0.3.gem) = b140c4f39f6e609c8113137b9a60dfc2ecb89864e496f87f23a68b3b8f12d8d1
+SIZE (rubygem/rails-dom-testing-2.0.3.gem) = 14336
diff --git a/textproc/rubygem-rails-dom-testing-rails61/pkg-descr b/textproc/rubygem-rails-dom-testing-rails61/pkg-descr
new file mode 100644
index 000000000000..c87a1ba37065
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing-rails61/pkg-descr
@@ -0,0 +1,8 @@
+This gem is responsible for comparing HTML doms and asserting that DOM elements
+are present in Rails applications. Doms are compared via assert_dom_equal and
+assert_dom_not_equal. Elements are asserted via assert_select,
+assert_select_encoded, assert_select_email and a subset of the dom can be
+selected with css_select. The gem is developed for Rails 4.2 and above, and
+will not work on previous versions.
+
+WWW: https://github.com/rails/rails-dom-testing