aboutsummaryrefslogtreecommitdiff
path: root/textproc/sgmls/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-04 22:50:40 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-04 22:50:40 +0000
commit5fad809a5036ede0aa1484f20794ae259980b7fa (patch)
treecddd9991fc9d4b10a6996ebf4fafeeaf1d756cbe /textproc/sgmls/Makefile
parentf83af9fadf126ce99ee41552d898bc5eb04fd222 (diff)
downloadports-5fad809a5036ede0aa1484f20794ae259980b7fa.tar.gz
ports-5fad809a5036ede0aa1484f20794ae259980b7fa.zip
Remove NOPORTDOCS and NOPORTEXAMPLES.
Notes
Notes: svn path=/head/; revision=360676
Diffstat (limited to 'textproc/sgmls/Makefile')
-rw-r--r--textproc/sgmls/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/textproc/sgmls/Makefile b/textproc/sgmls/Makefile
index 7b5b11132afc..1181bd53d784 100644
--- a/textproc/sgmls/Makefile
+++ b/textproc/sgmls/Makefile
@@ -18,22 +18,22 @@ INSTALL_TARGET= install install.man
PROGS= sgmls sgmlsasp rast
PKGDOCS= ChangeLog INSTALL LICENSE NEWS README TODO
+OPTIONS_DEFINE= DOCS
+
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/Makefile
post-build:
.for file in ${PROGS}
- @${STRIP_CMD} ${WRKSRC}/${file}
+ ${STRIP_CMD} ${WRKSRC}/${file}
.endfor
- @cd ${WRKSRC} && ${MAKE} test
+ cd ${WRKSRC} && ${MAKE} test
post-install:
-.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
@-${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PKGDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>