aboutsummaryrefslogtreecommitdiff
path: root/textproc/sgrep2/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-04-29 10:55:40 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-04-29 10:55:40 +0000
commit2d15f8c3689b5d5f9cf4b2b13ad47f7591142cb8 (patch)
tree4f15afa0526b4dbfdf32a664e75787d5308ec96a /textproc/sgrep2/Makefile
parent36ca7be718609d75343cc3171661b40f5b9ad9e5 (diff)
downloadports-2d15f8c3689b5d5f9cf4b2b13ad47f7591142cb8.tar.gz
ports-2d15f8c3689b5d5f9cf4b2b13ad47f7591142cb8.zip
New sgrep port. From the man page:
sgrep (structured grep) is a tool for searching text files and filtering text streams using structural criteria. The data model of sgrep is based on regions, which are non- empty substrings of text. Regions are typically occur- rences of constant strings or meaningful text elements, which are recognizable through some delimiting strings. PR: 6449 Submitted by: A Joseph Koshy <koshy@india.hp.com>
Notes
Notes: svn path=/head/; revision=10759
Diffstat (limited to 'textproc/sgrep2/Makefile')
-rw-r--r--textproc/sgrep2/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/textproc/sgrep2/Makefile b/textproc/sgrep2/Makefile
new file mode 100644
index 000000000000..977ff624c5a5
--- /dev/null
+++ b/textproc/sgrep2/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: sgrep
+# Version required: 0.99
+# Date created: Apr 29 1998
+# Whom: <koshy@india.hp.com>
+#
+# $Id$
+#
+
+DISTNAME= sgrep-0.99
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/
+
+MAINTAINER= koshy@india.hp.com
+
+MAN1= sgrep.1
+
+# Override the install target in the supplied makefile
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sgrep ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sgrep.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/sample.sgreprc ${PREFIX}/share/sgreprc
+
+.include <bsd.port.mk>