aboutsummaryrefslogtreecommitdiff
path: root/textproc/sphinxsearch
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-12-07 08:42:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-12-07 08:42:42 +0000
commit046199a0df4e5867d409fafe076446cea1abaeef (patch)
tree3b31a75bf7264d9fe885a932b094384babf06c58 /textproc/sphinxsearch
parentcb4aae4193917c1c285f0b3d5f6c701d6dad7c14 (diff)
downloadports-046199a0df4e5867d409fafe076446cea1abaeef.tar.gz
ports-046199a0df4e5867d409fafe076446cea1abaeef.zip
- Add unixODBC option
PR: ports/141231 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk> (maintainer)
Notes
Notes: svn path=/head/; revision=245325
Diffstat (limited to 'textproc/sphinxsearch')
-rw-r--r--textproc/sphinxsearch/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index 70efc9932a19..85b62bdeb2ec 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -26,7 +26,8 @@ OPTIONS= MYSQL "MySQL support" on \
PGSQL "PostgreSQL support" off \
ICONV "Iconv support" on \
OPTIMIZED_CFLAGS "Use compiler optimization (-O3)" off \
- ID64 "use 64-bit document and word IDs" off
+ ID64 "use 64-bit document and word IDs" off \
+ UNIXODBC "unixODBC support" off
## FFR
## LIBSTEMMER "compile with libstemmer support" off
@@ -70,6 +71,13 @@ CXXFLAGS+= -O3 -fomit-frame-pointer
CONFIGURE_ARGS+= --enable-id64
.endif
+.if defined(WITH_UNIXODBC)
+CONFIGURE_ARGS+= --with-unixodbc
+LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+.else
+CONFIGURE_ARGS+= --without-unixodbc
+.endif
+
## FFR. The snowball project doesn't release numbered versions of it's
## pre-processors. Instead, at arbitrary intervals a snapshot of their
## source repository is turned into a tarball (always the same filename)