aboutsummaryrefslogtreecommitdiff
path: root/textproc/stardict2
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2006-07-10 05:55:56 +0000
committerXin LI <delphij@FreeBSD.org>2006-07-10 05:55:56 +0000
commitab2df0e5aaa52f94978089132758df3efc733238 (patch)
tree65b7303cea185df42bbbeedd5bf5d13aa4bd6e2d /textproc/stardict2
parent9e6a69437a6eec161a03fd6caf767f55bfdc518e (diff)
downloadports-ab2df0e5aaa52f94978089132758df3efc733238.tar.gz
ports-ab2df0e5aaa52f94978089132758df3efc733238.zip
Update to 2.4.8, while I'm there, turn share/gnome/stardict into
dirrmtry because dictionaries are also installed there.
Notes
Notes: svn path=/head/; revision=167336
Diffstat (limited to 'textproc/stardict2')
-rw-r--r--textproc/stardict2/Makefile3
-rw-r--r--textproc/stardict2/distinfo6
-rw-r--r--textproc/stardict2/files/patch-src::conf.cpp11
-rw-r--r--textproc/stardict2/files/patch-src::readword.cpp29
-rw-r--r--textproc/stardict2/files/patch-src::tools::ec50.cpp11
-rw-r--r--textproc/stardict2/pkg-plist6
6 files changed, 21 insertions, 45 deletions
diff --git a/textproc/stardict2/Makefile b/textproc/stardict2/Makefile
index e26483515781..d7e5de03095f 100644
--- a/textproc/stardict2/Makefile
+++ b/textproc/stardict2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stardict
-PORTVERSION= 2.4.6
+PORTVERSION= 2.4.8
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,6 +23,7 @@ USE_GCC= 3.4
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui
+USE_GETTEXT= yes
GCONF_SCHEMAS= stardict.schemas
INSTALLS_OMF= yes
diff --git a/textproc/stardict2/distinfo b/textproc/stardict2/distinfo
index 12ed6d00a0ef..9f8f34c059b1 100644
--- a/textproc/stardict2/distinfo
+++ b/textproc/stardict2/distinfo
@@ -1,3 +1,3 @@
-MD5 (stardict/stardict-2.4.6.tar.bz2) = a985bb3737903ffcea880e6df1433661
-SHA256 (stardict/stardict-2.4.6.tar.bz2) = 994e6311379a268aa60df0c45cc762d6000d3594db172b4d1c4728b3dca0f816
-SIZE (stardict/stardict-2.4.6.tar.bz2) = 1088338
+MD5 (stardict/stardict-2.4.8.tar.bz2) = 2f743d809737ca157bad71791c45ce63
+SHA256 (stardict/stardict-2.4.8.tar.bz2) = 160dd1dfe46ae0b9d44f9059a40eee71ff389be498aa4478355ff4640969680f
+SIZE (stardict/stardict-2.4.8.tar.bz2) = 1235020
diff --git a/textproc/stardict2/files/patch-src::conf.cpp b/textproc/stardict2/files/patch-src::conf.cpp
new file mode 100644
index 000000000000..1c6dd3846df6
--- /dev/null
+++ b/textproc/stardict2/files/patch-src::conf.cpp
@@ -0,0 +1,11 @@
+--- src/conf.cpp.orig Mon Jul 10 05:23:39 2006
++++ src/conf.cpp Mon Jul 10 05:24:36 2006
+@@ -93,7 +93,7 @@
+ #ifdef _WIN32
+ add_entry("/apps/stardict/preferences/dictionary/tts_path", std::string("C:\\Program Files\\WyabdcRealPeopleTTS\nC:\\Program Files\\OtdRealPeopleTTS\nWyabdcRealPeopleTTS\nOtdRealPeopleTTS"));
+ #else
+- add_entry("/apps/stardict/preferences/dictionary/tts_path", std::string("/usr/share/WyabdcRealPeopleTTS\n/usr/share/OtdRealPeopleTTS"));
++ add_entry("/apps/stardict/preferences/dictionary/tts_path", std::string("/usr/local/share/WyabdcRealPeopleTTS\n/usr/local/share/OtdRealPeopleTTS"));
+ #endif
+ add_entry("/apps/stardict/preferences/dictionary/history", get_default_history_filename());
+ add_entry("/apps/stardict/preferences/dictionary/only_export_word", true);
diff --git a/textproc/stardict2/files/patch-src::readword.cpp b/textproc/stardict2/files/patch-src::readword.cpp
deleted file mode 100644
index c9ddb8f9cfa4..000000000000
--- a/textproc/stardict2/files/patch-src::readword.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/readword.cpp.orig Mon Jul 18 21:06:15 2005
-+++ src/readword.cpp Thu Aug 4 16:42:21 2005
-@@ -17,7 +17,7 @@
- g_file_test((gStarDictDataDir+G_DIR_SEPARATOR+"WyabdcRealPeopleTTS").c_str(),
- G_FILE_TEST_EXISTS);
- #else
-- have_data_file = g_file_test("/usr/share/WyabdcRealPeopleTTS", G_FILE_TEST_EXISTS);
-+ have_data_file = g_file_test("/usr/local/share/WyabdcRealPeopleTTS", G_FILE_TEST_EXISTS);
- #endif
- }
-
-@@ -35,7 +35,7 @@
- filename = gStarDictDataDir+"/WyabdcRealPeopleTTS/"+
- lowerword[0]+"/"+lowerword+".wav";
- #else
-- filename = std::string("/usr/share/WyabdcRealPeopleTTS/")+lowerword[0]+"/"+
-+ filename = std::string("/usr/local/share/WyabdcRealPeopleTTS/")+lowerword[0]+"/"+
- lowerword+".wav";
- #endif
- return_val = g_file_test(filename.c_str(), G_FILE_TEST_EXISTS);
-@@ -58,7 +58,7 @@
- filename = gStarDictDataDir+"/WyabdcRealPeopleTTS/"+
- lowerword[0]+"/"+lowerword+".wav";
- #else
-- filename = std::string("/usr/share/WyabdcRealPeopleTTS/")+
-+ filename = std::string("/usr/local/share/WyabdcRealPeopleTTS/")+
- lowerword[0]+"/"+lowerword+".wav";
- #endif
- play_wav_file(filename.c_str());
diff --git a/textproc/stardict2/files/patch-src::tools::ec50.cpp b/textproc/stardict2/files/patch-src::tools::ec50.cpp
deleted file mode 100644
index 25e4f40bbfd5..000000000000
--- a/textproc/stardict2/files/patch-src::tools::ec50.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tools/ec50.cpp.orig Fri Oct 3 21:17:32 2003
-+++ src/tools/ec50.cpp Tue Jan 18 02:15:29 2005
-@@ -1115,7 +1115,7 @@
-
- closeVari();
- closeFile();
--};
-+}
-
- int
- main(int argc,char * argv [])
diff --git a/textproc/stardict2/pkg-plist b/textproc/stardict2/pkg-plist
index 294b406e7be7..afe1797c3eb8 100644
--- a/textproc/stardict2/pkg-plist
+++ b/textproc/stardict2/pkg-plist
@@ -49,17 +49,21 @@ share/gnome/stardict/pixmaps/docklet_normal.png
share/gnome/stardict/pixmaps/docklet_scan.png
share/gnome/stardict/pixmaps/docklet_stop.png
share/gnome/stardict/pixmaps/index_appendix.png
+share/gnome/stardict/pixmaps/index_dictlist.png
share/gnome/stardict/pixmaps/index_wazard.png
share/gnome/stardict/pixmaps/splash.png
share/gnome/stardict/sounds/buttonactive.wav
share/gnome/stardict/sounds/menushow.wav
share/locale/cs/LC_MESSAGES/stardict.mo
share/locale/de/LC_MESSAGES/stardict.mo
+share/locale/el/LC_MESSAGES/stardict.mo
+share/locale/fr/LC_MESSAGES/stardict.mo
share/locale/hr/LC_MESSAGES/stardict.mo
share/locale/hu/LC_MESSAGES/stardict.mo
share/locale/ku/LC_MESSAGES/stardict.mo
share/locale/mk/LC_MESSAGES/stardict.mo
share/locale/nl/LC_MESSAGES/stardict.mo
+share/locale/pt_BR/LC_MESSAGES/stardict.mo
share/locale/ru/LC_MESSAGES/stardict.mo
share/locale/sk/LC_MESSAGES/stardict.mo
share/locale/tt/LC_MESSAGES/stardict.mo
@@ -71,7 +75,7 @@ share/locale/zh_TW/LC_MESSAGES/stardict.mo
@dirrmtry share/locale/tt
@dirrm share/gnome/stardict/sounds
@dirrm share/gnome/stardict/pixmaps
-@dirrm share/gnome/stardict
+@dirrmtry share/gnome/stardict
@dirrm share/gnome/omf/stardict
@dirrm share/gnome/help/stardict/zh_TW/figures
@dirrm share/gnome/help/stardict/zh_TW