aboutsummaryrefslogtreecommitdiff
path: root/textproc/tagsoup
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2016-02-11 22:51:46 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2016-02-11 22:51:46 +0000
commit1d706a0bfbfe44390b8f7659a4476802876d3911 (patch)
tree5d65fef091ecc35cc40db2e9dd8dd502ec89b5fe /textproc/tagsoup
parente62c25dd60f458a7990766a5287fc58fb93a39dc (diff)
downloadports-1d706a0bfbfe44390b8f7659a4476802876d3911.tar.gz
ports-1d706a0bfbfe44390b8f7659a4476802876d3911.zip
TagSoup - Just Keep On Truckin'
TagSoup is a SAX-compliant parser written in Java that, instead of parsing well-formed or valid XML, parses HTML as it is found in the wild: poor, nasty and brutish, though quite often far from short. TagSoup is designed for people who have to process this stuff using some semblance of a rational application design. By providing a SAX interface, it allows standard XML tools to be applied to even the worst HTML. TagSoup also includes a command-line processor that reads HTML files and can generate either clean HTML or well-formed XML that is a close approximation to XHTML. WWW: http://home.ccil.org/~cowan/tagsoup
Notes
Notes: svn path=/head/; revision=408700
Diffstat (limited to 'textproc/tagsoup')
-rw-r--r--textproc/tagsoup/Makefile32
-rw-r--r--textproc/tagsoup/distinfo2
-rw-r--r--textproc/tagsoup/pkg-descr12
3 files changed, 46 insertions, 0 deletions
diff --git a/textproc/tagsoup/Makefile b/textproc/tagsoup/Makefile
new file mode 100644
index 000000000000..9d9f5755f1c8
--- /dev/null
+++ b/textproc/tagsoup/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= tagsoup
+PORTVERSION= 1.2.1
+CATEGORIES= textproc java
+MASTER_SITES= http://home.ccil.org/~cowan/tagsoup/
+EXTRACT_SUFX= .jar
+
+MAINTAINER= java@FreeBSD.org
+COMMENT= SAX-compliant parser written in Java
+
+LICENSE= APACHE20
+
+USE_JAVA= yes
+JAVA_RUN= jre
+
+NO_BUILD= yes
+
+PLIST_FILES= ${JAVAJARDIR}/${PORTNAME}.jar \
+ ${JAVAJARDIR}/${PORTNAME}-${PORTVERSION}.jar
+
+do-extract:
+ @${DO_NADA}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${JAVAJARDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}-${PORTVERSION}.jar \
+ ${STAGEDIR}${JAVAJARDIR}
+ ${LN} -fs ${JAVAJARDIR}/${PORTNAME}-${PORTVERSION}.jar \
+ ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
+
+.include <bsd.port.mk>
diff --git a/textproc/tagsoup/distinfo b/textproc/tagsoup/distinfo
new file mode 100644
index 000000000000..a9fb2d15d04d
--- /dev/null
+++ b/textproc/tagsoup/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tagsoup-1.2.1.jar) = ac97f7b4b1d8e9337edfa0e34044f8d0efe7223f6ad8f3a85d54cc1018ea2e04
+SIZE (tagsoup-1.2.1.jar) = 90722
diff --git a/textproc/tagsoup/pkg-descr b/textproc/tagsoup/pkg-descr
new file mode 100644
index 000000000000..af120570eb65
--- /dev/null
+++ b/textproc/tagsoup/pkg-descr
@@ -0,0 +1,12 @@
+TagSoup - Just Keep On Truckin'
+
+TagSoup is a SAX-compliant parser written in Java that, instead of parsing
+well-formed or valid XML, parses HTML as it is found in the wild: poor,
+nasty and brutish, though quite often far from short. TagSoup is designed
+for people who have to process this stuff using some semblance of a rational
+application design. By providing a SAX interface, it allows standard XML
+tools to be applied to even the worst HTML. TagSoup also includes
+a command-line processor that reads HTML files and can generate either
+clean HTML or well-formed XML that is a close approximation to XHTML.
+
+WWW: http://home.ccil.org/~cowan/tagsoup