aboutsummaryrefslogtreecommitdiff
path: root/textproc/topic/Makefile
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2013-02-06 09:50:48 +0000
committerFrederic Culot <culot@FreeBSD.org>2013-02-06 09:50:48 +0000
commit2cfe6c318ec8ee94c3d99730a4259e327dffa0e0 (patch)
treed155e58ab8c0672964b66d3d80e3d90600e4f78c /textproc/topic/Makefile
parentda5491559ea0a59e6b56be7db1f710656ea16717 (diff)
downloadports-2cfe6c318ec8ee94c3d99730a4259e327dffa0e0.tar.gz
ports-2cfe6c318ec8ee94c3d99730a4259e327dffa0e0.zip
TOPIC markup provides a minimal context for plain text databases that
can be read/modified by most text editors, and easily parsed as well. WWW: http://topcat.hypermart.net/topic.html PR: ports/175807 Submitted by: Michael Sanders <mike@topcat.hypermart.net>
Notes
Notes: svn path=/head/; revision=311753
Diffstat (limited to 'textproc/topic/Makefile')
-rw-r--r--textproc/topic/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/textproc/topic/Makefile b/textproc/topic/Makefile
new file mode 100644
index 000000000000..92b5df147337
--- /dev/null
+++ b/textproc/topic/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= topic
+PORTVERSION= 1.02
+CATEGORIES= textproc
+MASTER_SITES= http://topcat.hypermart.net/code/
+
+MAINTAINER= mike@topcat.hypermart.net
+COMMENT= Topic markup parser
+
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/${PORTNAME}.1
+
+.include <bsd.port.mk>