aboutsummaryrefslogtreecommitdiff
path: root/textproc/topic/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-02 10:33:26 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-02 10:33:26 +0000
commitd04055801bbc21144e47a9c631e5b80ce15b6cf0 (patch)
treec97020e32d1e02769ee24787d92359cd3af813d3 /textproc/topic/Makefile
parent8a3f89fe108710b120d844b88b6f8f96d41346d2 (diff)
downloadports-d04055801bbc21144e47a9c631e5b80ce15b6cf0.tar.gz
ports-d04055801bbc21144e47a9c631e5b80ce15b6cf0.zip
- Try to unbreak parallel (-jX) builds by sanitizing makefile
- Cleanup Makefile: kill defunct WWW and comment MASTER_SITES
Notes
Notes: svn path=/head/; revision=324159
Diffstat (limited to 'textproc/topic/Makefile')
-rw-r--r--textproc/topic/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/textproc/topic/Makefile b/textproc/topic/Makefile
index 92b5df147337..8df87c116a70 100644
--- a/textproc/topic/Makefile
+++ b/textproc/topic/Makefile
@@ -3,7 +3,7 @@
PORTNAME= topic
PORTVERSION= 1.02
CATEGORIES= textproc
-MASTER_SITES= http://topcat.hypermart.net/code/
+MASTER_SITES= # http://topcat.hypermart.net/code/
MAINTAINER= mike@topcat.hypermart.net
COMMENT= Topic markup parser
@@ -11,8 +11,11 @@ COMMENT= Topic markup parser
PLIST_FILES= bin/${PORTNAME}
MAN1= ${PORTNAME}.1
+pre-build:
+ @${RM} ${WRKSRC}/topic.txt
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/${PORTNAME}.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>