aboutsummaryrefslogtreecommitdiff
path: root/textproc/translate-toolkit
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /textproc/translate-toolkit
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'textproc/translate-toolkit')
-rw-r--r--textproc/translate-toolkit/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/textproc/translate-toolkit/Makefile b/textproc/translate-toolkit/Makefile
index 0350a3b7dfd1..29761d284a62 100644
--- a/textproc/translate-toolkit/Makefile
+++ b/textproc/translate-toolkit/Makefile
@@ -11,21 +11,21 @@ COMMENT= Converts between many translation formats
LICENSE= GPLv2
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}vobject>=0:deskutils/py-vobject \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}vobject>=0:deskutils/py-vobject@${FLAVOR} \
msghack:devel/gettext-msghack \
- ${PYTHON_PKGNAMEPREFIX}iniparse>=0:devel/py-iniparse \
- ${PYTHON_PKGNAMEPREFIX}levenshtein>=0:devel/py-levenshtein \
- ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}iniparse>=0:devel/py-iniparse@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}levenshtein>=0:devel/py-levenshtein@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${FLAVOR} \
iso-codes>=1.3:misc/iso-codes \
bash:shells/bash \
- ${PYTHON_PKGNAMEPREFIX}utidylib>=0:www/py-utidylib
+ ${PYTHON_PKGNAMEPREFIX}utidylib>=0:www/py-utidylib@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
# Can use psyco (on i386)
NO_ARCH= yes
-USES= gettext python:2.7+
+USES= gettext python:2.7
USE_PYTHON= autoplist distutils
# list of manual pages to generate