aboutsummaryrefslogtreecommitdiff
path: root/textproc/ts-hunspell/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-07-20 16:37:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-07-20 16:37:29 +0000
commit6f1b301a3c8b315d7b8e12d08500cebcf6f5a6cd (patch)
tree38718a12375412518022a483a084b7afb2076181 /textproc/ts-hunspell/Makefile
parentde766ead61336eb048cde9a6bab3eba21b00d97e (diff)
downloadports-6f1b301a3c8b315d7b8e12d08500cebcf6f5a6cd.tar.gz
ports-6f1b301a3c8b315d7b8e12d08500cebcf6f5a6cd.zip
Add Tsonga hunspell dictionnaries
Notes
Notes: svn path=/head/; revision=278018
Diffstat (limited to 'textproc/ts-hunspell/Makefile')
-rw-r--r--textproc/ts-hunspell/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/ts-hunspell/Makefile b/textproc/ts-hunspell/Makefile
new file mode 100644
index 000000000000..d4a880ffa75d
--- /dev/null
+++ b/textproc/ts-hunspell/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ts-hunspell
+# Date created: 2011-07-20
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ts-hunspell
+PORTVERSION= 20110323
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
+MASTER_SITE_SUBDIR= addons/46611
+DISTNAME= tsonga_spell_checker-${PORTVERSION}-tb+sm+fx+fn
+EXTRACT_SUFX= .xpi
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Tsonga hunspell dictionaries
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+PLIST_FILES= share/hunspell/ts_ZA.aff \
+ share/hunspell/ts_ZA.dic
+PLIST_DIRS= share/hunspell
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/hunspell
+ @${INSTALL_DATA} ${WRKDIR}/dictionaries/ts-ZA.aff ${PREFIX}/share/hunspell/ts_ZA.aff
+ @${INSTALL_DATA} ${WRKDIR}/dictionaries/ts-ZA.dic ${PREFIX}/share/hunspell/ts_ZA.dic
+
+.include <bsd.port.mk>