aboutsummaryrefslogtreecommitdiff
path: root/textproc/txt2man/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-05-31 12:26:06 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-05-31 12:26:06 +0000
commitbca23b4a7cc6fe14b4686dfe7cd295e245d32675 (patch)
tree87173c8363040728f77aec832f0954113fb4ed66 /textproc/txt2man/Makefile
parent6c22305b6804f32b37f21eef59461a615f496382 (diff)
downloadports-bca23b4a7cc6fe14b4686dfe7cd295e245d32675.tar.gz
ports-bca23b4a7cc6fe14b4686dfe7cd295e245d32675.zip
Stage support
Notes
Notes: svn path=/head/; revision=355966
Diffstat (limited to 'textproc/txt2man/Makefile')
-rw-r--r--textproc/txt2man/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/textproc/txt2man/Makefile b/textproc/txt2man/Makefile
index e50893d78d25..16144587f847 100644
--- a/textproc/txt2man/Makefile
+++ b/textproc/txt2man/Makefile
@@ -13,13 +13,13 @@ BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= gmake
-INSTALL_TARGET= install prefix=${PREFIX}
+MAKE_ENV= prefix=${STAGEDIR}${PREFIX}
-MAN1= bookman.1 src2man.1 txt2man.1
-PLIST_FILES= bin/bookman bin/src2man bin/txt2man
+PLIST_FILES= bin/bookman bin/src2man bin/txt2man \
+ man/man1/bookman.1.gz man/man1/src2man.1.gz man/man1/txt2man.1.gz
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e "s,awk,gawk," ${WRKSRC}/bookman ${WRKSRC}/src2man
+ @${REINPLACE_CMD} 's,awk,gawk,' ${WRKSRC}/bookman ${WRKSRC}/src2man
+ @${REINPLACE_CMD} '/exec ksh/d' ${WRKSRC}/txt2man
.include <bsd.port.mk>