aboutsummaryrefslogtreecommitdiff
path: root/textproc/uim-m17nlib/Makefile
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-04-16 16:46:19 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-04-16 16:46:19 +0000
commite1cb76089d56bec642118229227e081ccdf4512b (patch)
tree791d8dbfe5990464f48be8c16f33089f5b78bd8c /textproc/uim-m17nlib/Makefile
parentbf53e8b27e3a669fb647cd7cf8cd4ff92b08b5e8 (diff)
downloadports-e1cb76089d56bec642118229227e081ccdf4512b.tar.gz
ports-e1cb76089d56bec642118229227e081ccdf4512b.zip
Add uim-m17nlib. Uim plugin using m17n library input method.
PR: ports/95785 Submitted by: NIIMI Satoshi <sa2c@sa2c.net>
Notes
Notes: svn path=/head/; revision=159732
Diffstat (limited to 'textproc/uim-m17nlib/Makefile')
-rw-r--r--textproc/uim-m17nlib/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/uim-m17nlib/Makefile b/textproc/uim-m17nlib/Makefile
new file mode 100644
index 000000000000..3af87a37ce8d
--- /dev/null
+++ b/textproc/uim-m17nlib/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: uim-m17nlib
+# Date created: 31 August 2003
+# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -m17nlib
+
+COMMENT= Uim plugin using m17n library input method
+
+RUN_DEPENDS= uim-module-manager:${PORTSDIR}/textproc/uim
+LIB_DEPENDS= m17n.1:${PORTSDIR}/devel/m17n-lib
+
+MASTERDIR= ${.CURDIR}/../../textproc/uim
+PKGDIR= ${.CURDIR}
+CONFIGURE_ARGS= --with-m17nlib
+
+UIM_SLAVE= yes
+
+do-install:
+ (cd ${WRKSRC}/uim && \
+ ${GMAKE} uim_plugin_LTLIBRARIES=libuim-m17nlib.la install-uim_pluginLTLIBRARIES)
+
+post-install:
+ uim-module-manager --register m17nlib
+
+.include "${MASTERDIR}/Makefile"