aboutsummaryrefslogtreecommitdiff
path: root/textproc/unroff
diff options
context:
space:
mode:
authorWolfram Schneider <wosch@FreeBSD.org>2003-03-03 23:09:31 +0000
committerWolfram Schneider <wosch@FreeBSD.org>2003-03-03 23:09:31 +0000
commit423e0fbe6eb6d0a0820a24d60c7cf95be1aa6a1d (patch)
tree8a25dbbb1558d49f5ccba861d1d8702cad8812f5 /textproc/unroff
parenta127113f1b163f4adc6fd80eb09db1aa85ea8442 (diff)
downloadports-423e0fbe6eb6d0a0820a24d60c7cf95be1aa6a1d.tar.gz
ports-423e0fbe6eb6d0a0820a24d60c7cf95be1aa6a1d.zip
Unbreak textproc/unroff on FreeBSD-5.x
- fix breakage noticed by bento - de-pkg-comment while here - CFLAG-police - condense makefile, obsolete scripts - honour NOPORTDOCS PR: ports/48795 Submitted by: Volker Stolz <vs@foldr.org>
Notes
Notes: svn path=/head/; revision=76820
Diffstat (limited to 'textproc/unroff')
-rw-r--r--textproc/unroff/Makefile15
-rw-r--r--textproc/unroff/files/patch-a2
-rw-r--r--textproc/unroff/pkg-plist4
-rw-r--r--textproc/unroff/scripts/configure30
4 files changed, 17 insertions, 34 deletions
diff --git a/textproc/unroff/Makefile b/textproc/unroff/Makefile
index 8f262db870fc..35c7dab3543a 100644
--- a/textproc/unroff/Makefile
+++ b/textproc/unroff/Makefile
@@ -14,6 +14,7 @@ DISTNAME= ${PORTNAME}-1.0
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PATCH1} ${PATCH2}
MAINTAINER= wosch@freebsd.org
+COMMENT= A programmable troff translator with backend for HTML
RUN_DEPENDS= elk:${PORTSDIR}/lang/elk
BUILD_DEPENDS= elk:${PORTSDIR}/lang/elk
@@ -26,9 +27,10 @@ UNROFF_SITE= http://www-rn.informatik.uni-bremen.de/software/unroff
PATCH1= me-misc-patch
PATCH2= misc-patch-2
+BUILD_WRKSRC= ${WRKSRC}/src
+
MAN1= unroff.1 unroff-html.1 unroff-html-man.1 \
unroff-html-me.1 unroff-html-ms.1
-MANCOMPRESSED= yes
pre-patch:
@${ECHO_MSG} "===> Applying distribution patches for ${PKGNAME}"
@@ -42,4 +44,15 @@ pre-patch:
fi; \
${PATCH} ${PATCH_DIST_ARGS} -p1 < ${PATCH2})
+do-install:
+ @${MKDIR} ${DATADIR}/misc
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/unroff ${PREFIX}/bin/unroff
+ ${CP} -R ${WRKSRC}/scm ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/tmac.hyper ${WRKSRC}/misc/sample.unroff ${DATADIR}/misc
+ ${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/manual.ms ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/textproc/unroff/files/patch-a b/textproc/unroff/files/patch-a
index 26329063a10c..77df871a8c47 100644
--- a/textproc/unroff/files/patch-a
+++ b/textproc/unroff/files/patch-a
@@ -22,7 +22,7 @@ diff -cr unroff-1.0.orig/src/Makefile unroff-1.0/src/Makefile
### You need a C compiler that compiles ANSI C code.
! #CC = gcc
-! #CFLAGS = -Wall -pedantic -O
+! CFLAGS += -DBSD
### If you need additional linker flags add them here.
! LDFLAGS = -s
diff --git a/textproc/unroff/pkg-plist b/textproc/unroff/pkg-plist
index 5220d5168cb6..5c2a325ffd12 100644
--- a/textproc/unroff/pkg-plist
+++ b/textproc/unroff/pkg-plist
@@ -1,5 +1,4 @@
bin/unroff
-share/unroff/doc/manual.ms
share/unroff/misc/sample.unroff
share/unroff/misc/tmac.hyper
share/unroff/scm/troff.scm
@@ -14,7 +13,8 @@ share/unroff/scm/html/ms.scm
share/unroff/scm/html/ms.scm.orig
share/unroff/scm/misc/hyper.scm
share/unroff/scm/misc/hyper.scm.orig
-@dirrm share/unroff/doc
+%%PORTDOCS%%share/doc/unroff/manual.ms
+%%PORTDOCS%%@dirrm share/doc/unroff
@dirrm share/unroff/misc
@dirrm share/unroff/scm/html
@dirrm share/unroff/scm/misc
diff --git a/textproc/unroff/scripts/configure b/textproc/unroff/scripts/configure
deleted file mode 100644
index 07313cf231a6..000000000000
--- a/textproc/unroff/scripts/configure
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/bin/sh
-
-# write a small makefile to ${WRKSRC}
-
-cat >${WRKSRC}/Makefile <<EOF
-CFLAGS+= -DBSD
-BINDIR= \${PREFIX}/bin
-LIBDIR= \${PREFIX}/share/unroff
-MANDIR= \${PREFIX}/man/man1
-
-all:
- (cd src; make 'CFLAGS=\${CFLAGS}' 'PREFIX=\${PREFIX}' all)
-
-install:
- @mkdir -p \${BINDIR} \${LIBDIR} \${MANDIR}
- install -c -o bin -g bin src/unroff \${PREFIX}/bin/unroff
- cp -R scm \${LIBDIR}
- @mkdir -p \${LIBDIR}/doc
- cp doc/manual.ms \${LIBDIR}/doc
- @mkdir -p \${LIBDIR}/misc
- cp doc/tmac.hyper misc/sample.unroff \${LIBDIR}/misc
- @chown -R bin.bin \${LIBDIR}
- install -c -m 644 -o bin -g bin doc/*.1 \${MANDIR}
-.if !defined(NOMANCOMPRESS)
- gzip -9nf \${MANDIR}/unroff*.1
-.endif
-
-EOF
-
-exit 0