aboutsummaryrefslogtreecommitdiff
path: root/textproc/unroff
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-11-09 01:39:22 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-11-09 01:39:22 +0000
commitd4754d3fd3a10ebab953d077c11bcb2d3b5ec391 (patch)
treec73ba1d965d10c2f1f875d732c65c08c8092825d /textproc/unroff
parent486ce86b4ea43a7ee9721d1bb4fb7617c193424d (diff)
downloadports-d4754d3fd3a10ebab953d077c11bcb2d3b5ec391.tar.gz
ports-d4754d3fd3a10ebab953d077c11bcb2d3b5ec391.zip
- Fix build
- Utilize DATADIR/DOCSDIR PR: 59012 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=93484
Diffstat (limited to 'textproc/unroff')
-rw-r--r--textproc/unroff/Makefile53
-rw-r--r--textproc/unroff/distinfo4
-rw-r--r--textproc/unroff/files/patch-a111
-rw-r--r--textproc/unroff/files/patch-c14
-rw-r--r--textproc/unroff/pkg-plist43
5 files changed, 101 insertions, 124 deletions
diff --git a/textproc/unroff/Makefile b/textproc/unroff/Makefile
index 69756c5aef51..e4b053d252af 100644
--- a/textproc/unroff/Makefile
+++ b/textproc/unroff/Makefile
@@ -7,51 +7,38 @@
PORTNAME= unroff
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= textproc
-MASTER_SITES= ${UNROFF_SITE}/dist/ \
- ${UNROFF_SITE}/contrib/
-DISTNAME= ${PORTNAME}-1.0
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PATCH1} ${PATCH2}
-
-MAINTAINER= ports@freebsd.org
-COMMENT= A programmable troff translator with backend for HTML
-
-RUN_DEPENDS= elk:${PORTSDIR}/lang/elk
-BUILD_DEPENDS= elk:${PORTSDIR}/lang/elk
+MASTER_SITES= http://www-rn.informatik.uni-bremen.de/software/unroff/%SUBDIR%/
+MASTER_SITE_SUBDIR= dist
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}
+DIST_SUBDIR= unroff
-BROKEN= "Does not build; will be removed after Feb 2"
+PATCH_SITES= ${MASTER_SITES}
+PATCH_SITE_SUBDIR= contrib
+PATCHFILES= me-misc-patch.gz misc-patch-2.gz
+PATCH_DIST_STRIP= -p1
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-DIST_SUBDIR= unroff
-PATCH_STRIP= -p1
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A programmable troff translator with backend for HTML
-UNROFF_SITE= http://www-rn.informatik.uni-bremen.de/software/unroff
-PATCH1= me-misc-patch
-PATCH2= misc-patch-2
+LIB_DEPENDS= elk.0:${PORTSDIR}/lang/elk
BUILD_WRKSRC= ${WRKSRC}/src
MAN1= unroff.1 unroff-html.1 unroff-html-man.1 \
unroff-html-me.1 unroff-html-ms.1
-pre-patch:
- @${ECHO_MSG} "===> Applying distribution patches for ${PKGNAME}"
- @(cd ${_DISTDIR}; \
- if [ ${PATCH_DEBUG_TMP} = yes ]; then \
- ${ECHO_MSG} "===> Applying distribution patch ${PATCH1}" ; \
- fi; \
- ${PATCH} ${PATCH_DIST_ARGS} -p0 < ${PATCH1}; \
- if [ ${PATCH_DEBUG_TMP} = yes ]; then \
- ${ECHO_MSG} "===> Applying distribution patch ${PATCH2}" ; \
- fi; \
- ${PATCH} ${PATCH_DIST_ARGS} -p1 < ${PATCH2})
-
do-install:
- @${MKDIR} ${DATADIR}/misc
- ${INSTALL_PROGRAM} ${WRKSRC}/src/unroff ${PREFIX}/bin/unroff
- ${CP} -R ${WRKSRC}/scm ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/tmac.hyper ${WRKSRC}/misc/sample.unroff ${DATADIR}/misc
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/unroff ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${PREFIX}/man/man1
+ @${MKDIR} ${DATADIR}/misc
+.for i in doc/tmac.hyper misc/sample.unroff
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DATADIR}/misc
+.endfor
+ ${TAR} -C ${WRKSRC} -cf - scm | \
+ ${TAR} -C ${DATADIR} --unlink -xf -
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/manual.ms ${DOCSDIR}
diff --git a/textproc/unroff/distinfo b/textproc/unroff/distinfo
index 0b0b28d29aa9..d533e643efa3 100644
--- a/textproc/unroff/distinfo
+++ b/textproc/unroff/distinfo
@@ -1,3 +1,3 @@
MD5 (unroff/unroff-1.0.tar.gz) = 918e9c065cb7486c4b885da7809f37e7
-MD5 (unroff/me-misc-patch) = e0cfe9a5012f573cf774115562f4462e
-MD5 (unroff/misc-patch-2) = ebedbf1a8dccfeb5ef3f996ba15374b2
+MD5 (unroff/me-misc-patch.gz) = a6af8590955e5a54e399cf0ab01fc9c4
+MD5 (unroff/misc-patch-2.gz) = b941bcec35911cbe117a392e07bba4df
diff --git a/textproc/unroff/files/patch-a b/textproc/unroff/files/patch-a
index 77df871a8c47..ec6d4a526513 100644
--- a/textproc/unroff/files/patch-a
+++ b/textproc/unroff/files/patch-a
@@ -1,68 +1,43 @@
-diff -cr unroff-1.0.orig/src/Makefile unroff-1.0/src/Makefile
-*** unroff-1.0.orig/src/Makefile Wed Aug 23 14:12:48 1995
---- unroff-1.0/src/Makefile Mon Feb 12 18:51:08 1996
-***************
-*** 1,14 ****
- # $Revision: 1.12 $
-
- ### You need a C compiler that compiles ANSI C code.
-! CC = gcc
-! CFLAGS = -Wall -pedantic -O
-
- ### If you need additional linker flags add them here.
-! LDFLAGS =
-
- ### The directory where the Elk installation resides on your system.
-! ELKDIR = /usr/elk
-
- ### Additional libraries. You may want to insert the output of the
- ### shell-script $(ELKDIR)/lib/ldflags here.
---- 1,14 ----
- # $Revision: 1.12 $
-
- ### You need a C compiler that compiles ANSI C code.
-! #CC = gcc
-! CFLAGS += -DBSD
-
- ### If you need additional linker flags add them here.
-! LDFLAGS = -s
-
- ### The directory where the Elk installation resides on your system.
-! ELKDIR = ${PREFIX}/share/elk
-
- ### Additional libraries. You may want to insert the output of the
- ### shell-script $(ELKDIR)/lib/ldflags here.
-***************
-*** 18,24 ****
- MAKEDEP = makedepend
-
- ### The directory under which you will install the Scheme files.
-! DIR = /usr/local/lib/unroff
-
- ### The default output format.
- FORMAT = html
---- 18,24 ----
- MAKEDEP = makedepend
-
- ### The directory under which you will install the Scheme files.
-! DIR = ${PREFIX}/share/unroff
-
- ### The default output format.
- FORMAT = html
-***************
-*** 30,36 ****
- ### -------------------------------------------------------------------------
-
- SHELL = /bin/sh
-! INCLUDE = -I$(ELKDIR)/include
- ELK = $(ELKDIR)/lib/module.o
- DEFS = -DDEFAULT_DIR=\"$(DIR)\" -DDEFAULT_FORMAT=\"$(FORMAT)\"
- CTAGS = ctags -t -w
---- 30,36 ----
- ### -------------------------------------------------------------------------
-
- SHELL = /bin/sh
-! INCLUDE = -I${PREFIX}/include/elk
- ELK = $(ELKDIR)/lib/module.o
- DEFS = -DDEFAULT_DIR=\"$(DIR)\" -DDEFAULT_FORMAT=\"$(FORMAT)\"
- CTAGS = ctags -t -w
+--- src/Makefile.orig Wed Aug 23 21:12:48 1995
++++ src/Makefile Thu Nov 6 22:21:29 2003
+@@ -1,24 +1,24 @@
+ # $Revision: 1.12 $
+
+ ### You need a C compiler that compiles ANSI C code.
+-CC = gcc
+-CFLAGS = -Wall -pedantic -O
++#CC = gcc
++CFLAGS += -DBSD
+
+ ### If you need additional linker flags add them here.
+ LDFLAGS =
+
+ ### The directory where the Elk installation resides on your system.
+-ELKDIR = /usr/elk
++ELKDIR = ${PREFIX}/share/elk
+
+ ### Additional libraries. You may want to insert the output of the
+ ### shell-script $(ELKDIR)/lib/ldflags here.
+-LIBS = -lm
++LIBS = -lm -lelk -L${LOCALBASE}/lib
+
+ ### The makedepend program (it's usually installed with the X11 binaries).
+ MAKEDEP = makedepend
+
+ ### The directory under which you will install the Scheme files.
+-DIR = /usr/local/lib/unroff
++DIR = ${PREFIX}/share/unroff
+
+ ### The default output format.
+ FORMAT = html
+@@ -30,8 +30,8 @@
+ ### -------------------------------------------------------------------------
+
+ SHELL = /bin/sh
+-INCLUDE = -I$(ELKDIR)/include
+-ELK = $(ELKDIR)/lib/module.o
++INCLUDE = -I${LOCALBASE}/include/elk
++#ELK = $(ELKDIR)/lib/module.o
+ DEFS = -DDEFAULT_DIR=\"$(DIR)\" -DDEFAULT_FORMAT=\"$(FORMAT)\"
+ CTAGS = ctags -t -w
+
diff --git a/textproc/unroff/files/patch-c b/textproc/unroff/files/patch-c
new file mode 100644
index 000000000000..7f39b85b84f2
--- /dev/null
+++ b/textproc/unroff/files/patch-c
@@ -0,0 +1,14 @@
+--- src/error.h.orig Fri Jun 2 22:16:01 1995
++++ src/error.h Thu Nov 6 22:13:38 2003
+@@ -12,9 +12,11 @@
+ void write_error(char *) NORETURN;
+ void open_error(char *) NORETURN;
+
++#if 0
+ /* Redefined to add NORETURN
+ */
+ extern Primitive_Error() NORETURN;
++#endif
+
+ char *printable_string(char *, int);
+ char *printable_char(char);
diff --git a/textproc/unroff/pkg-plist b/textproc/unroff/pkg-plist
index 5c2a325ffd12..5e1d43b94935 100644
--- a/textproc/unroff/pkg-plist
+++ b/textproc/unroff/pkg-plist
@@ -1,22 +1,23 @@
+@comment $FreeBSD$
bin/unroff
-share/unroff/misc/sample.unroff
-share/unroff/misc/tmac.hyper
-share/unroff/scm/troff.scm
-share/unroff/scm/troff.scm.orig
-share/unroff/scm/html/common.scm
-share/unroff/scm/html/common.scm.orig
-share/unroff/scm/html/m.scm
-share/unroff/scm/html/man.scm
-share/unroff/scm/html/me.scm
-share/unroff/scm/html/me.scm.orig
-share/unroff/scm/html/ms.scm
-share/unroff/scm/html/ms.scm.orig
-share/unroff/scm/misc/hyper.scm
-share/unroff/scm/misc/hyper.scm.orig
-%%PORTDOCS%%share/doc/unroff/manual.ms
-%%PORTDOCS%%@dirrm share/doc/unroff
-@dirrm share/unroff/misc
-@dirrm share/unroff/scm/html
-@dirrm share/unroff/scm/misc
-@dirrm share/unroff/scm
-@dirrm share/unroff
+%%PORTDOCS%%%%DOCSDIR%%/manual.ms
+%%DATADIR%%/misc/sample.unroff
+%%DATADIR%%/misc/tmac.hyper
+%%DATADIR%%/scm/troff.scm
+%%DATADIR%%/scm/troff.scm.orig
+%%DATADIR%%/scm/html/common.scm
+%%DATADIR%%/scm/html/common.scm.orig
+%%DATADIR%%/scm/html/m.scm
+%%DATADIR%%/scm/html/man.scm
+%%DATADIR%%/scm/html/me.scm
+%%DATADIR%%/scm/html/me.scm.orig
+%%DATADIR%%/scm/html/ms.scm
+%%DATADIR%%/scm/html/ms.scm.orig
+%%DATADIR%%/scm/misc/hyper.scm
+%%DATADIR%%/scm/misc/hyper.scm.orig
+@dirrm %%DATADIR%%/scm/misc
+@dirrm %%DATADIR%%/scm/html
+@dirrm %%DATADIR%%/scm
+@dirrm %%DATADIR%%/misc
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%