aboutsummaryrefslogtreecommitdiff
path: root/textproc/wordnet/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2006-01-16 03:48:42 +0000
committerMikhail Teterin <mi@FreeBSD.org>2006-01-16 03:48:42 +0000
commit8ebfc55a6eebdea8999a838c47b84ac3aae8f8e4 (patch)
treec34641f77bda875b1082c7958d2dd3241ea893d6 /textproc/wordnet/Makefile
parent360872c2f7438b258e1e9cbd7473f7abeffb1338 (diff)
downloadports-8ebfc55a6eebdea8999a838c47b84ac3aae8f8e4.tar.gz
ports-8ebfc55a6eebdea8999a838c47b84ac3aae8f8e4.zip
Finally update from 2.0 to 2.1. "Heavy Patching Zone" ensures WARNS=5
cleanliness in the main library (diffs to be sent to the vendor as in the past). The installed library is now called libWN, as vendor's build would call it, rather than libwn2, as the previous version of the port called it. This may upset the client port of p5 -- the maintainer is notified and awaits this commit. PR: ports/90323 Submitted by: clsung
Notes
Notes: svn path=/head/; revision=153618
Diffstat (limited to 'textproc/wordnet/Makefile')
-rw-r--r--textproc/wordnet/Makefile25
1 files changed, 5 insertions, 20 deletions
diff --git a/textproc/wordnet/Makefile b/textproc/wordnet/Makefile
index 7684e96ebc74..9d87f57b162f 100644
--- a/textproc/wordnet/Makefile
+++ b/textproc/wordnet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= WordNet
-PORTVERSION= 2.0
+PORTVERSION= 2.1
CATEGORIES= textproc
MASTER_SITES= ftp://ftp.cogsci.princeton.edu/pub/wordnet/${PORTVERSION}/ \
http://www.cogsci.princeton.edu/${PORTVERSION}/ \
@@ -17,14 +17,6 @@ COMMENT= Dictionaries and thesauri with devel. libraries (C, TCL) and browsers
LIB_DEPENDS= tk${TCL_VER}:${PORTSDIR}/x11-toolkits/tk${TCL_VER}
-# The vendor packages up a lot of useless precompiled binaries
-# for a few platforms with the source code. Do not extract them:
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude '*/bin/*' \
- --exclude '*/lib/solaris/*' \
- --exclude '*/lib/linux/*' \
- --exclude '*/lib/irix/*' \
- --exclude '*/*.[ao]'
-
TCL_DVER?= 8.4
TCL_VER= ${TCL_DVER:C/\.//}
SCRIPTS_ENV+= TCL_DVER=${TCL_DVER} VER=${PORTVERSION}
@@ -35,15 +27,8 @@ REINPLACE_ARGS= -i ""
INSTALLS_SHLIB= yes
post-patch:
- ${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' \
- -e 's,_VER_,${PORTVERSION},g' ${WRKSRC}/include/wnconsts.h \
- ${WRKSRC}/src/wnb/wnb
-
-.include <bsd.port.pre.mk>
-
-.for s in 1 3 5 7
-MAN$s!= ${MAKE} -f ${FILESDIR}/man.Makefile -V MAN$s
-.endfor
-MANCOMPRESSED= maybe
+ ${REINPLACE_CMD} -e 's,/usr/local/WordNet-2.1,${DATADIR},g' \
+ ${WRKSRC}/src/wnb ${WRKSRC}/doc/man/*.?
+ ${REINPLACE_CMD} -e 's, *\\n,\\n,' ${WRKSRC}/include/wn.h
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>