aboutsummaryrefslogtreecommitdiff
path: root/textproc/wordnet
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-10-31 05:04:29 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-10-31 05:04:29 +0000
commit7e04dc48fd8b42fb3951ce1736e8c229d122d48e (patch)
tree8b7ff7b8d2ab75b39b6294ca28a9579915923413 /textproc/wordnet
parent6c5b827b78fea2c1a0f42738b1921608e71e9e91 (diff)
downloadports-7e04dc48fd8b42fb3951ce1736e8c229d122d48e.tar.gz
ports-7e04dc48fd8b42fb3951ce1736e8c229d122d48e.zip
Upgrade to 1.7. For changes see
ftp://ftp.cogsci.princeton.edu/pub/wordnet/1.7/CHANGES
Notes
Notes: svn path=/head/; revision=49410
Diffstat (limited to 'textproc/wordnet')
-rw-r--r--textproc/wordnet/Makefile28
-rw-r--r--textproc/wordnet/distinfo3
-rw-r--r--textproc/wordnet/files/dict.Makefile7
-rw-r--r--textproc/wordnet/files/include.Makefile2
-rw-r--r--textproc/wordnet/files/man.Makefile2
-rw-r--r--textproc/wordnet/files/patch-aa6
-rw-r--r--textproc/wordnet/files/patch-ac6
-rw-r--r--textproc/wordnet/files/patch-ae9
-rw-r--r--textproc/wordnet/files/patch-official122
-rw-r--r--textproc/wordnet/files/src.lib.Makefile4
-rw-r--r--textproc/wordnet/files/src.wn.Makefile2
-rw-r--r--textproc/wordnet/files/src.wnb.Makefile8
-rw-r--r--textproc/wordnet/pkg-plist73
13 files changed, 75 insertions, 197 deletions
diff --git a/textproc/wordnet/Makefile b/textproc/wordnet/Makefile
index 521dbdb0c36d..13d769cc548e 100644
--- a/textproc/wordnet/Makefile
+++ b/textproc/wordnet/Makefile
@@ -6,33 +6,29 @@
#
PORTNAME= wordnet
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= textproc
-MASTER_SITES= ftp://ftp.cogsci.princeton.edu/pub/wordnet/ \
+MASTER_SITES= ftp://ftp.cogsci.princeton.edu/pub/wordnet/${PORTVERSION}/ \
ftp://ftp.ims.uni-stuttgart.de/pub/WordNet/${PORTVERSION}/
-DISTFILES= wn16.unix.tar.gz
+DISTFILES= wn${PORTVERSION:S/.//}.unix.tar.gz
MAINTAINER= mi@aldan.algebra.com
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
-MAN1= wn.1 wnb.1 wnintro.1
-MAN3= binsrch.3 morph.3 wnintro.3 wnsearch.3 wnutil.3
-MAN5= cntlist.5 glossidx.5 lexnames.5 senseidx.5 taglist.5 \
- wndb.5 wninput.5 wnintro.5
-MAN7= morphy.7 uniqbeg.7 wngloss.7 wngroups.7 wnintro.7 \
- wnlicens.7 wnpkgs.7 wnstats.7
-MANCOMPRESSED= maybe
-
TCL_DVER= 8.3
SCRIPTS_ENV+= TCL_DVER=${TCL_DVER}
MAKE_ENV+= TCL_DVER=${TCL_DVER}
-PLIST_SUB+= TCL_DVER=${TCL_DVER}
+PLIST_SUB+= TCL_DVER=${TCL_DVER} VER=${PORTVERSION}
# Parallel build is faster even on a single cpu machine:
MAKE_ARGS= -j 2
+NO_WRKSUBDIR= yes
-post-extract:
- # bin and lib contain useless pre-built binaries:
- ${RM} -rf ${WRKSRC}/bin ${WRKSRC}/lib
+.include <bsd.port.pre.mk>
+
+.for s in 1 3 5 7
+MAN$s!= ${MAKE} -f ${FILESDIR}/man.Makefile -V MAN$s
+.endfor
+MANCOMPRESSED= maybe
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/wordnet/distinfo b/textproc/wordnet/distinfo
index b8e43032a886..aaa3d5c8ec54 100644
--- a/textproc/wordnet/distinfo
+++ b/textproc/wordnet/distinfo
@@ -1,2 +1 @@
-MD5 (wn16.unix.tar.gz) = cb6b9cedd139cacb5928c4fb49b4b7a6
-MD5 (semcor16.tar.gz) = 1a635e2ff96145c4308188e056448deb
+MD5 (wn17.unix.tar.gz) = 96a1c6d54ed19edd8e44e51042364c7d
diff --git a/textproc/wordnet/files/dict.Makefile b/textproc/wordnet/files/dict.Makefile
index a9ce4da4a2cb..dccae6a07a6f 100644
--- a/textproc/wordnet/files/dict.Makefile
+++ b/textproc/wordnet/files/dict.Makefile
@@ -1,9 +1,8 @@
-WN_INSTALLDIR= ${PREFIX}/share/wordnet-1.6
+WN_INSTALLDIR= ${PREFIX}/share/wordnet-1.7
WN_FILES= data.noun data.verb data.adj data.adv index.noun \
index.verb index.adj index.adv noun.exc verb.exc \
- adj.exc adv.exc cousin.exc cousin.tops index.sense \
- cntlist lexnames index.gloss sentidx.vrb sents.vrb \
- stoplist.pl
+ adj.exc adv.exc index.sense cntlist.rev \
+ cntlist lexnames sentidx.vrb sents.vrb
all: $(WN_FILES)
diff --git a/textproc/wordnet/files/include.Makefile b/textproc/wordnet/files/include.Makefile
index c3a9f88e38ab..dc2d1b1049e5 100644
--- a/textproc/wordnet/files/include.Makefile
+++ b/textproc/wordnet/files/include.Makefile
@@ -1,4 +1,4 @@
-WN_INSTALLDIR = ${PREFIX}/include/wordnet-1.6
+WN_INSTALLDIR = ${PREFIX}/include/wordnet-1.7
WN_FILES= license.h setutil.h wn.h wnconsts.h wnglobal.h \
wnhelp.h wnrtl.h wntypes.h
diff --git a/textproc/wordnet/files/man.Makefile b/textproc/wordnet/files/man.Makefile
index 0b9f44911a46..fc75eeceb498 100644
--- a/textproc/wordnet/files/man.Makefile
+++ b/textproc/wordnet/files/man.Makefile
@@ -2,7 +2,7 @@ MANDIR= ${PREFIX}/man/man
MAN1= wn.1 wnb.1 wnintro.1
MAN3= binsrch.3 morph.3 wnintro.3 wnsearch.3 wnutil.3
-MAN5= cntlist.5 glossidx.5 lexnames.5 senseidx.5 taglist.5 \
+MAN5= cntlist.5 lexnames.5 senseidx.5 \
wndb.5 wninput.5 wnintro.5
MAN7= morphy.7 uniqbeg.7 wngloss.7 wngroups.7 wnintro.7 \
wnlicens.7 wnpkgs.7 wnstats.7
diff --git a/textproc/wordnet/files/patch-aa b/textproc/wordnet/files/patch-aa
index 752d86d809d3..6e194dff90de 100644
--- a/textproc/wordnet/files/patch-aa
+++ b/textproc/wordnet/files/patch-aa
@@ -1,10 +1,10 @@
--- include/wnconsts.h Fri Feb 27 13:54:53 1998
+++ include/wnconsts.h Sat Feb 26 16:11:51 2000
@@ -16,2 +16,6 @@
--#define DEFAULTPATH "/usr/local/wordnet1.6/dict"
--#define DEFAULTBIN "/usr/local/wordnet1.6/bin"
+-#define DEFAULTPATH "/usr/local/wordnet1.7/dict"
+-#define DEFAULTBIN "/usr/local/wordnet1.7/bin"
+#ifndef DEFAULTPATH
-+#define DEFAULTPATH "/usr/local/share/wordnet-1.6"
++#define DEFAULTPATH "/usr/local/share/wordnet-1.7"
+#endif
+#ifndef DEFAULTBIN
+#define DEFAULTBIN "/usr/local/bin"
diff --git a/textproc/wordnet/files/patch-ac b/textproc/wordnet/files/patch-ac
index 8e4e78294643..97c57f010d94 100644
--- a/textproc/wordnet/files/patch-ac
+++ b/textproc/wordnet/files/patch-ac
@@ -9,7 +9,7 @@
- int argc, char *argv[]) {
+ int argc, Tcl_Obj *objv[]) {
unsigned int bitfield;
-- char bitfieldstr[32];
+- static char bitfieldstr[32];
char *morph;
@@ -43,9 +41,10 @@
if (argc != 3) {
@@ -37,7 +37,7 @@
int wn_bit (ClientData clientData, Tcl_Interp *interp,
- int argc, char *argv[]) {
- unsigned int bitfield;
-- char bitfieldstr[32];
+- static char bitfieldstr[32];
+ int argc, Tcl_Obj *objv[]) {
int whichbit;
if (argc != 2) {
@@ -64,5 +64,5 @@
@@ -295,3 +290,3 @@
(ClientData) NULL, (Tcl_CmdDeleteProc *) NULL);
- return TCL_OK;
-+ return Tcl_PkgProvide(interp, "Wordnet", "1.6");
++ return Tcl_PkgProvide(interp, "Wordnet", "1.7");
}
diff --git a/textproc/wordnet/files/patch-ae b/textproc/wordnet/files/patch-ae
new file mode 100644
index 000000000000..38d94675e1a8
--- /dev/null
+++ b/textproc/wordnet/files/patch-ae
@@ -0,0 +1,9 @@
+--- src/lib/search.c Tue Jun 19 11:02:47 2001
++++ src/lib/search.c Tue Oct 30 23:11:26 2001
+@@ -2051,5 +2051,5 @@
+ passed and return bit mask. */
+
+-unsigned int is_defined(char *searchstr, int dbase)
++unsigned long is_defined(char *searchstr, int dbase)
+ {
+ IndexPtr index;
diff --git a/textproc/wordnet/files/patch-official b/textproc/wordnet/files/patch-official
deleted file mode 100644
index 1701ab0ccb2a..000000000000
--- a/textproc/wordnet/files/patch-official
+++ /dev/null
@@ -1,122 +0,0 @@
-This patch mostly contains the differences between the search.c as in
-the released version 1.6 vs. the later version found in
- ftp://ftp.cogsci.princeton.edu/pub/wordnet/bugfixes/
-
-I also modified the groupexc function to fix the problem documented in
- ftp://ftp.cogsci.princeton.edu/pub/wordnet/README.bugs
-(buf[8] vs. buf[9] -- point 5 at the bottom) and modified it to avoid
-allocating 1Kb from the stack and needlessly strcpy the argument given.
-Nothing gets written into the string anyway, and we can examine it
-without making a duplicate copy. -mi
-
---- src/lib/search.c Fri Nov 7 11:27:45 1997
-+++ src/lib/search.c Fri Aug 7 12:57:08 1998
-@@ -19,3 +19,3 @@
-
--static char *Id = "$Id: search.c,v 1.134 1997/11/07 16:27:36 wn Exp $";
-+static char *Id = "$Id: search.c,v 1.136 1998/08/07 17:51:32 wn Exp $";
-
-@@ -448,2 +448,7 @@
-
-+ /* Can't do earlier - calls indexlookup which messes up strtok calls */
-+
-+ for (i = 0; i < synptr->wcount; i++)
-+ synptr->wnsns[i] = getsearchsense(synptr, i + 1);
-+
- return(synptr);
-@@ -588,3 +593,3 @@
- sprintf(tbuf, " (Sense %d)\n",
-- getsearchsense(cursyn, synptr->pto[i]));
-+ cursyn->wnsns[synptr->pto[i] - 1]);
- printsynset(prefix, cursyn, tbuf, DEFOFF, synptr->pto[i],
-@@ -1405,16 +1405,15 @@
-
- static int groupexc(unsigned long off1, unsigned long off2)
- {
-- char buf[8], *p, linebuf[1024];
-+ char buf[9], *p, *line;
-
- sprintf(buf, "%8.8lu", (off1 < off2 ? off1 : off2));
-
- if ((p = bin_search(buf, cousinexcfp)) != NULL) {
- sprintf(buf, "%8.8lu", (off2 > off1 ? off2 : off1));
-- strcpy(linebuf, p + 9); /* don't copy key */
-- linebuf[strlen(linebuf) - 1] = '\0'; /* strip off newline */
-- p = strtok(linebuf, " ");
-- while (p && strcmp(p, buf))
-+ line = p + 9; /* ignore the key */
-+ p = strtok(line, " ");
-+ while (p && strncmp(p, buf, 8))
- p = strtok(NULL, " ");
- }
- return(p ? 1 : 0);
-@@ -1775,2 +1780,8 @@
- wnresults.numforms++;
-+
-+ if (ptrtyp == COORDS) { /* clean up by removing hypernym */
-+ lastsyn = synlist->ptrlist;
-+ synlist->ptrlist = lastsyn->ptrlist;
-+ free_synset(lastsyn);
-+ }
- }
-@@ -1781,3 +1792,3 @@
- /* Recursive search algorithm to trace a pointer tree and return results
-- in linked list of data structures. */
-+ in linked list of data structures. */
-
-@@ -1785,4 +1796,5 @@
- {
-- int i;
-+ int i, j;
- SynsetPtr cursyn, synlist = NULL, lastsyn = NULL;
-+ int tstptrtyp, docoords;
-
-@@ -1805,5 +1817,13 @@
- }
--
-+
-+ if (ptrtyp == COORDS) {
-+ tstptrtyp = HYPERPTR;
-+ docoords = 1;
-+ } else {
-+ tstptrtyp = ptrtyp;
-+ docoords = 0;
-+ }
-+
- for (i = 0; i < synptr->ptrcount; i++) {
-- if((synptr->ptrtyp[i] == ptrtyp) &&
-+ if((synptr->ptrtyp[i] == tstptrtyp) &&
- ((synptr->pfrm[i] == 0) ||
-@@ -1814,5 +1834,2 @@
-
-- for (i = 0; i < cursyn->wcount; i++)
-- cursyn->wnsns[i] = getsearchsense(cursyn, i + 1);
--
- if (lastsyn)
-@@ -1828,3 +1845,5 @@
- (depth+1));
-- }
-+ } else if (docoords) {
-+ cursyn->ptrlist = traceptrs_ds(cursyn, HYPOPTR, NOUN, 0);
-+ }
- }
-@@ -2193,3 +2212,3 @@
- if (wnsnsflag)
-- sprintf(buf + strlen(buf), "#%d", getsearchsense(synptr, wdnum + 1));
-+ sprintf(buf + strlen(buf), "#%d", synptr->wnsns[wdnum]);
-
-@@ -2246,3 +2265,3 @@
- sprintf(tbuf + strlen(tbuf), "#%d",
-- getsearchsense(psynptr, wdoff + 1));
-+ psynptr->wnsns[wdoff]);
- if (!first)
-@@ -2333,2 +2352,9 @@
- $Log: search.c,v $
-+ * Revision 1.136 1998/08/07 17:51:32 wn
-+ * added COORDS to traceptrs_ds and findtheinfo_ds
-+ * fixed getsearchsense code to only happen in parse_synset
-+ *
-+ * Revision 1.135 1998/08/07 13:04:24 wn
-+ * *** empty log message ***
-+ *
- * Revision 1.134 1997/11/07 16:27:36 wn
diff --git a/textproc/wordnet/files/src.lib.Makefile b/textproc/wordnet/files/src.lib.Makefile
index 97e48f59fdb4..404fb842d279 100644
--- a/textproc/wordnet/files/src.lib.Makefile
+++ b/textproc/wordnet/files/src.lib.Makefile
@@ -1,13 +1,13 @@
SRCS= binsrch.c morph.c search.c setutil.c wnglobal.c \
wnhelp.c wnrtl.c wnutil.c
-CFLAGS+= -DUNIX -DDEFAULTPATH="\"${PREFIX}/share/wordnet-1.6\"" \
+CFLAGS+= -DUNIX -DDEFAULTPATH="\"${PREFIX}/share/wordnet-1.7\"" \
-DDEFAULTBIN="\"${PREFIX}/bin\"" -Werror
CFLAGS+= -I${.CURDIR}/../../include
LIB= wn1
-SHLIB_MAJOR= 6
+SHLIB_MAJOR= 7
SHLIB_MINOR= 0
NOPROFILE= True
diff --git a/textproc/wordnet/files/src.wn.Makefile b/textproc/wordnet/files/src.wn.Makefile
index 5bfe8139bb0c..aeb5e3239ab4 100644
--- a/textproc/wordnet/files/src.wn.Makefile
+++ b/textproc/wordnet/files/src.wn.Makefile
@@ -1,7 +1,7 @@
PROG= wn
NOMAN= True # man pages installed separately
-CFLAGS+= -DUNIX -DDEFAULTPATH="\"${PREFIX}/share/wordnet-1.6\"" \
+CFLAGS+= -DUNIX -DDEFAULTPATH="\"${PREFIX}/share/wordnet-1.7\"" \
-DDEFAULTBIN="\"${PREFIX}/bin\""
CFLAGS+= -I${.CURDIR}/../../include
diff --git a/textproc/wordnet/files/src.wnb.Makefile b/textproc/wordnet/files/src.wnb.Makefile
index dd30a1c61a8a..618ac05854e6 100644
--- a/textproc/wordnet/files/src.wnb.Makefile
+++ b/textproc/wordnet/files/src.wnb.Makefile
@@ -3,7 +3,7 @@ TCL_DVER?= 8.3
TCL_VER= ${TCL_DVER:S/.//g}
TCL_INCDIR?= ${PREFIX}/include/tcl${TCL_DVER}
-CFLAGS+= -DUNIX -DDEFAULTPATH="\"${PREFIX}/share/wordnet-1.6\"" \
+CFLAGS+= -DUNIX -DDEFAULTPATH="\"${PREFIX}/share/wordnet-1.7\"" \
-DDEFAULTBIN="\"${PREFIX}/bin\""
CFLAGS+= -I${.CURDIR}/../../include -I$(TCL_INCDIR)
@@ -11,7 +11,7 @@ CFLAGS+= -I${.CURDIR}/../../include -I$(TCL_INCDIR)
LDADD= -L../lib -lwn1 -L${PREFIX}/lib -ltcl${TCL_VER} -ltk${TCL_VER}
LIB= tclwn1
-SHLIB_MAJOR= 6
+SHLIB_MAJOR= 7
SHLIB_MINOR= 0
SRCS= stubs.c
@@ -20,12 +20,12 @@ INTERNALLIB= True # To avoid building the useless static library
all: ${SHLIB_NAME} pkgIndex.tcl
pkgIndex.tcl:
- echo "package ifneeded Wordnet 1.6 [list load \
+ echo "package ifneeded Wordnet 1.7 [list load \
[file join ${PREFIX}/lib ${SHLIB_NAME}] Wordnet]" \
> pkgIndex.tcl
LIBDIR= ${PREFIX}/lib
-RESDIR= ${PREFIX}/share/wordnet-1.6/wnres
+RESDIR= ${PREFIX}/share/wordnet-1.7/wnres
${LIBDIR} ${RESDIR} ${LIBDIR}/tcl${TCL_DVER}/Wordnet:
mkdir -p ${.TARGET}
diff --git a/textproc/wordnet/pkg-plist b/textproc/wordnet/pkg-plist
index cf183b0669f0..2d7543b29388 100644
--- a/textproc/wordnet/pkg-plist
+++ b/textproc/wordnet/pkg-plist
@@ -1,45 +1,42 @@
bin/wnb
bin/wn
-include/wordnet-1.6/license.h
-include/wordnet-1.6/setutil.h
-include/wordnet-1.6/wn.h
-include/wordnet-1.6/wnconsts.h
-include/wordnet-1.6/wnglobal.h
-include/wordnet-1.6/wnhelp.h
-include/wordnet-1.6/wnrtl.h
-include/wordnet-1.6/wntypes.h
+include/wordnet-%%VER%%/license.h
+include/wordnet-%%VER%%/setutil.h
+include/wordnet-%%VER%%/wn.h
+include/wordnet-%%VER%%/wnconsts.h
+include/wordnet-%%VER%%/wnglobal.h
+include/wordnet-%%VER%%/wnhelp.h
+include/wordnet-%%VER%%/wnrtl.h
+include/wordnet-%%VER%%/wntypes.h
lib/libwn1.a
-lib/libwn1.so.6
+lib/libwn1.so.7
lib/libwn1.so
-lib/libtclwn1.so.6
+lib/libtclwn1.so.7
lib/libtclwn1.so
lib/tcl%%TCL_DVER%%/Wordnet/pkgIndex.tcl
-share/wordnet-1.6/adj.exc
-share/wordnet-1.6/adv.exc
-share/wordnet-1.6/cntlist
-share/wordnet-1.6/cousin.exc
-share/wordnet-1.6/cousin.tops
-share/wordnet-1.6/data.adj
-share/wordnet-1.6/data.adv
-share/wordnet-1.6/data.noun
-share/wordnet-1.6/data.verb
-share/wordnet-1.6/index.adj
-share/wordnet-1.6/index.adv
-share/wordnet-1.6/index.gloss
-share/wordnet-1.6/index.noun
-share/wordnet-1.6/index.sense
-share/wordnet-1.6/index.verb
-share/wordnet-1.6/lexnames
-share/wordnet-1.6/noun.exc
-share/wordnet-1.6/sentidx.vrb
-share/wordnet-1.6/sents.vrb
-share/wordnet-1.6/stoplist.pl
-share/wordnet-1.6/verb.exc
-share/wordnet-1.6/wnres/license.txt
-share/wordnet-1.6/wnres/wn.xbm
-share/wordnet-1.6/wnres/wnb.man
-share/wordnet-1.6/wnres/wngloss.man
-@dirrm include/wordnet-1.6
+share/wordnet-%%VER%%/adj.exc
+share/wordnet-%%VER%%/adv.exc
+share/wordnet-%%VER%%/cntlist
+share/wordnet-%%VER%%/cntlist.rev
+share/wordnet-%%VER%%/data.adj
+share/wordnet-%%VER%%/data.adv
+share/wordnet-%%VER%%/data.noun
+share/wordnet-%%VER%%/data.verb
+share/wordnet-%%VER%%/index.adj
+share/wordnet-%%VER%%/index.adv
+share/wordnet-%%VER%%/index.noun
+share/wordnet-%%VER%%/index.sense
+share/wordnet-%%VER%%/index.verb
+share/wordnet-%%VER%%/lexnames
+share/wordnet-%%VER%%/noun.exc
+share/wordnet-%%VER%%/sentidx.vrb
+share/wordnet-%%VER%%/sents.vrb
+share/wordnet-%%VER%%/verb.exc
+share/wordnet-%%VER%%/wnres/license.txt
+share/wordnet-%%VER%%/wnres/wn.xbm
+share/wordnet-%%VER%%/wnres/wnb.man
+share/wordnet-%%VER%%/wnres/wngloss.man
+@dirrm include/wordnet-%%VER%%
@dirrm lib/tcl%%TCL_DVER%%/Wordnet
-@dirrm share/wordnet-1.6/wnres
-@dirrm share/wordnet-1.6
+@dirrm share/wordnet-%%VER%%/wnres
+@dirrm share/wordnet-%%VER%%