aboutsummaryrefslogtreecommitdiff
path: root/textproc/xalan-c/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-03-08 10:18:49 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-03-08 10:18:49 +0000
commitbfa84448efa1678898ff0f776b1b76519fefa4c9 (patch)
tree65eacd8e4cd85f745f5a6c9a8601809c37701454 /textproc/xalan-c/Makefile
parent8deea0a6c74605ef4e36fc058f66945935dcc1e2 (diff)
downloadports-bfa84448efa1678898ff0f776b1b76519fefa4c9.tar.gz
ports-bfa84448efa1678898ff0f776b1b76519fefa4c9.zip
- Update to 1.9.0
- Optionally use icu.32 instead of icu2.x PR: ports/78436 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=130603
Diffstat (limited to 'textproc/xalan-c/Makefile')
-rw-r--r--textproc/xalan-c/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/textproc/xalan-c/Makefile b/textproc/xalan-c/Makefile
index 4bd4b30dcd1e..f0653f3078b1 100644
--- a/textproc/xalan-c/Makefile
+++ b/textproc/xalan-c/Makefile
@@ -7,7 +7,7 @@
# ------------------------------------------------------------------------------
PORTNAME= xalan-c
-PORTVERSION= 1.8.0
+PORTVERSION= 1.9.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML:S/$/:msax,docs/}
MASTER_SITE_SUBDIR= ${PORTNAME}/source/:msax ${PORTNAME}/docs/:docs
@@ -57,6 +57,10 @@ USE_GMAKE= yes
MAKE_ENV+= XALANCROOT=${WRKSRC}
MAKE_ENV+= XERCESCROOT=${XERCESCROOT}
+.if ( ${OSVERSION} < 500000 )
+EXTRA_CFLAGS= -ftemplate-depth-20
+.endif
+
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= runConfigure
CONFIGURE_ENV+= XALANCROOT=${WRKSRC}
@@ -64,7 +68,7 @@ CONFIGURE_ENV+= XERCESCROOT=${XERCESCROOT}
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -l ${PTHREAD_LIBS} \
- -z -I${LOCALBASE}/include -C --prefix=${PREFIX}
+ -z ${EXTRA_CFLAGS} -I${LOCALBASE}/include -C --prefix=${PREFIX}
.if defined(WITH_INMEM)
LOCALSYS= inmem
@@ -99,7 +103,7 @@ PLIST_SUB+= LOCALSYS_NLS="@comment "
.if defined(WITH_TRANSCODER_ICU)
PKGNAMESUFFIX+= -icu
-LIB_DEPENDS+= icuuc.28:${PORTSDIR}/devel/icu2
+LIB_DEPENDS+= icuuc.32:${PORTSDIR}/devel/icu
ICUROOT?= ${LOCALBASE}
CONFIGURE_ENV+= XALAN_USE_ICU=1
CONFIGURE_ENV+= ICUROOT=${ICUROOT}
@@ -158,7 +162,15 @@ pre-extract:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/check-config-options
post-patch:
- ${RM} -f ${WRKSRC}/src/xalanc/PlatformSupport/XalanArrayAllocator.hpp.orig
+ ${RM} -f ${WRKSRC}/src/xalanc/ICUBridge/ICUFormatNumberFunctor.hpp.orig \
+ ${WRKSRC}/src/xalanc/PlatformSupport/XalanArrayAllocator.hpp.orig \
+ ${WRKSRC}/src/xalanc/XMLSupport/FormatterToText.hpp.orig \
+ ${WRKSRC}/src/xalanc/XPath/ElementPrefixResolverProxy.hpp.orig \
+ ${WRKSRC}/src/xalanc/XPath/NameSpace.hpp.orig \
+ ${WRKSRC}/src/xalanc/XPath/XalanQNameByValue.hpp.orig \
+ ${WRKSRC}/src/xalanc/XSLT/FunctionSystemProperty.hpp.orig \
+ ${WRKSRC}/src/xalanc/XSLT/TopLevelArg.hpp.orig
+ ${CHMOD} 755 ${WRKSRC}/runConfigure ${WRKSRC}/configure
post-install:
.if !defined(WITH_DEBUG)
@@ -177,8 +189,8 @@ post-install:
cd ${DOCSDIR} && \
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${_DISTDIR}/${DOCS_TARBALL} ${EXTRACT_AFTER_ARGS} && \
- ${MV} ${DOCSDIR}/docs/* ${DOCSDIR} && \
- ${RMDIR} ${DOCSDIR}/docs
+ ${MV} ${DOCSDIR}/Xalan-C_${PORTVERSION:S/./_/g}-docs/* ${DOCSDIR} && \
+ ${RMDIR} ${DOCSDIR}/Xalan-C_${PORTVERSION:S/./_/g}-docs
.endif
post-clean: