aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlppm/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-15 04:09:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-15 04:09:09 +0000
commit1bdf10e1da34183b6ab830b979c8cff8a7ef0816 (patch)
tree6267b7575ff5724483b7e2a00725cf55a9abf3e5 /textproc/xmlppm/Makefile
parent72e6d66a800b480b0aba3e997c93db643609cc5d (diff)
downloadports-1bdf10e1da34183b6ab830b979c8cff8a7ef0816.tar.gz
ports-1bdf10e1da34183b6ab830b979c8cff8a7ef0816.zip
add xmlppm
XML-Conscious PPM Compression
Notes
Notes: svn path=/head/; revision=42609
Diffstat (limited to 'textproc/xmlppm/Makefile')
-rw-r--r--textproc/xmlppm/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/xmlppm/Makefile b/textproc/xmlppm/Makefile
new file mode 100644
index 000000000000..cecf88d1b101
--- /dev/null
+++ b/textproc/xmlppm/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: xmlppm
+# Date created: May 15, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlppm
+PORTVERSION= 0.95.2
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.cs.cornell.edu/People/jcheney/xmlppm/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= expat.2:${PORTSDIR}/textproc/expat2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
+
+do-install:
+ @(cd ${WRKSRC} ; ${INSTALL_PROGRAM} xmlppm xmlunppm ${PREFIX}/bin)
+
+.include <bsd.port.mk>