aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlwrapp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-25 15:06:44 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-25 15:06:44 +0000
commit2b41d64b31aa79376a3ada24a20d2390ee9b4e83 (patch)
treee12b3dee1ee5115675fb84acf1c14e49dcad7f26 /textproc/xmlwrapp
parent1ea2c12a36383979728eaad7d5d0fafae238abab (diff)
downloadports-2b41d64b31aa79376a3ada24a20d2390ee9b4e83.tar.gz
ports-2b41d64b31aa79376a3ada24a20d2390ee9b4e83.zip
- Update to 0.6.2
- Add OPTIONS: XSLT - While I'm here, add WWW Changes: http://xmlwrapp.svn.sourceforge.net/viewvc/xmlwrapp/tags/release-0.6.2/NEWS PR: ports/158582 Submitted by: Niclas Zeising <niclas.zeising@gmail.com>
Notes
Notes: svn path=/head/; revision=280411
Diffstat (limited to 'textproc/xmlwrapp')
-rw-r--r--textproc/xmlwrapp/Makefile36
-rw-r--r--textproc/xmlwrapp/distinfo4
-rw-r--r--textproc/xmlwrapp/files/patch-tools::cxxflags20
-rw-r--r--textproc/xmlwrapp/files/patch-tools::mkmf30
-rw-r--r--textproc/xmlwrapp/pkg-descr3
-rw-r--r--textproc/xmlwrapp/pkg-plist234
6 files changed, 255 insertions, 72 deletions
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index ae4ba85821eb..37af9656e65d 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -7,37 +7,37 @@
#
PORTNAME= xmlwrapp
-PORTVERSION= 0.5.0
+PORTVERSION= 0.6.2
CATEGORIES= textproc
MASTER_SITES= SF
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A modern style C++ library for working with XML data
+LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
+
+OPTIONS= XSLT "build libxsltwrap library (requires libxslt)" off
+
+CONFIGURE_ARGS= --prefix ${PREFIX}
+CPPFLAGS+= -I${LOCALBASE}/include
+USE_AUTOTOOLS= libtool
+USE_GNOME= libxml2 pkgconfig gnomehack
USE_PERL5_BUILD= yes
-USE_GNOME= libxml2 pkgconfig
+USE_LDCONFIG= yes
WANT_GNOME= yes
HAS_CONFIGURE= yes
-CONFIGURE_SCRIPT= configure.pl
-CONFIGURE_ARGS= --prefix ${PREFIX}
-USE_LDCONFIG= yes
-CFLAGS+= -fPIC
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${HAVE_GNOME:Mlibxslt}!=""
+.if defined(WITH_XSLT)
USE_GNOME+= libxslt
.else
-CONFIGURE_ARGS+= --disable-xslt
+CONFIGURE_ARGS+=--disable-xslt
.endif
post-patch:
- ${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},' -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/configure.pl
- ${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/tools/mkmf
-# Fix for GCC 4.2
- @${REINPLACE_CMD} -e 's,^std::ostream,namespace xml { &,' \
- -e '/^namespace/s,xml::,,g' -e '$$s,^,} ,' \
- ${WRKSRC}/src/libxml/node.cxx
-
-.include <bsd.port.post.mk>
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} 's/docs//' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/xmlwrapp/distinfo b/textproc/xmlwrapp/distinfo
index e5021243d1c8..e180dc2a249c 100644
--- a/textproc/xmlwrapp/distinfo
+++ b/textproc/xmlwrapp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xmlwrapp-0.5.0.tgz) = af3b71a6983c5c08e00096f5bb9f8ce61de3147f020aef327624043736d5ac73
-SIZE (xmlwrapp-0.5.0.tgz) = 442550
+SHA256 (xmlwrapp-0.6.2.tar.gz) = befef91d8a5826d66b1f18db8786ab6b0d097555ccb07906c85f12f69d638767
+SIZE (xmlwrapp-0.6.2.tar.gz) = 946770
diff --git a/textproc/xmlwrapp/files/patch-tools::cxxflags b/textproc/xmlwrapp/files/patch-tools::cxxflags
deleted file mode 100644
index a729520901ea..000000000000
--- a/textproc/xmlwrapp/files/patch-tools::cxxflags
+++ /dev/null
@@ -1,20 +0,0 @@
---- tools/cxxflags.orig Wed Jan 8 06:26:51 2003
-+++ tools/cxxflags Tue May 13 05:50:41 2003
-@@ -240,7 +240,7 @@
-
- $flags{'debug'} = "-g";
- $flags{'depend'} = '-M';
-- $flags{'optimize'} = '-O2';
-+ $flags{'optimize'} = '';
- $flags{'ar'} = $ENV{'AR'} || 'ar';
- $flags{'arflags'} = $ENV{'ARFLAGS'} || 'rc';
- $flags{'sar'} = $clo{'cxx'};
-@@ -353,7 +353,7 @@
- $flags{'debug'} = "-g";
- $flags{'depend'} = '-xM';
- $flags{'pic'} = '-Kpic';
-- $flags{'optimize'} = '-s -xlibmil -xlibmopt -xO2';
-+ $flags{'optimize'} = '-s -xlibmil -xlibmopt';
- $flags{'ar'} = $clo{'cxx'};
- $flags{'arflags'} = '-xar -o';
- $flags{'sar'} = $clo{'cxx'};
diff --git a/textproc/xmlwrapp/files/patch-tools::mkmf b/textproc/xmlwrapp/files/patch-tools::mkmf
deleted file mode 100644
index 3904c89013ea..000000000000
--- a/textproc/xmlwrapp/files/patch-tools::mkmf
+++ /dev/null
@@ -1,30 +0,0 @@
---- tools/mkmf.orig Tue Apr 8 07:23:38 2003
-+++ tools/mkmf Tue May 13 06:05:24 2003
-@@ -469,6 +469,7 @@
- 'BINDIR' => '/usr/local/bin',
- 'INCLUDEDIR' => '/usr/local/include',
- 'LIBDIR' => '/usr/local/lib',
-+ 'LIBDATADIR' => '/usr/local/libdata',
- 'MANDIR' => '/usr/local/share/man',
- );
-
-@@ -558,7 +559,7 @@
- print MF "\tmkdir -p $vars{'BINDIR'}\n" if @binaries;
- print MF "\tmkdir -p $vars{'INCLUDEDIR'}\n" if @include_files or @include_dirs;
- print MF "\tmkdir -p $vars{'LIBDIR'}\n" if @static_libraries or @shared_libraries;
-- print MF "\tmkdir -p $vars{'LIBDIR'}/pkgconfig\n" if @pkgconfig;
-+ print MF "\tmkdir -p $vars{'LIBDATADIR'}/pkgconfig\n" if @pkgconfig;
- print MF "\tmkdir -p $vars{'MANDIR'}\n" if @man_pages;
-
- foreach my $binary (@binaries) {
-@@ -567,8 +568,8 @@
- }
-
- foreach my $pc (@pkgconfig) {
-- print MF "\tcp $pc $vars{'LIBDIR'}/pkgconfig/$pc\n";
-- print MF "\tchmod 644 $vars{'LIBDIR'}/pkgconfig/$pc\n";
-+ print MF "\tcp $pc $vars{'LIBDATADIR'}/pkgconfig/$pc\n";
-+ print MF "\tchmod 644 $vars{'LIBDATADIR'}/pkgconfig/$pc\n";
- }
-
- foreach my $directory (@include_dirs) {
diff --git a/textproc/xmlwrapp/pkg-descr b/textproc/xmlwrapp/pkg-descr
index 07cb72c4ec58..41c7f8b6af67 100644
--- a/textproc/xmlwrapp/pkg-descr
+++ b/textproc/xmlwrapp/pkg-descr
@@ -11,3 +11,6 @@ Features:
text data.
* Complete isolation from the backend parser due to the private
implementation (pimpl) idiom.
+
+WWW: http://xmlwrapp.sourceforge.net/
+ https://github.com/vslavik/xmlwrapp
diff --git a/textproc/xmlwrapp/pkg-plist b/textproc/xmlwrapp/pkg-plist
index 6c2547a47d37..c500500db566 100644
--- a/textproc/xmlwrapp/pkg-plist
+++ b/textproc/xmlwrapp/pkg-plist
@@ -5,7 +5,9 @@ include/xmlwrapp/document.h
include/xmlwrapp/event_parser.h
include/xmlwrapp/init.h
include/xmlwrapp/node.h
+include/xmlwrapp/nodes_view.h
include/xmlwrapp/tree_parser.h
+include/xmlwrapp/version.h
include/xmlwrapp/xmlwrapp.h
%%GNOME:%%include/xsltwrapp/init.h
%%GNOME:%%include/xsltwrapp/stylesheet.h
@@ -13,9 +15,237 @@ include/xmlwrapp/xmlwrapp.h
lib/libxmlwrapp.a
lib/libxmlwrapp.so
lib/libxmlwrapp.so.5
+lib/libxmlwrapp.la
%%GNOME:%%lib/libxsltwrapp.a
%%GNOME:%%lib/libxsltwrapp.so
-%%GNOME:%%lib/libxsltwrapp.so.2
+%%GNOME:%%lib/libxsltwrapp.so.3
+%%GNOME:%%lib/libxsltwrapp.la
libdata/pkgconfig/xmlwrapp.pc
-%%GNOME:%%@dirrm include/xsltwrapp
+%%GNOME:%%libdata/pkgconfig/xsltwrapp.pc
+%%PORTDOCS%%%%DOCSDIR%%/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/attr.html
+%%PORTDOCS%%%%DOCSDIR%%/attributes_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/attributes_8h__dep__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/attributes_8h__dep__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/attributes_8h__dep__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/attributes_8h__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/attributes_8h__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/attributes_8h__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/attributes_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/classes.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1attributes-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1attributes.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1attributes_1_1attr-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1attributes_1_1attr.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1attributes_1_1const__iterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1attributes_1_1const__iterator.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1attributes_1_1iterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1attributes_1_1iterator.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1const__nodes__view-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1const__nodes__view.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1document-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1document.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1event__parser-members.html
+%%PORTDOCS%%%%DOCSDIR%%/closed.gif
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1event__parser.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1init-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1init.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1init__inherit__graph.map
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1init__inherit__graph.md5
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1init__inherit__graph.png
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1node-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1node.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1node_1_1const__iterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1node_1_1const__iterator.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1node_1_1iterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1node_1_1iterator.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1nodes__view-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1nodes__view.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1nodes__view_1_1const__iterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1nodes__view_1_1const__iterator.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1nodes__view_1_1iterator-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1nodes__view_1_1iterator.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1tree__parser-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxml_1_1tree__parser.html
+%%PORTDOCS%%%%DOCSDIR%%/classxslt_1_1init-members.html
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/classxslt_1_1init.html
+%%PORTDOCS%%%%DOCSDIR%%/classxslt_1_1init__coll__graph.map
+%%PORTDOCS%%%%DOCSDIR%%/classxslt_1_1init__coll__graph.md5
+%%PORTDOCS%%%%DOCSDIR%%/classxslt_1_1init__coll__graph.png
+%%PORTDOCS%%%%DOCSDIR%%/classxslt_1_1init__inherit__graph.map
+%%PORTDOCS%%%%DOCSDIR%%/classxslt_1_1init__inherit__graph.md5
+%%PORTDOCS%%%%DOCSDIR%%/classxslt_1_1init__inherit__graph.png
+%%PORTDOCS%%%%DOCSDIR%%/classxslt_1_1stylesheet-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classxslt_1_1stylesheet.html
+%%PORTDOCS%%%%DOCSDIR%%/document_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/document_8h__dep__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/document_8h__dep__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/document_8h__dep__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/document_8h__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/document_8h__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/document_8h__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/document_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/documents.html
+%%PORTDOCS%%%%DOCSDIR%%/event__parser_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/event__parser_8h__dep__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/event__parser_8h__dep__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/event__parser_8h__dep__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/event__parser_8h__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/event__parser_8h__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/event__parser_8h__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/event__parser_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/files.html
+%%PORTDOCS%%%%DOCSDIR%%/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_enum.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_eval.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_func.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_rela.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_type.html
+%%PORTDOCS%%%%DOCSDIR%%/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_defs.html
+%%PORTDOCS%%%%DOCSDIR%%/graph_legend.dot
+%%PORTDOCS%%%%DOCSDIR%%/graph_legend.html
+%%PORTDOCS%%%%DOCSDIR%%/graph_legend.png
+%%PORTDOCS%%%%DOCSDIR%%/hierarchy.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__0.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__0.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__0.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__1.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__1.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__1.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__10.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__10.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__10.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__11.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__11.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__11.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__12.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__12.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__12.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__13.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__13.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__13.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__14.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__14.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__14.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__15.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__15.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__15.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__16.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__16.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__16.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__17.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__17.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__17.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__18.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__18.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__18.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__19.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__19.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__19.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__2.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__2.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__2.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__3.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__3.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__3.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__4.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__4.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__4.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__5.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__5.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__5.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__6.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__6.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__6.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__7.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__7.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__7.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__8.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__8.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__8.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__9.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__9.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__9.png
+%%PORTDOCS%%%%DOCSDIR%%/inherits.html
+%%PORTDOCS%%%%DOCSDIR%%/intro.html
+%%PORTDOCS%%%%DOCSDIR%%/namespaces.html
+%%PORTDOCS%%%%DOCSDIR%%/namespacexml.html
+%%PORTDOCS%%%%DOCSDIR%%/namespacexslt.html
+%%PORTDOCS%%%%DOCSDIR%%/node.html
+%%PORTDOCS%%%%DOCSDIR%%/node_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/node_8h__dep__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/node_8h__dep__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/node_8h__dep__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/open.gif
+%%PORTDOCS%%%%DOCSDIR%%/node_8h__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/node_8h__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/node_8h__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/node_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/nodes__view_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/nodes__view_8h__dep__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/nodes__view_8h__dep__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/nodes__view_8h__dep__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/nodes__view_8h__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/nodes__view_8h__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/nodes__view_8h__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/nodes__view_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/parsing.html
+%%PORTDOCS%%%%DOCSDIR%%/prepare.html
+%%PORTDOCS%%%%DOCSDIR%%/structxml_1_1node_1_1cdata-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structxml_1_1node_1_1cdata.html
+%%PORTDOCS%%%%DOCSDIR%%/structxml_1_1node_1_1comment-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structxml_1_1node_1_1comment.html
+%%PORTDOCS%%%%DOCSDIR%%/structxml_1_1node_1_1pi-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structxml_1_1node_1_1pi.html
+%%PORTDOCS%%%%DOCSDIR%%/structxml_1_1node_1_1text-members.html
+%%PORTDOCS%%%%DOCSDIR%%/structxml_1_1node_1_1text.html
+%%PORTDOCS%%%%DOCSDIR%%/stylesheet_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/stylesheet_8h__dep__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/stylesheet_8h__dep__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/stylesheet_8h__dep__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/stylesheet_8h__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/tab_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/stylesheet_8h__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/stylesheet_8h__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/stylesheet_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/tab_l.gif
+%%PORTDOCS%%%%DOCSDIR%%/tab_r.gif
+%%PORTDOCS%%%%DOCSDIR%%/tabs.css
+%%PORTDOCS%%%%DOCSDIR%%/tips.html
+%%PORTDOCS%%%%DOCSDIR%%/tree__parser_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/tree__parser_8h__dep__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/tree__parser_8h__dep__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/tree__parser_8h__dep__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/tree__parser_8h__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/tree__parser_8h__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/tree__parser_8h__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/tree__parser_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/version_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/version_8h__dep__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/version_8h__dep__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/version_8h__dep__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/version_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/whatnext.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlwrapp_2init_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlwrapp_2init_8h__dep__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/xmlwrapp_2init_8h__dep__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/xmlwrapp_2init_8h__dep__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/xmlwrapp_2init_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlwrapp_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/xslt.html
+%%PORTDOCS%%%%DOCSDIR%%/xsltwrapp_2init_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/xsltwrapp_2init_8h__dep__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/xsltwrapp_2init_8h__dep__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/xsltwrapp_2init_8h__dep__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/xsltwrapp_2init_8h__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/xsltwrapp_2init_8h__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/xsltwrapp_2init_8h__incl.png
+%%PORTDOCS%%%%DOCSDIR%%/xsltwrapp_2init_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/xsltwrapp_8h_source.html
@dirrm include/xmlwrapp
+%%GNOME:%%@dirrm include/xsltwrapp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%