aboutsummaryrefslogtreecommitdiff
path: root/textproc/xsv
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-03-23 02:11:26 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-03-23 02:11:26 +0000
commitb20005237079a2023b6ec3a806a8a4009f26e039 (patch)
tree1983d8159a5c0a2338150cfcf7753a1d5d89411d /textproc/xsv
parent8297905759145c25a1842b6dd3aa7304024e8c81 (diff)
downloadports-b20005237079a2023b6ec3a806a8a4009f26e039.tar.gz
ports-b20005237079a2023b6ec3a806a8a4009f26e039.zip
XSV is a command-line tool for performing schema-validity
assessment of XML documents in accord with the W3C XML Schema specification, second edition. XSV (XML Schema Validator) is an open source (GPLed) work-in-progress attempt at a conformant schema-aware processor, as defined by XML Schema Part 1: Structures, Second Edition of 28 October 2004. It has been developed at the Language Technology Group of the Human Communication Research Centre in the School of Informatics at the University of Edinburgh, with support for one of us (Thompson) from the World Wide Web Consortium. WWW: http://www.ltg.ed.ac.uk/~ht/xsv-status.html
Notes
Notes: svn path=/head/; revision=348825
Diffstat (limited to 'textproc/xsv')
-rw-r--r--textproc/xsv/Makefile38
-rw-r--r--textproc/xsv/distinfo2
-rw-r--r--textproc/xsv/files/patch-setup.py25
-rw-r--r--textproc/xsv/pkg-descr13
4 files changed, 78 insertions, 0 deletions
diff --git a/textproc/xsv/Makefile b/textproc/xsv/Makefile
new file mode 100644
index 000000000000..54dc245181e6
--- /dev/null
+++ b/textproc/xsv/Makefile
@@ -0,0 +1,38 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xsv
+PORTVERSION= 3.1
+CATEGORIES= textproc python
+MASTER_SITES= ftp://ftp.cogsci.ed.ac.uk/pub/XSV/
+DISTNAME= ${PORTNAME:U}-${DISTVERSION}
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= XML Schema Validator
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ltxml>0:${PORTSDIR}/textproc/py-ltxml
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+INSTALLS_EGGINFO= yes
+USE_LDCONFIG= yes
+
+PORTDOCS= pc-shrinkwrap xsv-status.xml xsv-status.html
+PORTEXAMPLES= triv.xml triv.xsd tiny.xml tiny.xsd
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/xsv/distinfo b/textproc/xsv/distinfo
new file mode 100644
index 000000000000..78260bfef920
--- /dev/null
+++ b/textproc/xsv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (XSV-3.1.tar.gz) = acd0b8522ae6e14ffe17ef23f376aa51c7420152a038c53ef5b51fc0d79c4018
+SIZE (XSV-3.1.tar.gz) = 157804
diff --git a/textproc/xsv/files/patch-setup.py b/textproc/xsv/files/patch-setup.py
new file mode 100644
index 000000000000..c5e14c6d98ed
--- /dev/null
+++ b/textproc/xsv/files/patch-setup.py
@@ -0,0 +1,25 @@
+--- ./setup.py.orig 2008-01-18 13:17:40.000000000 +0100
++++ ./setup.py 2014-03-23 02:06:18.690868591 +0100
+@@ -16,20 +16,10 @@
+ self.install_dir = getattr(install_cmd, 'install_lib')
+ return install_data.run(self)
+
+-datafiles=[('XSV/example',
+- ['triv.xml',
+- 'triv.xsd',
+- 'tiny.xml',
+- 'tiny.xsd']),
+- ('XSV',['XSV/nndump.xml',
++datafiles=[('XSV',['XSV/nndump.xml',
+ 'XSV/XMLSchema.dtd',
+ 'XSV/datatypes.dtd']),
+- ('XSV/pubtext',['xsv.xsl']),
+- ('XSV/doc',['COPYING',
+- 'COPYRIGHT',
+- 'pc-shrinkwrap',
+- 'xsv-status.xml',
+- 'xsv-status.html'])] # only works for bdist and friends
++ ('XSV/pubtext',['xsv.xsl'])]
+
+ if sys.platform.find("win32",0,5)==0:
+ platform="WIN32"
diff --git a/textproc/xsv/pkg-descr b/textproc/xsv/pkg-descr
new file mode 100644
index 000000000000..5ccaf20d1cca
--- /dev/null
+++ b/textproc/xsv/pkg-descr
@@ -0,0 +1,13 @@
+XSV is a command-line tool for performing schema-validity
+assessment of XML documents in accord with the
+W3C XML Schema specification, second edition.
+
+XSV (XML Schema Validator) is an open source (GPLed) work-in-progress
+attempt at a conformant schema-aware processor, as defined by
+XML Schema Part 1: Structures, Second Edition of 28 October 2004.
+It has been developed at the Language Technology Group of the Human
+Communication Research Centre in the School of Informatics at the
+University of Edinburgh, with support for one of us (Thompson)
+from the World Wide Web Consortium.
+
+WWW: http://www.ltg.ed.ac.uk/~ht/xsv-status.html