aboutsummaryrefslogtreecommitdiff
path: root/textproc/yodl
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-09 01:36:55 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-09 01:36:55 +0000
commit6191a0f6a8f6384636ebfb8fed314bd36e3804f7 (patch)
tree8820b40d432e57663e2a87eff34c8e568dd2ea84 /textproc/yodl
parent7032f98510726019e07faad9003c218e9687ee7a (diff)
downloadports-6191a0f6a8f6384636ebfb8fed314bd36e3804f7.tar.gz
ports-6191a0f6a8f6384636ebfb8fed314bd36e3804f7.zip
Major overhaul to make this thing work again.
1) New MASTER_SITES. I put a bunch of them (obtained from the good ole' ftpsearch.ntnu.no) here for redundancy. 2) Chase checksum. I was unable to find the original distfile. 3) Make port respect CC/CFLAGS. 4) Remove GMAKE now that we respect CC/CFLAGS. 5) Remove bash dependency now that we can use /bin/sh. 6) Fix compile warning about malloc.h vs. stdlib.h. PR: 17150 Submitted by: Mikhail Teterin <mi@aldan.algebra.com> Hall of Shame entry: dburr (for complete disregard)
Notes
Notes: svn path=/head/; revision=29417
Diffstat (limited to 'textproc/yodl')
-rw-r--r--textproc/yodl/Makefile29
-rw-r--r--textproc/yodl/distinfo2
-rw-r--r--textproc/yodl/files/patch-aa49
-rw-r--r--textproc/yodl/files/patch-ab10
-rw-r--r--textproc/yodl/files/patch-ac47
5 files changed, 89 insertions, 48 deletions
diff --git a/textproc/yodl/Makefile b/textproc/yodl/Makefile
index 4d4424aa47d3..7b72da6fc4a6 100644
--- a/textproc/yodl/Makefile
+++ b/textproc/yodl/Makefile
@@ -8,18 +8,23 @@
PORTNAME= yodl
PORTVERSION= 1.22
CATEGORIES= textproc
-MASTER_SITES= ftp://ftp.icce.rug.nl/pub/unix/
+MASTER_SITES= ftp://ftp.sco.com/skunkware/src/textproc/ \
+ ftp://ftp.sunsite.org.uk/Mirrors/ftp.sco.com/skunkware/src/textproc/ \
+ ftp://ftp.vse.cz/pub/.sd10c/SCO/ftp.sco.com/skunkware/src/textproc/ \
+ ftp://ftp.netsw.org/netsw/Typesetting/ASCII/Generate/ \
+ ftp://ftp.win.ne.jp/pub/misc/ \
+ ftp://ftp.eos.hokudai.ac.jp/pub/misc/ \
+ ftp://ftp.sunet.se/pub3/vendor/sco/skunkware/src/textproc/
MAINTAINER= dburr@FreeBSD.org
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash1 \
- latex:${PORTSDIR}/print/latex \
+BUILD_DEPENDS= latex:${PORTSDIR}/print/latex \
dvips:${PORTSDIR}/print/dvips
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash1 \
- latex:${PORTSDIR}/print/latex \
+RUN_DEPENDS= latex:${PORTSDIR}/print/latex \
dvips:${PORTSDIR}/print/dvips
-USE_GMAKE= YES
+ALL_TARGET= progs manpages misc/striproff
+INSTALL_TARGET= installman installmanual
MAN1= yodl.1 \
striproff.1 \
@@ -32,15 +37,7 @@ do-build:
(cd ${WRKSRC} && ${SETENV} CFLAGS="${CFLAGS}" ${GMAKE} PREFIX=${PREFIX} progs)
(cd ${WRKSRC}/misc && gcc ${CFLAGS} -s -o striproff striproff.c)
-# this weird contortion is because the YODL makefile is broken
-# trust me, it works.
-do-install:
- @${ECHO_MSG} "*** NOTE: any errors from make can be safely ignored."
- (cd ${WRKSRC} && ${GMAKE} PREFIX=${PREFIX} install)
- -(cd ${WRKSRC} && ${GMAKE} PREFIX=${PREFIX} manpages)
- (cd ${WRKSRC}/manpages && ${GMAKE} PREFIX=${PREFIX} manpages)
- (cd ${WRKSRC}/manpages && ${GMAKE} PREFIX=${PREFIX} MANPREFIX=${PREFIX}/man installman)
- (cd ${WRKSRC} && ${GMAKE} PREFIX=${PREFIX} installmanual)
- (cd ${WRKSRC}/misc && ${INSTALL_PROGRAM} striproff ${PREFIX}/bin/striproff)
+post-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/misc/striproff ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/textproc/yodl/distinfo b/textproc/yodl/distinfo
index a7a347a5a160..d1c85b1cf2aa 100644
--- a/textproc/yodl/distinfo
+++ b/textproc/yodl/distinfo
@@ -1 +1 @@
-MD5 (yodl-1.22.tar.gz) = 870da39805a0063630d085e49d48de64
+MD5 (yodl-1.22.tar.gz) = 04f46f2ae4d1823865ef14fec9998b84
diff --git a/textproc/yodl/files/patch-aa b/textproc/yodl/files/patch-aa
index 0dd2466b0d31..2c9c8c47ebd4 100644
--- a/textproc/yodl/files/patch-aa
+++ b/textproc/yodl/files/patch-aa
@@ -1,33 +1,28 @@
---- Makefile.old Wed Oct 29 04:20:09 1997
-+++ Makefile Mon Jul 20 16:34:44 1998
-@@ -6,21 +6,21 @@
+--- Makefile Thu Apr 22 17:49:36 1999
++++ Makefile.new Thu Jun 8 21:21:07 2000
+@@ -6,16 +6,17 @@
# A `lib' directory under which ...../yodl will be attached, as the
# system-wide include directory for macros of the yodl program?
-LIBDIR=/usr/local/lib
-+LIBDIR=${PREFIX}/lib
++LOCALBASE?=/usr/local
++LIBDIR=${LOCALBASE}/lib
# To what directory are the yodl program and all shell scripts installed?
-BINDIR = /usr/local/bin
-+BINDIR = ${PREFIX}/bin
++BINDIR = ${LOCALBASE}/bin
# Where do your man pages go? MANPREFIX is where the subdirs man1, man2 etc.
# are located, CATPREFIX is where subdirs cat1, cat2 etc. are, that's
# where formatted pages go.
--MANPREFIX=/usr/man
--CATPREFIX=/var/man
-+MANPREFIX=${PREFIX}/man
-+CATPREFIX=${PREFIX}/man
+-MANPREFIX=/usr/local/man
+-CATPREFIX=/usr/local/man
++MANPREFIX=${LOCALBASE}/man
++CATPREFIX=${LOCALBASE}/man
# What's your LaTeX command? The shellscript "yodl2dvi" will run "yodl2tex" and
# your LaTeX-er for you, creating the .dvi file. LaTeX is also used in
- # "make dvidoc" and "make psdoc".
--LATEX = mlatex
-+LATEX = latex
-
- # What's your command to process a manpage into a format that's suitable
- # for viewing? Command should take one file argument and send the output
-@@ -37,13 +37,13 @@
+@@ -37,13 +38,13 @@
# What's your pager, a-la "less"? Will be used in the "yodl2manless"
# and "yodl2msless" scripts that show groff output in ASCII via a pager.
@@ -35,29 +30,21 @@
+LESS = more
# The C compiler?
- CC = cc
+-CC = cc
++CC ?= cc
# Compiler flags?
--CFLAGS = -g -c -Wall
-+CFLAGS += -c -Wall
+-CFLAGS = -c -O2 -Kalloca
++CFLAGS += -c
# Installation program? If you don't have install, make sure that you state
# something that also strips executables.
-@@ -70,7 +70,7 @@
- SROFF = $(BINDIR)/striproff
-
- # If you also want the manpage under $(MANPREFIX)/man1, uncomment:
--# SROFFMAN = $(MANPREFIX)/man1/striproff.1
-+SROFFMAN = $(MANPREFIX)/man1/striproff.1
-
- # Additionally, if you want the preformatted manpage under $(CATPREFIX)/cat1,
- # uncomment:
-@@ -81,7 +81,7 @@
+@@ -81,7 +82,7 @@
# shell will do too, but I suggest that you get bash if you don't have it
# yet. I have it installed as /bin/sh, lucky me.
# Define the path of your bash below:
--BASH = /bin/sh
-+BASH = ${PREFIX}/bin/bash
+-BASH = /bin/bash
++BASH = /bin/sh
# Some systems seem to lack the function strerror() (I've heard of SunOS 4.1.4
# with GCC 2.6). If that's the case, uncomment the following:
diff --git a/textproc/yodl/files/patch-ab b/textproc/yodl/files/patch-ab
new file mode 100644
index 000000000000..ccde70d19040
--- /dev/null
+++ b/textproc/yodl/files/patch-ab
@@ -0,0 +1,10 @@
+--- src/yodlfixlabels/yodlfixlabels.h Wed Oct 16 03:38:41 1996
++++ src/yodlfixlabels/yodlfixlabels.h.new Thu Jun 8 21:23:20 2000
+@@ -1,7 +1,6 @@
+
+ /* required standard includes */
+ #include <ctype.h>
+-#include <malloc.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/textproc/yodl/files/patch-ac b/textproc/yodl/files/patch-ac
new file mode 100644
index 000000000000..de1d6aeb7c19
--- /dev/null
+++ b/textproc/yodl/files/patch-ac
@@ -0,0 +1,47 @@
+--- manpages/Makefile.in.orig Fri Jan 24 05:42:52 1997
++++ manpages/Makefile.in Fri Mar 3 10:01:20 2000
+@@ -7,4 +7,2 @@
+
+-SHELL=__BASH__
+-
+ man1=$(MANPREFIX)/man1
+@@ -24,6 +22,6 @@
+ yodl.man: yodl.yo ../Makefile
+- yodl2man $<
++ yodl2man yodl.yo
+
+ $(man1)/yodl.1: yodl.man
+- cp $< $@
++ cp yodl.man $@
+
+@@ -34,6 +32,6 @@
+ yodlconverters.man: yodlconverters.yo ../Makefile
+- yodl2man $<
++ yodl2man yodlconverters.yo
+
+ $(man1)/yodlconverters.1: yodlconverters.man
+- cp $< $@
++ cp yodlconverters.man $@
+
+@@ -48,3 +46,3 @@
+ $(man7)/yodlmacros.7: yodlmacros.man
+- cp $< $@
++ cp yodlmacros.man $@
+
+@@ -55,6 +53,6 @@
+ yodlmanpage.man: yodlmanpage.yo ../Makefile
+- yodl2man $<
++ yodl2man yodlmanpage.yo
+
+ $(man7)/yodlmanpage.7: yodlmanpage.man
+- cp $< $@
++ cp yodlmanpage.man $@
+
+@@ -65,6 +63,6 @@
+ striproff.man: striproff.yo ../Makefile
+- yodl2man $<
++ yodl2man striproff.yo
+
+ $(man1)/striproff.1: striproff.man
+- cp $< $@
++ cp striproff.man $@