aboutsummaryrefslogtreecommitdiff
path: root/textproc/yodl
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-01-21 10:18:16 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-01-21 10:18:16 +0000
commit665141259d6a1e414248fadb7452a7f6e799ba53 (patch)
treeec148ec41720f721217b86700ac2d7d29ccf87f3 /textproc/yodl
parent68092363b1ea0095ed6ecda08dfaf3ebc9b96722 (diff)
downloadports-665141259d6a1e414248fadb7452a7f6e799ba53.tar.gz
ports-665141259d6a1e414248fadb7452a7f6e799ba53.zip
textproc/yodl: Update version 3.04.00=>3.05.00
- Add LICENSE (GPLv3) - Take MAINTAINERSHIP Differential Revision: https://reviews.freebsd.org/D1567 Approved by: bapt(mentor)
Notes
Notes: svn path=/head/; revision=377583
Diffstat (limited to 'textproc/yodl')
-rw-r--r--textproc/yodl/Makefile6
-rw-r--r--textproc/yodl/distinfo4
-rw-r--r--textproc/yodl/files/patch-src_verbinsert_verbinsert.cc34
3 files changed, 40 insertions, 4 deletions
diff --git a/textproc/yodl/Makefile b/textproc/yodl/Makefile
index 8e403c7208f8..d144835be09c 100644
--- a/textproc/yodl/Makefile
+++ b/textproc/yodl/Makefile
@@ -2,15 +2,17 @@
# $FreeBSD$
PORTNAME= yodl
-PORTVERSION= 3.04.00
+PORTVERSION= 3.05.00
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}
EXTRACT_SUFX= .orig.tar.gz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Easy to use but powerful document formatting/preparation language
+LICENSE= GPLv3
+
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/bin/getopt:${PORTSDIR}/misc/getopt
BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
diff --git a/textproc/yodl/distinfo b/textproc/yodl/distinfo
index 4e2f0a7e95ff..4267c8eebb31 100644
--- a/textproc/yodl/distinfo
+++ b/textproc/yodl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (yodl_3.04.00.orig.tar.gz) = 66b317877906e165506796f9342a1adf931376f7d8b6990b2d2ff12107685893
-SIZE (yodl_3.04.00.orig.tar.gz) = 296554
+SHA256 (yodl_3.05.00.orig.tar.gz) = 2f360062a85f9359207088b2586da863e2b111428f3e12486cd34c9de12b1b8a
+SIZE (yodl_3.05.00.orig.tar.gz) = 301612
diff --git a/textproc/yodl/files/patch-src_verbinsert_verbinsert.cc b/textproc/yodl/files/patch-src_verbinsert_verbinsert.cc
new file mode 100644
index 000000000000..599c50113be0
--- /dev/null
+++ b/textproc/yodl/files/patch-src_verbinsert_verbinsert.cc
@@ -0,0 +1,34 @@
+--- src/verbinsert/verbinsert.cc.orig 2015-01-20 18:56:00.226610975 +0600
++++ src/verbinsert/verbinsert.cc 2015-01-20 18:56:46.890607566 +0600
+@@ -2,6 +2,7 @@
+ #include <fstream>
+ #include <iomanip>
+ #include <string>
++#include <cstdlib>
+ #include <unistd.h>
+
+ using namespace std;
+@@ -37,19 +38,19 @@
+ continue;
+
+ case 's':
+- indent.append(stoul(optarg), ' ');
++ indent.append(strtoul(optarg, NULL, 0), ' ');
+ continue;
+
+ case 't':
+- indent.insert(0, stoul(optarg), '\t');
++ indent.insert(0, strtoul(optarg, NULL, 0), '\t');
+ continue;
+
+ case 'S':
+- vindent.append(stoul(optarg), ' ');
++ vindent.append(strtoul(optarg, NULL, 0), ' ');
+ continue;
+
+ case 'T':
+- vindent.insert(0, stoul(optarg), '\t');
++ vindent.insert(0, strtoul(optarg, NULL, 0), '\t');
+ continue;
+
+ case 'N':