aboutsummaryrefslogtreecommitdiff
path: root/textproc/yodl
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-03-09 16:19:07 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-03-09 16:19:07 +0000
commit6b5badef77c349225e88366fcde08a4ad1ae52f8 (patch)
treec2523b655b414235957dee942a9f53d8880c9d9f /textproc/yodl
parent4f29913ec5f53c8285965ff2403db3f8f96d0a79 (diff)
downloadports-6b5badef77c349225e88366fcde08a4ad1ae52f8.tar.gz
ports-6b5badef77c349225e88366fcde08a4ad1ae52f8.zip
- Update to 2.13.2
- Take maintainership Approved by: tabthorpe
Notes
Notes: svn path=/head/; revision=229760
Diffstat (limited to 'textproc/yodl')
-rw-r--r--textproc/yodl/Makefile99
-rw-r--r--textproc/yodl/distinfo6
-rw-r--r--textproc/yodl/files/patch-build43
-rw-r--r--textproc/yodl/files/patch-src.lib.lib.h12
-rw-r--r--textproc/yodl/pkg-descr6
-rw-r--r--textproc/yodl/pkg-plist63
6 files changed, 173 insertions, 56 deletions
diff --git a/textproc/yodl/Makefile b/textproc/yodl/Makefile
index 0e75880f496f..ff9d6cc69f0e 100644
--- a/textproc/yodl/Makefile
+++ b/textproc/yodl/Makefile
@@ -6,41 +6,84 @@
#
PORTNAME= yodl
-PORTVERSION= 1.31.18
-PORTREVISION= 2
+PORTVERSION= 2.13.2
CATEGORIES= textproc
-MASTER_SITES= ftp://ftp.lilypond.org/pub/yodl/development/ \
- http://www.foad.org/zsh/zsh/ \
- http://www.zsh.org/pub/GPL/ \
- http://mirrors.sunsite.dk/ \
- http://www.math.technion.ac.il/pub/zsh/GPL/ \
- http://litterbug.lut.ac.uk/zsh/ \
- http://ftp.dmz.digex.net/pub/packages/ \
- http://linux.sarang.net/ftp/mirror/system/shell/zsh/GPL/
-
-MAINTAINER= ports@FreeBSD.org
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .orig.tar.gz
+
+MAINTAINER= pgj@FreeBSD.org
COMMENT= An easy to use but powerful document formatting/preparation language
-BUILD_DEPENDS= latex:${PORTSDIR}/print/latex \
- dvips:${PORTSDIR}/print/dvips
-RUN_DEPENDS= latex:${PORTSDIR}/print/latex \
- dvips:${PORTSDIR}/print/dvips
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ getopt:${PORTSDIR}/misc/getopt
+BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
+ bash:${PORTSDIR}/shells/bash \
+ gsed:${PORTSDIR}/textproc/gsed
+
+USE_PERL5_BUILD= yes
+
+MANCOMPRESSED= no
+MAN1= yodl.1 yodlpost.1 yodlconverters.1 yodlverbinsert.1
+MAN7= yodlmanpage.7 yodlletter.7 yodlmacros.7 yodlbuiltins.7
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-MAKEFILE= GNUmakefile
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
-MAN1= yodl.1 \
- striproff.1 \
- yodlconverters.1
-MAN7= yodlmacros.7 \
- yodlmanpage.7
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base \
+ dvips:${PORTSDIR}/print/dvipsk-tetex
+.endif
post-patch:
- @${REINPLACE_CMD} -e "s,tr '.*' '.*',tr '[:lower:]' '[:upper:]'," \
- ${WRKSRC}/src/yodl/GNUmakefile
+ @${REINPLACE_CMD} -e 's|"/usr/share/yodl"|"${PREFIX}/share/${PORTNAME}-${PORTVERSION}"| ; \
+ s|"/usr/bin"|"${PREFIX}/bin"|' \
+ ${WRKSRC}/src/config.h
+ @${REINPLACE_CMD} -e 's|"/share/yodl"|"/share/yodl-${PORTVERSION}"| ; \
+ s|"-r"|"-R"| ; \
+ s|"/share/man"|"/man"| ; \
+ s|"/share/doc"|"/share/doc/yodl-${PORTVERSION}"| ; \
+ s|"/share/doc/yodl"|"/share/doc/yodl-${PORTVERSION}"|' \
+ ${WRKSRC}/build
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake|' \
+ ${WRKSRC}/build \
+ ${WRKSRC}/src/build \
+ ${WRKSRC}/src/yodlpost/build \
+ ${WRKSRC}/src/yodl/build \
+ ${WRKSRC}/manual/build \
+ ${WRKSRC}/man/build \
+ ${WRKSRC}/macros/build
+ @${REINPLACE_CMD} -e 's|#!/bin/bash|#!${LOCALBASE}/bin/bash| ; \
+ s|sed |${LOCALBASE}/bin/gsed | ; \
+ s|getopt |${LOCALBASE}/bin/getopt |' \
+ ${WRKSRC}/src/yodl/replace \
+ ${WRKSRC}/scripts/yodl2whatever.in \
+ ${WRKSRC}/scripts/configreplacements \
+ ${WRKSRC}/macros/rawmacros/separator \
+ ${WRKSRC}/macros/rawmacros/keepdiff \
+ ${WRKSRC}/macros/rawmacros/repairs \
+ ${WRKSRC}/macros/rawmacros/startdoc \
+ ${WRKSRC}/macros/rawmacros/makeyoin \
+ ${WRKSRC}/macros/rawmacros/create
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/perl|#!${PERL}|' \
+ ${WRKSRC}/macros/rawmacros/separator.pl \
+ ${WRKSRC}/macros/rawmacros/startdoc.pl \
+ ${WRKSRC}/contrib/build.pl
+
+do-build:
+ @cd ${WRKSRC} && ./build package
+.if !defined(NOPORTDOCS)
+ @cd ${WRKSRC} && ./build doc
+.endif
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/scripts/out/striproff ${PREFIX}/bin
+do-install:
+ @cd ${WRKSRC} && ./build install ${PREFIX}
+.if !defined(NOPORTDOCS)
+ @cd ${WRKSRC} && ./build install_doc ${PREFIX}
+.endif
.include <bsd.port.mk>
diff --git a/textproc/yodl/distinfo b/textproc/yodl/distinfo
index f9c280e46ab9..3831c9969a80 100644
--- a/textproc/yodl/distinfo
+++ b/textproc/yodl/distinfo
@@ -1,3 +1,3 @@
-MD5 (yodl-1.31.18.tar.gz) = 247c5bf178baeb1f0b96511323f30a61
-SHA256 (yodl-1.31.18.tar.gz) = 84bf33b538a791cd20e329fb2d49bc59d125922bf0b5ac6ecc42dacc05c5a967
-SIZE (yodl-1.31.18.tar.gz) = 320053
+MD5 (yodl_2.13.2.orig.tar.gz) = a35444c0d8a9c7ad347e7f02084b14e6
+SHA256 (yodl_2.13.2.orig.tar.gz) = 43769a61af123e16225ab85bff0074309895f105eae344ca1dfe08b751f7ff1f
+SIZE (yodl_2.13.2.orig.tar.gz) = 700081
diff --git a/textproc/yodl/files/patch-build b/textproc/yodl/files/patch-build
new file mode 100644
index 000000000000..891021c9ab44
--- /dev/null
+++ b/textproc/yodl/files/patch-build
@@ -0,0 +1,43 @@
+--- build.orig 2007-02-12 20:01:56.000000000 +0100
++++ build 2009-03-04 19:27:30.000000000 +0100
+@@ -28,11 +28,15 @@
+ buildIn("macros", "std", ""); // and the std conversions
+
+ buildIn("manual", "docmacros", "");// macrolist for the manual
+- buildIn("manual", "manual", ""); // create the manual
+
+ buildIn("man", "man", ""); // create the manpages
+ }
+
++void doc()
++{
++ buildIn("manual", "manual", ""); // create the manual
++}
++
+ void install(string where)
+ {
+ system("mkdir -p " + where);
+@@ -40,6 +44,10 @@
+ buildIn("src", "install", where + "/bin");
+ buildIn("macros", "install", where + "/share/yodl");
+ buildIn("man", "install", where + "/share/man");
++}
++
++void install_doc(string where)
++{
+ buildIn("manual", "install", where + "/share/doc");
+
+ exec("cp", "-r",
+@@ -74,8 +82,12 @@
+ cleanup();
+ else if (arg1 == "install")
+ install(element(2, argv));
++ else if (arg1 == "install_doc")
++ install_doc(element(2, argv));
+ else if (arg1 == "package")
+ package();
++ else if (arg1 == "doc")
++ doc();
+ else
+ {
+ printf("request `", arg1, "' not yet available\n");
diff --git a/textproc/yodl/files/patch-src.lib.lib.h b/textproc/yodl/files/patch-src.lib.lib.h
deleted file mode 100644
index 7f4b9623aa64..000000000000
--- a/textproc/yodl/files/patch-src.lib.lib.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/lib/lib.h.orig Wed Jul 31 23:08:06 2002
-+++ src/lib/lib.h Wed Jul 31 23:08:35 2002
-@@ -16,7 +16,7 @@
-
- #if HAVE_MALLOC_H
- # include <malloc.h>
--#elif defined STDC_HEADERS
-+#elif defined STDC_HEADERS && !defined __FreeBSD__
- extern void free PARAMS ((char *));
- extern char *malloc PARAMS ((int));
- extern char *realloc PARAMS ((char*, int));
---- patch-src.lib.lib.h ends here ---
diff --git a/textproc/yodl/pkg-descr b/textproc/yodl/pkg-descr
index e071c54f6a14..5e7e99e5fa7e 100644
--- a/textproc/yodl/pkg-descr
+++ b/textproc/yodl/pkg-descr
@@ -1,6 +1,6 @@
-YODL - Yet Oneother Document Language, an easy to use but powerful document
-preparation language with converters for ASCII, man, latex, SGML, and HTML.
+YODL - Your Own Document Language, an easy to use but powerful document
+preparation language with converters for ASCII, man, latex, XML, and HTML.
YODL implements an easy-to-use, yet powerful document preparation language.
It also includes converters to convert documents written in that language to
-several formats, including ASCII, man page format, LaTeX, dvi, SGML, and HTML.
+several formats, including ASCII, man page format, LaTeX, dvi, XML, and HTML.
diff --git a/textproc/yodl/pkg-plist b/textproc/yodl/pkg-plist
index fe65ea77bb6c..3891da7a5094 100644
--- a/textproc/yodl/pkg-plist
+++ b/textproc/yodl/pkg-plist
@@ -1,13 +1,56 @@
+@comment $FreeBSD$
bin/yodl
-bin/yodl2whatever
-bin/yodl2dvi
-bin/yodl2manless
-bin/yodl2msless
-bin/yodl2msps
-bin/yodl2tex
bin/yodl2html
-bin/yodl2sgml
-bin/yodl2txt
+bin/yodl2latex
bin/yodl2man
-bin/yodl2ms
-bin/striproff
+bin/yodl2txt
+bin/yodl2whatever
+bin/yodl2xml
+bin/yodlpost
+bin/yodlverbinsert
+man/man1/yodl2html.1.gz
+man/man1/yodl2latex.1.gz
+man/man1/yodl2man.1.gz
+man/man1/yodl2txt.1.gz
+man/man1/yodl2whatever.1.gz
+man/man1/yodl2xml.1.gz
+share/yodl-%%PORTVERSION%%/chartables/html.tables.yo
+share/yodl-%%PORTVERSION%%/chartables/latex.tables.yo
+share/yodl-%%PORTVERSION%%/chartables/latex2.tables.yo
+share/yodl-%%PORTVERSION%%/chartables/man.tables.yo
+share/yodl-%%PORTVERSION%%/chartables/sgml.tables.yo
+share/yodl-%%PORTVERSION%%/chartables/shell.tables.yo
+share/yodl-%%PORTVERSION%%/chartables/texinfo.tables.yo
+share/yodl-%%PORTVERSION%%/chartables/txt.tables.yo
+share/yodl-%%PORTVERSION%%/chartables/xml.tables.yo
+share/yodl-%%PORTVERSION%%/xml/rug-articlebegin.xml
+share/yodl-%%PORTVERSION%%/xml/rug-articleendtitle.xml
+share/yodl-%%PORTVERSION%%/xml/rug-articlesummary.xml
+share/yodl-%%PORTVERSION%%/xml/rug-menubegin.xml
+share/yodl-%%PORTVERSION%%/xml/rug-menuend.xml
+share/yodl-%%PORTVERSION%%/xml/rug-menuendtitle.xml
+share/yodl-%%PORTVERSION%%/xml/rug-xhtmlbegin.xml
+share/yodl-%%PORTVERSION%%/xml/rug-xhtmlend.xml
+share/yodl-%%PORTVERSION%%/xml/rug-nl-articlebegin.xml
+share/yodl-%%PORTVERSION%%/xml/rug-nl-articleendtitle.xml
+share/yodl-%%PORTVERSION%%/xml/rug-nl-articlesummary.xml
+share/yodl-%%PORTVERSION%%/xml/rug-nl-menubegin.xml
+share/yodl-%%PORTVERSION%%/xml/rug-nl-menuend.xml
+share/yodl-%%PORTVERSION%%/xml/rug-nl-menuendtitle.xml
+share/yodl-%%PORTVERSION%%/xml/rug-nl-xhtmlbegin.xml
+share/yodl-%%PORTVERSION%%/xml/rug-nl-xhtmlend.xml
+share/yodl-%%PORTVERSION%%/html.yo
+share/yodl-%%PORTVERSION%%/latex.yo
+share/yodl-%%PORTVERSION%%/man.yo
+share/yodl-%%PORTVERSION%%/std.html.yo
+share/yodl-%%PORTVERSION%%/std.latex.yo
+share/yodl-%%PORTVERSION%%/std.man.yo
+share/yodl-%%PORTVERSION%%/std.txt.yo
+share/yodl-%%PORTVERSION%%/std.xml.yo
+share/yodl-%%PORTVERSION%%/txt.yo
+share/yodl-%%PORTVERSION%%/xlatin1.tex
+share/yodl-%%PORTVERSION%%/xml.yo
+share/yodl-%%PORTVERSION%%/yodlversion.yo
+@dirrm share/yodl-%%PORTVERSION%%/chartables
+@dirrm share/yodl-%%PORTVERSION%%/xml
+@dirrm share/yodl-%%PORTVERSION%%