aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-12 02:53:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-12 02:53:58 +0000
commit19d2f3c2b2388f9b1cfe4ce7a6d902a90902fb94 (patch)
tree753719af1488abbf8fcf7c5506413b41837fd48d /textproc
parent91e0c8f1a70eea46e773c869a6b98512ea431673 (diff)
downloadports-19d2f3c2b2388f9b1cfe4ce7a6d902a90902fb94.tar.gz
ports-19d2f3c2b2388f9b1cfe4ce7a6d902a90902fb94.zip
add py-feedparser 2.76
An RSS feed parser
Notes
Notes: svn path=/head/; revision=103723
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-feedparser/Makefile32
-rw-r--r--textproc/py-feedparser/distinfo2
-rw-r--r--textproc/py-feedparser/pkg-descr5
4 files changed, 40 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 474f1b63a5c4..e165b8f7da80 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -406,6 +406,7 @@
SUBDIR += py-docutils
SUBDIR += py-dsv
SUBDIR += py-expat
+ SUBDIR += py-feedparser
SUBDIR += py-jaxml
SUBDIR += py-ltxml
SUBDIR += py-martel
diff --git a/textproc/py-feedparser/Makefile b/textproc/py-feedparser/Makefile
new file mode 100644
index 000000000000..0dc56a488aff
--- /dev/null
+++ b/textproc/py-feedparser/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: feedparser
+# Date created: Mar 11, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= feedparser
+PORTVERSION= 2.76
+CATEGORIES= textproc python
+MASTER_SITES= http://diveintomark.org/projects/feed_parser/
+EXTRACT_SUFX= .py
+DISTNAME= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An RSS feed parser
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= #
+EXTRACT_AFTER_ARGS= .
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PYTHON= yes
+
+PLIST_FILES= ${PYTHON_SITELIBDIR:S,^${PREFIX}/,,}/${PORTNAME}.py
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/py-feedparser/distinfo b/textproc/py-feedparser/distinfo
new file mode 100644
index 000000000000..c089ef76796f
--- /dev/null
+++ b/textproc/py-feedparser/distinfo
@@ -0,0 +1,2 @@
+MD5 (feedparser.py) = b233c80826705aacaab5b50819b277e7
+SIZE (feedparser.py) = 57429
diff --git a/textproc/py-feedparser/pkg-descr b/textproc/py-feedparser/pkg-descr
new file mode 100644
index 000000000000..414bc24e5577
--- /dev/null
+++ b/textproc/py-feedparser/pkg-descr
@@ -0,0 +1,5 @@
+This is a "universal" feed parser, suitable for reading syndicated feeds as
+produced by weblogs, news sites, wikis, and many other types of sites. It
+handles Atom feeds, and the 9 different versions of RSS.
+
+WWW: http://diveintomark.org/projects/feed_parser/