aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /textproc
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Notes
Notes: svn path=/head/; revision=137660
Diffstat (limited to 'textproc')
-rw-r--r--textproc/cdsware/Makefile3
-rw-r--r--textproc/linux-aspell/Makefile3
-rw-r--r--textproc/linux-expat/Makefile5
-rw-r--r--textproc/linux-f10-aspell/Makefile3
-rw-r--r--textproc/linux-f10-expat/Makefile5
-rw-r--r--textproc/linux-f10-libxml/Makefile2
-rw-r--r--textproc/linux-f10-libxml2/Makefile2
-rw-r--r--textproc/linux-f8-aspell/Makefile3
-rw-r--r--textproc/linux-f8-expat/Makefile5
-rw-r--r--textproc/linux-f8-libxml/Makefile2
-rw-r--r--textproc/linux-f8-libxml2/Makefile2
-rw-r--r--textproc/linux-libxml/Makefile2
-rw-r--r--textproc/linux-libxml2/Makefile2
-rw-r--r--textproc/pocketreader/Makefile6
14 files changed, 23 insertions, 22 deletions
diff --git a/textproc/cdsware/Makefile b/textproc/cdsware/Makefile
index 806e7b685fcf..4828ab99f74c 100644
--- a/textproc/cdsware/Makefile
+++ b/textproc/cdsware/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cdsware
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= textproc www
MASTER_SITES= http://cdsware.cern.ch/download/
@@ -26,7 +27,7 @@ BROKEN= "Conflicting dependencies: apache 1.x and apache 2.x"
RUN_DEPENDS+= ${X11BASE}/bin/pdftotext:${PORTSDIR}/graphics/xpdf
. endif
. if !defined(WITHOUT_ACROREAD)
-RUN_DEPENDS+= ${LOCALBASE}/bin/acroread:${PORTSDIR}/print/acroread
+RUN_DEPENDS+= ${X11BASE}/bin/acroread5:${PORTSDIR}/print/acroread
. endif
. if !defined(WITHOUT_WV)
RUN_DEPENDS+= ${LOCALBASE}/bin/wvHtml:${PORTSDIR}/textproc/wv
diff --git a/textproc/linux-aspell/Makefile b/textproc/linux-aspell/Makefile
index f67f424cf82b..c9bff8771b4c 100644
--- a/textproc/linux-aspell/Makefile
+++ b/textproc/linux-aspell/Makefile
@@ -27,10 +27,9 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm \
NO_BUILD= yes
USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
USE_GMAKE= yes
-NO_FILTER_SHLIBS= yes
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
DBPATH= /var/lib/rpm
diff --git a/textproc/linux-expat/Makefile b/textproc/linux-expat/Makefile
index d75922d2d94b..d0998ecab7cc 100644
--- a/textproc/linux-expat/Makefile
+++ b/textproc/linux-expat/Makefile
@@ -7,14 +7,15 @@
PORTNAME= expat
PORTVERSION= 1.95.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc linux
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Linux/i386 binary port of Expat XML-parsing library
-RUN_DEPENDS= ${LINUXBASE}/sbin/ldconfig:${PORTSDIR}/emulators/linux_base-8
+RUN_DEPENDS=
+USE_LINUX= yes
BASEVERSION= 9
ONLY_FOR_ARCHS= i386 amd64
PLIST= ${WRKDIR}/plist
diff --git a/textproc/linux-f10-aspell/Makefile b/textproc/linux-f10-aspell/Makefile
index f67f424cf82b..c9bff8771b4c 100644
--- a/textproc/linux-f10-aspell/Makefile
+++ b/textproc/linux-f10-aspell/Makefile
@@ -27,10 +27,9 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm \
NO_BUILD= yes
USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
USE_GMAKE= yes
-NO_FILTER_SHLIBS= yes
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
DBPATH= /var/lib/rpm
diff --git a/textproc/linux-f10-expat/Makefile b/textproc/linux-f10-expat/Makefile
index d75922d2d94b..d0998ecab7cc 100644
--- a/textproc/linux-f10-expat/Makefile
+++ b/textproc/linux-f10-expat/Makefile
@@ -7,14 +7,15 @@
PORTNAME= expat
PORTVERSION= 1.95.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc linux
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Linux/i386 binary port of Expat XML-parsing library
-RUN_DEPENDS= ${LINUXBASE}/sbin/ldconfig:${PORTSDIR}/emulators/linux_base-8
+RUN_DEPENDS=
+USE_LINUX= yes
BASEVERSION= 9
ONLY_FOR_ARCHS= i386 amd64
PLIST= ${WRKDIR}/plist
diff --git a/textproc/linux-f10-libxml/Makefile b/textproc/linux-f10-libxml/Makefile
index c9590a2f6ffe..5e8c6f71a020 100644
--- a/textproc/linux-f10-libxml/Makefile
+++ b/textproc/linux-f10-libxml/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libxml
PORTVERSION= 1.8.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc linux
MAINTAINER= freebsd-emulation@FreeBSD.org
diff --git a/textproc/linux-f10-libxml2/Makefile b/textproc/linux-f10-libxml2/Makefile
index c9590a2f6ffe..5e8c6f71a020 100644
--- a/textproc/linux-f10-libxml2/Makefile
+++ b/textproc/linux-f10-libxml2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libxml
PORTVERSION= 1.8.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc linux
MAINTAINER= freebsd-emulation@FreeBSD.org
diff --git a/textproc/linux-f8-aspell/Makefile b/textproc/linux-f8-aspell/Makefile
index f67f424cf82b..c9bff8771b4c 100644
--- a/textproc/linux-f8-aspell/Makefile
+++ b/textproc/linux-f8-aspell/Makefile
@@ -27,10 +27,9 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm \
NO_BUILD= yes
USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
USE_GMAKE= yes
-NO_FILTER_SHLIBS= yes
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
DBPATH= /var/lib/rpm
diff --git a/textproc/linux-f8-expat/Makefile b/textproc/linux-f8-expat/Makefile
index d75922d2d94b..d0998ecab7cc 100644
--- a/textproc/linux-f8-expat/Makefile
+++ b/textproc/linux-f8-expat/Makefile
@@ -7,14 +7,15 @@
PORTNAME= expat
PORTVERSION= 1.95.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc linux
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Linux/i386 binary port of Expat XML-parsing library
-RUN_DEPENDS= ${LINUXBASE}/sbin/ldconfig:${PORTSDIR}/emulators/linux_base-8
+RUN_DEPENDS=
+USE_LINUX= yes
BASEVERSION= 9
ONLY_FOR_ARCHS= i386 amd64
PLIST= ${WRKDIR}/plist
diff --git a/textproc/linux-f8-libxml/Makefile b/textproc/linux-f8-libxml/Makefile
index c9590a2f6ffe..5e8c6f71a020 100644
--- a/textproc/linux-f8-libxml/Makefile
+++ b/textproc/linux-f8-libxml/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libxml
PORTVERSION= 1.8.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc linux
MAINTAINER= freebsd-emulation@FreeBSD.org
diff --git a/textproc/linux-f8-libxml2/Makefile b/textproc/linux-f8-libxml2/Makefile
index c9590a2f6ffe..5e8c6f71a020 100644
--- a/textproc/linux-f8-libxml2/Makefile
+++ b/textproc/linux-f8-libxml2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libxml
PORTVERSION= 1.8.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc linux
MAINTAINER= freebsd-emulation@FreeBSD.org
diff --git a/textproc/linux-libxml/Makefile b/textproc/linux-libxml/Makefile
index c9590a2f6ffe..5e8c6f71a020 100644
--- a/textproc/linux-libxml/Makefile
+++ b/textproc/linux-libxml/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libxml
PORTVERSION= 1.8.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc linux
MAINTAINER= freebsd-emulation@FreeBSD.org
diff --git a/textproc/linux-libxml2/Makefile b/textproc/linux-libxml2/Makefile
index c9590a2f6ffe..5e8c6f71a020 100644
--- a/textproc/linux-libxml2/Makefile
+++ b/textproc/linux-libxml2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libxml
PORTVERSION= 1.8.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc linux
MAINTAINER= freebsd-emulation@FreeBSD.org
diff --git a/textproc/pocketreader/Makefile b/textproc/pocketreader/Makefile
index df639a333b80..b72fb2e0c22f 100644
--- a/textproc/pocketreader/Makefile
+++ b/textproc/pocketreader/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pocketreader
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc linux
MASTER_SITES= http://www.pocketreader.com/download/software/
DISTNAME= linux-bin
@@ -16,14 +16,14 @@ EXTRACT_SUFX= _tar.gz
MAINTAINER= simond@irrelevant.org
COMMENT= Siemens PocketReader
-USE_LINUX?= YES
+USE_LINUX= YES
NO_BUILD= YES
PLIST_FILES= bin/pocketreader
WRKSRC= ${WRKDIR}/linux
do-install:
- brandelf -t Linux ${WRKSRC}/installfiles/pocketreader_static
+ ${BRANDELF} -t Linux ${WRKSRC}/installfiles/pocketreader_static
${CP} ${WRKSRC}/installfiles/pocketreader_static ${PREFIX}/bin/pocketreader
.include <bsd.port.mk>