aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-09 19:42:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-09 19:42:46 +0000
commit30a00f2227a3e53b607331247c81c2911c1e98ef (patch)
treeb3bdcd25b598432ef78aefb0f72e9412f429eee4 /textproc
parentfc3bdd2b5bc1f418653dc07e3f7734890f957654 (diff)
downloadports-30a00f2227a3e53b607331247c81c2911c1e98ef.tar.gz
ports-30a00f2227a3e53b607331247c81c2911c1e98ef.zip
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like "CC foo.c"). CMake and ninja enable this by default, some autotools using ports do as well. This is unacceptable because we need complete build logs at any time, so we now switch to verbose build logs unconditionally. Note that this change deliberately affects ALL builds and not only package builds on cluster, because we need to be sure that user experiencing failure can always provide informative build log regardless of settings and without rerunning the build. Change summary: - Always do verbose builds for cmake, ninja and GNU configure (the latter includes check if --disable-silent-rules is actually supported by the configure script; there are isolated cases when it's not true) - Remove CMAKE_VERBOSE, NINJA_VERBOSE and CONFIGURE_ARGS=--disable-silent-rules from all ports which set them for this is no longer needed - Revert hacks for --disable-silent-rules support priorly committed to biology/ncbi-blast+ and net-p2p/mldonkey - no longer needed as well Submitted by: amdmi3 Reviewed by: mat Exp-run by: antoine Approved by: portmgr (mat, antoine) Differential Revision: D7534
Notes
Notes: svn path=/head/; revision=421635
Diffstat (limited to 'textproc')
-rw-r--r--textproc/google-ctemplate/Makefile1
-rw-r--r--textproc/groonga/Makefile1
-rw-r--r--textproc/libucl/Makefile1
-rw-r--r--textproc/uncrustify/Makefile1
-rw-r--r--textproc/xmlwrapp/Makefile1
-rw-r--r--textproc/zorba/Makefile3
6 files changed, 1 insertions, 7 deletions
diff --git a/textproc/google-ctemplate/Makefile b/textproc/google-ctemplate/Makefile
index aea95159f7e9..b250e02b3c28 100644
--- a/textproc/google-ctemplate/Makefile
+++ b/textproc/google-ctemplate/Makefile
@@ -17,7 +17,6 @@ OPTIONS_DEFINE= DOCS
USES= libtool pathfix pkgconfig python shebangfix
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules
SHEBANG_FILES= src/template-converter src/htmlparser/generate_fsm.py src/htmlparser/fsm_config.py
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/textproc/groonga/Makefile b/textproc/groonga/Makefile
index b9a85b3bb302..8cb3e35fa004 100644
--- a/textproc/groonga/Makefile
+++ b/textproc/groonga/Makefile
@@ -16,7 +16,6 @@ USES= execinfo gmake libedit libtool pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-benchmark \
--disable-document \
- --disable-silent-rules \
--localstatedir=/var \
--without-cutter \
--without-inkscape \
diff --git a/textproc/libucl/Makefile b/textproc/libucl/Makefile
index 8d929ea6c9f6..a8e7ed95c90e 100644
--- a/textproc/libucl/Makefile
+++ b/textproc/libucl/Makefile
@@ -41,7 +41,6 @@ USE_GITHUB= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --disable-silent-rules
GH_ACCOUNT= vstakhov
diff --git a/textproc/uncrustify/Makefile b/textproc/uncrustify/Makefile
index e668a9bdef8f..46615c6fe567 100644
--- a/textproc/uncrustify/Makefile
+++ b/textproc/uncrustify/Makefile
@@ -14,7 +14,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
USES= gmake
-CONFIGURE_ARGS= --disable-silent-rules
TEST_TARGET= check
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index a3f31446909e..7ea36f73e6a7 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -27,7 +27,6 @@ XSLT_CONFIGURE_ENABLE= xslt
USES= pathfix pkgconfig libtool
USE_GNOME= libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index 8889dd265586..b28226fb6ea7 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -41,8 +41,7 @@ USES= cmake:outsource compiler:c++11-lib execinfo
CXXFLAGS+= -I${LOCALBASE}/include -O1 # compiler hangs with -O2 on CURRENT
LDFLAGS+= -L${LOCALBASE}/lib
CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
- -DLOCALBASE:STRING=${LOCALBASE} \
- -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
+ -DLOCALBASE:STRING=${LOCALBASE}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}