aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-08-28 20:57:44 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-08-30 10:36:49 +0000
commit3e0e47becc96fd33151c453fb9927b431723aa58 (patch)
tree877625b79ae7f5e532aa4925f572882707f4943d /textproc
parent9f5b792c9ebb6879739688fcb47dc74afde43420 (diff)
downloadports-3e0e47becc96fd33151c453fb9927b431723aa58.tar.gz
ports-3e0e47becc96fd33151c453fb9927b431723aa58.zip
textproc/kdiff3: update to latest release, 1.9.3
There do not seem to be release notes. Looking at commits, there is a handful of bug-fixes (including one to deal with the bug we previously had patched in ports).
Diffstat (limited to 'textproc')
-rw-r--r--textproc/kdiff3/Makefile9
-rw-r--r--textproc/kdiff3/distinfo6
-rw-r--r--textproc/kdiff3/files/patch-src_mergeresultwindow.cpp50
3 files changed, 7 insertions, 58 deletions
diff --git a/textproc/kdiff3/Makefile b/textproc/kdiff3/Makefile
index 2bd43a3078f0..33f59e9d3881 100644
--- a/textproc/kdiff3/Makefile
+++ b/textproc/kdiff3/Makefile
@@ -1,6 +1,5 @@
PORTNAME= kdiff3
-DISTVERSION= 1.9.2
-PORTREVISION= 2
+DISTVERSION= 1.9.3
CATEGORIES= textproc kde
MASTER_SITES= KDE/stable/${PORTNAME}
@@ -14,10 +13,10 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/range/algorithm.hpp:devel/boost-libs
USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
- coreaddons crash ecm i18n iconthemes jobwidgets kio \
- parts service sonnet textwidgets widgetsaddons windowsystem \
+ coreaddons crash i18n iconthemes jobwidgets kio \
+ parts service solid sonnet textwidgets widgetsaddons windowsystem \
xmlgui \
- doctools_build
+ doctools_build ecm_build
USE_QT= concurrent core dbus gui network printsupport widgets xml \
buildtools_build qmake_build
diff --git a/textproc/kdiff3/distinfo b/textproc/kdiff3/distinfo
index 5ae5dc3e8ac5..d4dab6cae027 100644
--- a/textproc/kdiff3/distinfo
+++ b/textproc/kdiff3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1621514687
-SHA256 (kdiff3-1.9.2.tar.xz) = f1775f1ca501080363707b2923d493fc314ae4f0b00b172d4cad9b4d3cc2d805
-SIZE (kdiff3-1.9.2.tar.xz) = 1053404
+TIMESTAMP = 1630183188
+SHA256 (kdiff3-1.9.3.tar.xz) = 317bf5c7e27cba81bce7e1a7a579105443133b633cbb71bc1f169e86a235af9c
+SIZE (kdiff3-1.9.3.tar.xz) = 1056920
diff --git a/textproc/kdiff3/files/patch-src_mergeresultwindow.cpp b/textproc/kdiff3/files/patch-src_mergeresultwindow.cpp
deleted file mode 100644
index 508fc50cc56f..000000000000
--- a/textproc/kdiff3/files/patch-src_mergeresultwindow.cpp
+++ /dev/null
@@ -1,50 +0,0 @@
-See https://invent.kde.org/sdk/kdiff3/-/merge_requests/31
-
-When writing out files, don't treat removed lines as real lines,
-and append a newline to the whole output file.
---- src/mergeresultwindow.cpp.orig 2021-05-17 17:26:58 UTC
-+++ src/mergeresultwindow.cpp
-@@ -2964,6 +2964,9 @@ bool MergeResultWindow::saveDocument(const QString& fi
- textOutStream.setGenerateByteOrderMark(true); // Only for UTF-16
- textOutStream.setCodec(pEncoding);
-
-+ // Determine the line feed for this file
-+ const QString lineFeed(eLineEndStyle == eLineEndStyleDos ? QString("\r\n") : QString("\n"));
-+
- int line = 0;
- MergeLineList::iterator mlIt = m_mergeLineList.begin();
- for(mlIt = m_mergeLineList.begin(); mlIt != m_mergeLineList.end(); ++mlIt)
-@@ -2976,18 +2979,14 @@ bool MergeResultWindow::saveDocument(const QString& fi
-
- if(mel.isEditableText())
- {
-- QString str = mel.getString(m_pldA, m_pldB, m_pldC);
-+ const QString str = mel.getString(m_pldA, m_pldB, m_pldC);
-
-- if(line > 0) // Prepend line feed, but not for first line
-+ if(line > 0 && !mel.isRemoved())
- {
-- if(eLineEndStyle == eLineEndStyleDos)
-- {
-- str.prepend("\r\n");
-- }
-- else
-- {
-- str.prepend("\n");
-- }
-+ // Put line feed between lines, but not for the first line
-+ // or between lines that have been removed (because there
-+ // isn't a line there).
-+ textOutStream << lineFeed;
- }
-
- textOutStream << str;
-@@ -2995,6 +2994,8 @@ bool MergeResultWindow::saveDocument(const QString& fi
- }
- }
- }
-+ // At the end of the stream, needs a newline
-+ textOutStream << lineFeed;
- textOutStream.flush();
- bool bSuccess = file.writeFile(dataArray.data(), dataArray.size());
- if(!bSuccess)