aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-10-08 14:10:21 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-10-08 14:10:21 +0000
commit4173c41acee38ae91c2aa218e4be1d5b6d1d453a (patch)
treec9fe420f670fe2f8036cde14a2b7f9fde5bcca50 /textproc
parente02f07d6df38e4d265050dbc9c6410a0e7c84f34 (diff)
downloadports-4173c41acee38ae91c2aa218e4be1d5b6d1d453a.tar.gz
ports-4173c41acee38ae91c2aa218e4be1d5b6d1d453a.zip
Add p5-Search-Saryer, a Perl interface to the Sary library.
Notes
Notes: svn path=/head/; revision=67641
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Search-Saryer/Makefile24
-rw-r--r--textproc/p5-Search-Saryer/distinfo1
-rw-r--r--textproc/p5-Search-Saryer/files/patch-Saryer.pm24
-rw-r--r--textproc/p5-Search-Saryer/pkg-comment1
-rw-r--r--textproc/p5-Search-Saryer/pkg-descr3
-rw-r--r--textproc/p5-Search-Saryer/pkg-plist7
7 files changed, 61 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6c4b62740e40..14e3c7fad567 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -178,6 +178,7 @@
SUBDIR += p5-RDFStore
SUBDIR += p5-Regexp-Common
SUBDIR += p5-SVG
+ SUBDIR += p5-Search-Saryer
SUBDIR += p5-Sort-ArbBiLex
SUBDIR += p5-Sort-Fields
SUBDIR += p5-Sort-PolySort
diff --git a/textproc/p5-Search-Saryer/Makefile b/textproc/p5-Search-Saryer/Makefile
new file mode 100644
index 000000000000..ab9153b9220c
--- /dev/null
+++ b/textproc/p5-Search-Saryer/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Search::Saryer
+# Date created: 8 October 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Search-Saryer
+PORTVERSION= 0.10
+CATEGORIES= textproc perl5
+MASTER_SITES= ftp://ftp.namazu.org/sary/perl/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= sary.8:${PORTSDIR}/textproc/sary
+
+PERL_CONFIGURE= yes
+
+MAN3= Search::Saryer.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Search-Saryer/distinfo b/textproc/p5-Search-Saryer/distinfo
new file mode 100644
index 000000000000..3c68fe7df808
--- /dev/null
+++ b/textproc/p5-Search-Saryer/distinfo
@@ -0,0 +1 @@
+MD5 (Search-Saryer-0.10.tar.gz) = 7a075732bdcfe36c72481b9d6b36f03f
diff --git a/textproc/p5-Search-Saryer/files/patch-Saryer.pm b/textproc/p5-Search-Saryer/files/patch-Saryer.pm
new file mode 100644
index 000000000000..192adc8e51f5
--- /dev/null
+++ b/textproc/p5-Search-Saryer/files/patch-Saryer.pm
@@ -0,0 +1,24 @@
+--- Saryer.pm.orig Mon Dec 18 14:10:08 2000
++++ Saryer.pm Tue Oct 8 23:04:36 2002
+@@ -13,10 +13,10 @@
+
+ =head1 SYNOPSIS
+
+- my $saryer = Search::Saryer::new(filename->'search.txt');
++ my $saryer = Search::Saryer::new(filename=>'search.txt');
+
+ if (defined $saryer->search($pattern)) {
+- while (defined ($line = saryer->get_next_line())) {
++ while (defined ($line = $saryer->get_next_line())) {
+ print $line;
+ }
+ }
+@@ -27,7 +27,7 @@
+
+ =head2 new
+
+- $saryer->new('filename'->'file.txt')
++ $saryer->new('filename'=>'file.txt')
+
+ Create saryer object.
+ If creation process was failed, it returns undef.
diff --git a/textproc/p5-Search-Saryer/pkg-comment b/textproc/p5-Search-Saryer/pkg-comment
new file mode 100644
index 000000000000..505ea7d7ffed
--- /dev/null
+++ b/textproc/p5-Search-Saryer/pkg-comment
@@ -0,0 +1 @@
+Perl interface to the Sary library
diff --git a/textproc/p5-Search-Saryer/pkg-descr b/textproc/p5-Search-Saryer/pkg-descr
new file mode 100644
index 000000000000..d1d621026baa
--- /dev/null
+++ b/textproc/p5-Search-Saryer/pkg-descr
@@ -0,0 +1,3 @@
+This module is a Perl interface to the Sary library.
+
+WWW: http://sary.namazu.org/index.html.en
diff --git a/textproc/p5-Search-Saryer/pkg-plist b/textproc/p5-Search-Saryer/pkg-plist
new file mode 100644
index 000000000000..ec769ceb739d
--- /dev/null
+++ b/textproc/p5-Search-Saryer/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Search/Saryer.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Search/Saryer/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Search/Saryer/Saryer.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Search/Saryer/Saryer.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Search/Saryer
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Search 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Search 2>/dev/null || true