aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-10 16:20:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-10 16:20:02 +0000
commit68a5ec56cacb81d03e95c7a2b293bab6567df6ef (patch)
tree13ee22c2a35349c3b4ccf2f20771244b1bd5b260 /textproc
parent927ebf7e811f9000091aad00ee3dd337501844ab (diff)
downloadports-68a5ec56cacb81d03e95c7a2b293bab6567df6ef.tar.gz
ports-68a5ec56cacb81d03e95c7a2b293bab6567df6ef.zip
- Fix build when several db* are installed
- Really disable mysql support when WITH_MYSQL is not defined - Disable sqlite - Bump PORTREVISION PR: 126410 Submitted by: Max Brazhnikov <makc@issp.ac.ru> (with discussion on freenode/#kde-freebsd) Approved by: maintainer
Notes
Notes: svn path=/head/; revision=218345
Diffstat (limited to 'textproc')
-rw-r--r--textproc/rasqal/Makefile6
-rw-r--r--textproc/redland/Makefile6
2 files changed, 10 insertions, 2 deletions
diff --git a/textproc/rasqal/Makefile b/textproc/rasqal/Makefile
index 4f52d223fec1..0c28c68e0f79 100644
--- a/textproc/rasqal/Makefile
+++ b/textproc/rasqal/Makefile
@@ -8,6 +8,7 @@
PORTNAME= redland
PORTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://librdf.org/dist/source/
@@ -19,6 +20,7 @@ COMMENT= A high-level interface for RDF
LIB_DEPENDS= raptor.2:${PORTSDIR}/textproc/raptor
USE_BDB= yes
+WITH_BDB_HIGHEST= yes
INVALID_BDB_VER=2
USE_GNOME= gnomehack gnometarget lthack pkgconfig
USE_OPENSSL= yes
@@ -30,7 +32,8 @@ LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-raptor=system \
--with-rasqal=internal \
- --with-threestore=no
+ --with-threestore=no \
+ --with-sqlite=no
USE_LDCONFIG= yes
USE_PERL5_BUILD= yes
@@ -48,6 +51,7 @@ USE_MYSQL= yes
CONFIGURE_ARGS+=--with-mysql=yes
PLIST_SUB+= MYSQL=""
.else
+CONFIGURE_ARGS+=--with-mysql=no
PLIST_SUB+= MYSQL="@comment "
.endif
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index 4f52d223fec1..0c28c68e0f79 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -8,6 +8,7 @@
PORTNAME= redland
PORTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://librdf.org/dist/source/
@@ -19,6 +20,7 @@ COMMENT= A high-level interface for RDF
LIB_DEPENDS= raptor.2:${PORTSDIR}/textproc/raptor
USE_BDB= yes
+WITH_BDB_HIGHEST= yes
INVALID_BDB_VER=2
USE_GNOME= gnomehack gnometarget lthack pkgconfig
USE_OPENSSL= yes
@@ -30,7 +32,8 @@ LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-raptor=system \
--with-rasqal=internal \
- --with-threestore=no
+ --with-threestore=no \
+ --with-sqlite=no
USE_LDCONFIG= yes
USE_PERL5_BUILD= yes
@@ -48,6 +51,7 @@ USE_MYSQL= yes
CONFIGURE_ARGS+=--with-mysql=yes
PLIST_SUB+= MYSQL=""
.else
+CONFIGURE_ARGS+=--with-mysql=no
PLIST_SUB+= MYSQL="@comment "
.endif