aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2015-03-17 15:01:15 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2015-03-17 15:01:15 +0000
commit8e417acfeab5d0b74762c75c1c5d84c43332b4d2 (patch)
treebe8facc9bceee97316015c316ab726fca7b08d17 /textproc
parentd1454d6e66416368e6f79b7853deaa270b761761 (diff)
downloadports-8e417acfeab5d0b74762c75c1c5d84c43332b4d2.tar.gz
ports-8e417acfeab5d0b74762c75c1c5d84c43332b4d2.zip
Net::Groonga::HTTP is a client library for Groonga http server.
Groonga is a fast full text search engine. Please look http://groonga.org/. WWW: http://search.cpan.org/dist/Net-Groonga-HTTP/
Notes
Notes: svn path=/head/; revision=381493
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Net-Groonga-HTTP/Makefile27
-rw-r--r--textproc/p5-Net-Groonga-HTTP/distinfo2
-rw-r--r--textproc/p5-Net-Groonga-HTTP/pkg-descr6
-rw-r--r--textproc/p5-Net-Groonga-HTTP/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6b9112eac8a4..b2dbe06bb2ea 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -612,6 +612,7 @@
SUBDIR += p5-Markapl
SUBDIR += p5-Marpa-HTML
SUBDIR += p5-MathML-Entities
+ SUBDIR += p5-Net-Groonga-HTTP
SUBDIR += p5-Net-IDN-Encode
SUBDIR += p5-Net-Snort-Parser
SUBDIR += p5-Net-YASA
diff --git a/textproc/p5-Net-Groonga-HTTP/Makefile b/textproc/p5-Net-Groonga-HTTP/Makefile
new file mode 100644
index 000000000000..16ae04f24c99
--- /dev/null
+++ b/textproc/p5-Net-Groonga-HTTP/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= Net-Groonga-HTTP
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for Groonga httpd client library
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= \
+ p5-Data-Page>0:${PORTSDIR}/databases/p5-Data-Page \
+ p5-Furl>0:${PORTSDIR}/www/p5-Furl \
+ p5-JSON-XS>0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-Mouse>0:${PORTSDIR}/devel/p5-Mouse \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= modbuild
+NO_ARCH= YES
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Net-Groonga-HTTP/distinfo b/textproc/p5-Net-Groonga-HTTP/distinfo
new file mode 100644
index 000000000000..2a5134b1929e
--- /dev/null
+++ b/textproc/p5-Net-Groonga-HTTP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Groonga-HTTP-0.03.tar.gz) = 4b462a8d3cb5732f08b0603c93b888a7f29427257d6bc191e7cf78776d0464a6
+SIZE (Net-Groonga-HTTP-0.03.tar.gz) = 12343
diff --git a/textproc/p5-Net-Groonga-HTTP/pkg-descr b/textproc/p5-Net-Groonga-HTTP/pkg-descr
new file mode 100644
index 000000000000..39dce939eb01
--- /dev/null
+++ b/textproc/p5-Net-Groonga-HTTP/pkg-descr
@@ -0,0 +1,6 @@
+Net::Groonga::HTTP is a client library for Groonga http server.
+
+Groonga is a fast full text search engine. Please look
+http://groonga.org/.
+
+WWW: http://search.cpan.org/dist/Net-Groonga-HTTP/
diff --git a/textproc/p5-Net-Groonga-HTTP/pkg-plist b/textproc/p5-Net-Groonga-HTTP/pkg-plist
new file mode 100644
index 000000000000..ba51b284f419
--- /dev/null
+++ b/textproc/p5-Net-Groonga-HTTP/pkg-plist
@@ -0,0 +1,6 @@
+%%PERL5_MAN3%%/Net::Groonga::HTTP.3.gz
+%%PERL5_MAN3%%/Net::Groonga::HTTP::Response.3.gz
+%%PERL5_MAN3%%/Net::Groonga::Pager.3.gz
+%%SITE_PERL%%/Net/Groonga/HTTP.pm
+%%SITE_PERL%%/Net/Groonga/HTTP/Response.pm
+%%SITE_PERL%%/Net/Groonga/Pager.pm